Question about Mercury Villager

1 Answer

My mercury villager starts and drives but the second it starts to warm up a little it runs really rough and then dies

I replaced plugs,rotter butten,distrebuter cap,the cat,and still can't figure it out please help

Posted by on

1 Answer

I would do a cylinder leak down test

Start with the mechanical integrety first.

Is the exhaust converter 12 years old & blocked?

Gas filter how old,more than 3 or 4 years

Check fuel pressure at motor

New O2 Sensors at 100,000 miles

Thermostat working

PCV System?

Vacuum Leaks?

Posted on Dec 04, 2012

  • 3 more comments 
  • mike Dec 04, 2012

    i cut the cat off cause thats what i thought it was.no vacume leaks.i changed the fuel filter two months ago but it ran out of gas shortly after.and thats when all my prombloms started.you think that could be the problom?

  • Anonymous Dec 04, 2012

    Running out of gas ruined the fuel pump. Need fuel to keep it cool Can not use any vehicle without the converter & O2 Sensors you have no fuel control in closed loop when hot

  • mike Dec 04, 2012

    well see thats the thing i can hear the fuel pump kick on and it runs good when temp gauge reading cold but when it starts getting on the normal line thats when it starts acting up real bad.and i put a piece of flex pipe were the cat was so its going thru the o2 sencor.

  • Anonymous Dec 04, 2012

    Read what I wrote above. You have no fuel control at all without the o2 sensors. You removed all the required parts needed to use the vehicle

  • Anonymous Dec 04, 2012

    It is against Federal Laws to remove the exhaust converter

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When idling at a standstill engine seems to run rough and seem like it will die but it doesn't. When driving there is a noticeable lagging feel to the drive as if the timing were slightly retarded. Like it...


Sounds like a misfire in a cylinder. Check plugs for carbon build up. If carbon on plug, there's a good chance that you will need to replace the fuel injector. Start with checking plugs and then O2 sensor(s). This is steps beyond typical tune-up check. It's especially helpful if you can get a code. AutoZone and KwikLube will run diagnostics for free.

Mar 18, 2011 | 1998 Mercury Villager

1 Answer

1998 Mercury Grand Marquis GS runs Rough when cold


I have the same problem and can
Not figure it out did u have any luck?

Feb 02, 2010 | 1998 Mercury Mystique

1 Answer

Mine has 217,000 miles. Has run great up until some time ago, when it started driving roughly only in wet weather. Now in dry weather, it starts fine, but drives roughly after warmed up (15-20 min) and...


The knock sensor NEVER causes a drivability problem. DO NOT change it. Instead, clean the MAF, Mass Air Flow sesnor that's on the air intake tube near air cleaner. It is coated with varnish. Spray with carb cleaner several times and gently, gently brush the wires. Theya re glass coated. Be careful.

Then disconnect battery for 2 hours and then reconnect and drive for 0 miles for computer to relearn engine contrils.

Also go here for more help
http://groups.yahoo.com/group/villagerquest/

Dec 27, 2009 | 2000 Mercury Villager

1 Answer

Car running rough when raining


check the spark plug wires, put water in a spray bottle and spray along the wires,especially by the coil,if the car starts to run bad or you see sparks, the wires are no good, hope this helps, Ray

Apr 03, 2009 | 1999 Mercury Villager

1 Answer

1996 Mercury Villager with idle problems


Make sure there is no vacuumm leak.
Check and let me know.Then i would be able to tell you all the steps for troubleshooting.
Thanks.

Mar 30, 2009 | 1999 Mercury Villager

4 Answers

When car is cold it seemingly runs on 3 cylinders


seem like you got the same problem as my scion xa, check the fuel pressure regulater. bad regulater some time smell like leak gas. auto zone might cause you about $80.00.

Feb 09, 2009 | 1992 Honda Accord

2 Answers

1993 Mercury Villager won't start


Glad I could help, sounds like your figured it out on your on,

Dec 16, 2008 | 1993 Mercury Villager

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

fordexpert

Level 3 Expert

5501 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...