Question about Cars & Trucks

1 Answer

Montero sport 99 new crank sensor,new cam sensor,fuel pump ok,new spark plugs and wires,but no power in the spark plugs.

My Montero sport 99 is not getting spark,what could be the problem. The coils or the ignition module? what else could cause this problem.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Greenhorn:

    A rookie expert who has answered 20 questions on their first day.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Contributor
  • 31 Answers

Check your distributor cap

Posted on Dec 02, 2012

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: 96 jeep grand cherokee 4.0

change the computer .... PCM get a used one it fixed mine had same problem

Posted on Feb 19, 2009

sledge1863
  • 149 Answers

SOURCE: 1995 lumina cranks but will not start

Sounds like it has jumped timing, dont know which engine you have so could be chain or belt.

Posted on Mar 23, 2009

dttech
  • 4803 Answers

SOURCE: I have a 93 mercury topaz 4cyl 2.3L that stalls

It sounds to me like you replaced everything but the most likely cause of a stall while driving...The crank sensor.

Posted on Oct 11, 2009

  • 2 Answers

SOURCE: 1997 Dodge Intrepid cranks over won't fire

I have this same NO START problem...
Began with tach giving readings not exceding 1200 rpm with strange 4000 + spikes.. Cruse control would not turn on or off at times and indicator light would only work sometimes..Had several episodes of excessive cranking to get it to start.. Stalling out while driving and even at freeway speeds.. Pulling the negative cable for 10 min. allowed it to start although with lots of cranking and put it in limp mode which required another computer reset to get out of.. Had thrown error codes related to cam and crank sensors which were replaced along with coil and manifold temp sensors.. Had the 9 volt power to sensors when key was on but the check engine light does not stay on with all the other idiot lights..
I wish people who respond would read the post first..
Original post states,
Cranks,No spark,No fuel pump run, changed some sensors ect...
If it cranks it ain't the neutral safety switch, starter or battery!! WAKE UP!!
Seems the computer is not turning on the coil, injectors or fuel pump for a reason.. Find that reason and you will find the solution to the problem.. Seeing as that the computers logic states are a dealer secrete the poster as I have changed many parts in blind hope that it will fix the problem.. Relays, sensors and ecu computer.. Did a visual check of all harness potential wear spots like where it crosses over the power rack..
Could it be in the wiring harness inside the dash??
Could it be a bad ground??
Can an alternator that has failed cause the computer not to start??
Can a bad oil pressure sensor cause the computer not to start??
Can signal loss from the TCU or BCU to the ECU cause this??
Is there an undocumented kill if the ECU thinks it was in an accident??
I can ground the relay line from the ECU and the fuel pump runs and pressures up and the other relays turn on as well..
This crank but no start problem seems to be common with a lot of 1994-2001 Dodge and Chrysler owners.. All these systems have become interlaced with undocumented safety features that baffle the DIYer..If you have seen this and have fixed it PLEASE RESPOND!!!!

Posted on May 02, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 Mitsubishi montero sport xls replaced crankshaft sensor still will not crank


Test fuel pressure at key on. Next test for spark to plugs. Use "noid" light to test for injector pulse.

Jul 03, 2016 | 2001 Mitsubishi Montero

1 Answer

2002 Mitsubishi Montero Sport (won't not 'want') start. Replaced the starter and fuel pump. Filter still not getting gas to the cylinders


If you already replaced fuel pump and filter and still no fuel pressure at injectors rail, your problem is more than likely electrical. Check for good power and ground at fuel pump connector. If no power at fuel pump connector, check your fuel pump fuse, relay and wiring for opens(broken) feed wire.

Feb 07, 2016 | 2002 Mitsubishi Montero Sport

1 Answer

How to wire up an ignition on a 1999 mitisubishi Montero sport


PDF]MITSUBISHI MONTERO SPORT 1997-2004 VEHICLE ...

alarmsellout.com/.../MITSUBISHI%20MONTERO%20SPORT%201997-...
WIRING INFORMATION: 1997 Mitsubishi Montero Sport. WIRE ... WHITE. IgnitionHarness. STARTER WIRE ... This must be bypassed when installing a remote start system. ... WIRING INFORMATION: 1999 Mitsubishi Montero Sport. WIRE.

Montero Sport Starting Problem - YouTube

? 2:35
https://www.youtube.com/watch?v=TZCbEmfi3JM
Nov 2, 2011 - Uploaded by aaron1969lopez
Im not sure what is causing me to have trouble starting myMontero Sport. ... 2001 Mitsubishi Montero Sport ...

1997-2004 3.0L V6 Firing Order -Ignition Coil Spark Plug ...



Dec 08, 2015 | Cars & Trucks

2 Answers

I have a 2001 montero sport es 3.0. It wouldn't start one morning. This happened b4 and I went back next day, unplugged the maf sensor and it started, rough, but ran.. I plugged in maf and it ran


Did that work this time? Did you get a "check engine" light? Get the code read?

Unfortunately, "won't start" can be caused by so many different things we really can't begin to help you with what you've said.

Nov 16, 2015 | Cars & Trucks

2 Answers

Montero Sport 99 crank but no start,what could be the problem?


when you turn the key to the start position do you hear the fuel pump

Dec 02, 2012 | Cars & Trucks

1 Answer

I have a 98 Montero Sport with low rpm engine stalls...


spark plug cable is lose or one spark plug is faulty.

Jan 24, 2010 | 1998 Mitsubishi Montero Sport

2 Answers

1996 Mitsubishi Montero has no power..


My 96 Pajero SWB 3.0 would loose power as soon as i accelerate. It feels like the spark plugs are miss firing or if the engine was flooded.

I did a general service which included oil change, oil filter, fuel filter, air filter, spark plugs i checked my O2 sensor, dissembled and cleaned throttle body and sensors. Cleaned air intake sensor as well as the distributer etc.

Problem not solved, still loose power when i accelerate....can it be something wrong with my ECU??

My A/C control isnt working at all. Found a 15Amp fuse that was blown but when replaced it shorts again. Where can i get a wiring diagram of the heater/a/c system for my vehicle model?

May 28, 2009 | 1996 Mitsubishi Montero Sport

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

165 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...