Question about 1993 Toyota Land Cruiser

2 Answers

Speedo will not work with new sensor fitted

Speedo hasn't worked for some time, was told it was the sensor on gear box. At the onset of problem the speedo would work intermitently and then died. Is there a seperate fuse for the speedo or is it run of the main power fuse. Could you help please.

Regards
Shayne.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If you haven't installed or bought a new sensor, then have an auto electrucian checkout the ols sensor first, the check for this is really simple and is listed in the 80 series manual. if the sensor is faulty then buy a new one if the sensor is ok then you have to check the integrity of the electric connection (wiring) to the instrument then if that is ok then check the instrument, for the previous solution suggested- There is no Bloody speedo cable as in a turning one only electrical.

Posted on Feb 28, 2009

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 22 Answers

If you can try take off the dash and remove the dash unit and check to see if the speedo cable is attatched properly

Posted on Jan 10, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

95 buick regal custom speedo issues


There is a gear that drives the sensor gear much like the old speedo cable gear.
If you connected the sensor and the check engine light went off, chances are the sensor is working.

Jul 04, 2013 | Cars & Trucks

1 Answer

1995 trooper transmission light blinks when shift to drive


does the speed change at all? does the speedometer if you noticed is working? if the speedo is not working then the problem is your speed sensor on the gear box is not working and that is the reason the automatic transmission stayed on safe mode. renew the speedo and will work ok.

Sep 03, 2012 | 1995 Isuzu Trooper

2 Answers

I changed the standard single drive rearend gears to a 410 posi on my 92 Camaro RS and the speedometer is now swinging up and down not working properley. I've been told to replace the sensor. Is this the...


Sensor most likely. It's located on the tailshaft of the 700. You might check for wiring damage starting at the sensor and working towards the wiring bundle it goes to.

Apr 10, 2011 | Chevrolet Camaro Cars & Trucks

1 Answer

Speedometer works then stops working


Chances are the nylon speedo drive wheel has worn and occasionaly catches gears the works and then misses and doesnt work. follow the speedo cable down to the gearbox where the cable fits into the box undo and pull the drive out and check the shape and condition of the gearing teeth, if the shape is like an hour glass with smoothed off teeth this is likely to be the problem. You may also have gearbox issues causing this wear.

Sep 07, 2009 | 1994 Honda Civic

2 Answers

My speedometer works sometimes and sometimes it doesnt but the heat one works and gas one works what is causing this?


hi every car has a speedo meter cable in tat a worm gear attached in the wheel so i case of fails the speedo meter works some time and nt work . so u hav to change the speedo meter warm gear

Aug 25, 2009 | 1998 Dodge Neon

1 Answer

Speedo problem


Just fit a new speed sensor on the gearbox.Its location is on the output shaft side of the box.Thats your problem a faulty switch.Good luck pippall

Aug 08, 2009 | 2000 Ford Focus

1 Answer

Won't shift out of first gear


good diagnosis that is correct if the vehicle speed sensor is not working the speedo doesnt work and the trans doesnt know when to shift

Jul 17, 2009 | 1998 Ford Windstar

1 Answer

No gear at all


take ur gear box of and chech wear ur speedo plug is and if ur car run before ur plug got lost then yh thats ur proplem

Mar 04, 2009 | 1991 Mazda 626

Not finding what you are looking for?
1993 Toyota Land Cruiser Logo

657 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6864 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...