Question about 1995 Ford Explorer

1 Answer

Hi i have a 95 explorer and it will idle fine for awhile then it starts idling rough but if i hit the gas a few times alittle hard it will idle good again but after a minute it will idle rough again p

Just bought truck and put new plugs, wires air filter in it i also sprayed carb cleaner in throttle body and hope it didnt screw up any senser's the check engine light is not on but not sure it works again i just bought it but did not run like this before i did tuneup it will idle great for a bit but start lobeing then if i nail it a few times it will run smooth it only has 95000 on it

Posted by on

Ad

1 Answer

Check over your work--- you put the problem in it

Did you not make a diagram of the wires before you
removed them & mark the ends of the new ones?

Have to also know the firing order before you start
any job.

Did you gap the plugs correctly

Posted on Nov 28, 2012

  • tracy poore Nov 28, 2012

    yes i gaped plugs and did one wire at a time like i said it runs great for a bit and then starts to run rough and hit the gas a few ggod times and will run great but after a bit does same thing again if plugs were not gaged right or wire crossed it would not run good at any time

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Rough idle 95 astro van, I did a full tune up , plugs,wires,cap, rotor,air filter,and fuel filter and cleaned egr vavle.


I actually had to replace my EGR valve and the gasket. I clean the valve well and reused both. I don't think the gasket sealed well enough though. So I went ahead and got a new valve, gasket and changed them. It runs a lot smoother now.

Dec 14, 2012 | 1995 Chevrolet Astro

1 Answer

1993 3.4l camaro Idles fine when first started. After a few seconds it idles rough and rpm drops. No power when driving. RPM will not go above 3000 even if floored when driving.


there are a few reasons to ur problems 1st check and or replace fuel filter -check and or service egr valve -carbon usually builds up in and around valve causing rough idle -no power and can cause non start problem ---also air filter - fuel pump-bad gas -timing skip-pcv valve-catalytic converter clogging these are some of the problems usually one of the first 2 is the problem good luck

Jun 21, 2011 | Chevrolet Camaro Cars & Trucks

2 Answers

My 95 Windstar idles very roughly. It starts just fine but after about 4 to 5 minutes it starts idling roughly. I put a new air filter in but that didn't do anything.


Hi, Try to replace fuel filter. It maybe clogged up and making engine run rough or poor. Also check and replace spark plugs. A bad spark plug will make it run rough too. Good luck.

Jun 15, 2011 | 1995 Ford Windstar

2 Answers

I have a 2000 ford mustang with a 3.8l v6. Well I know it had been sitting for a while. But anyways when I go to start it, it will try forever to start if I tap the gas while turning the key it will start...


yes your plug wires are bad. this sounds like a fuel system problem (ie plugged filter, flat injector weak pump) a good tune up will take care of it all. the Ford dealer will have all the correct factory parts as well as ford trained technicians to do the job right. also in today's market place you would be surprised how competitively priced they are.

Oct 01, 2010 | 2000 Ford Mustang

1 Answer

Idle problems with my 95' avenger


you may have a bad engine coolant temp sensor. that is what frequently causes that issue on dodges

Apr 13, 2009 | 1995 Dodge Avenger

1 Answer

Computer reads multiple misfires rough idle trouble starting


The air fuel mixture sensor is probably starting to fail. You need to have a simple diagnosis done at the shop and then have it replaced - they are usually not much a reputable mechanical shops. When the motor warms up your air/fuel mixture changes hence the rough idle etc. Hope this helps.

Dec 31, 2008 | 2004 Nissan XTerra

3 Answers

95 cadillac eldorado engine stalls rough idle check engine light is on


I have a 1994 Cadillac Eldorado and every time i start it the car has rough Idle and the Idle fluctuate's. I also can feel it in the gas pedal when the car is doing this I tried replacing the throttle body sensor but it still does it I also was told it was the Idle error sensor. So instead of spending the unecessary money again I thought I would go online and see if anyone could help me with this problem.

Sep 30, 2008 | 1995 Cadillac Eldorado

2 Answers

Ran out of gas and now she won't run!


i would say that you have a bad fuel pump or if you have a carb on it the float inside the carb is stuck check these and i'm sure you will find it's one of these.

Sep 06, 2008 | 1987 Ford F 250

Not finding what you are looking for?
1995 Ford Explorer Logo

156 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...