Question about 2001 Mitsubishi Montero Sport 4WD

Open Question

My 2002 mistubishi triton neutral light is flashing while driving, i had a problem with alt & changed it now gauge not showing full charge & neutral light is blinking while in drive but car is driving ok please help

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 137 Answers

SOURCE: 2000 Mitsubishi Montero 4 wheel drive indicator light flashes

get oil changed in gearbox and the switch on the box

Posted on Jul 08, 2009

Ad
polarcycle
  • 1392 Answers

SOURCE: I have a 2001 Mitsubishi Eclipse GT Neutral light blinking

Could be a wiring issue if you already replaced the speed sensor. I believe there are 2 speed sensors on that tranny though, and both are usaully replaced at the same time.

Posted on Jun 05, 2009

mythman
  • 84 Answers

SOURCE: the neutral light blinks whilst the vehicle is in

The blinking neutral light is an indicator of problems with your vehicle's transmission.

Have it checked by a qualified technician immediately. Be ready to answer 1) how often the vehicle is used, 2) average mileage (distance travelled) per day, 3) maintenance record, and 4) what was done/happened before the neutral indicator light started blinking.

Hope this helps.

Posted on Jul 01, 2009

  • 83 Answers

SOURCE: when in drive the neutral indicator light flashes

Check your ATF cooling system. Your transmission fluid is overheating. This might be after a hard drive. The fluid might need to be replaced too.

Posted on Sep 01, 2009

  • 1 Answer

SOURCE: GAS GAUGE SHOWS EMPTY

TCL light is constantly illuminated, gas mileage has dropped by half, running extremely rich. Are the symptoms related?

Posted on Sep 22, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2002 gmc Yukon.4wd.....the message center light keep flashing..showing a flashing battery red...i got a new battery and alt is good. its causing all lights to go Dem n cut off.


Service Batt. Charging Message - Chevrolet Forum - Chevy ...

chevroletforum.com > ... > Tahoe & Suburban
Oct 25, 2009 - The Service Battery Charging System message keeps comming on in ... on the Information Center has started to pop up more frequently now.

Nov 01, 2015 | GMC Cars & Trucks

1 Answer

Amp Gauge goes all the way past the highest number


amp gauge, and you forgot high number, 30, 60 , 80 , 100 amps?
and did it go left or right, one way is discharge other is charging.
key facts all.?????
no year,
no statement of , if car is stock or not.
if someone added a gauge, here,

back in the olden days, before the way better volt meter.
they had Amp gauges, many we ADD on.
most are wrong size. too. and installed WRONG. (ask correct way)
if the alt dies, the ammeter goes negative amps showing disgnarge ammount,
when runing right it ill be in the posative direction, charging battey
or at 0amps, battery is charged.
all this depends on how its installed.
if put in the alternator lead (big) it will only show alternator output.
10 to 50amps, 10 is typical. 50 be dead battery, running.

Feb 23, 2014 | Jeep Cars & Trucks

1 Answer

98 nissan altima will not charge battary, change alt and has new battery but still showing not charge


Check the gauge isn't fautly it might have broke!!! or there might be a louse connection!

Jan 22, 2013 | 1998 Nissan Altima

1 Answer

I have 2002 Toyota Camry and it would not start. I had the battery checked and replaced it. The car will not turn over but clicks when I turn the key, the windows will not go up, I can't put the car...


i would double check the fuses and then check the charging system.for some reason the alt fuse blew unless it was jumped off backwards or cables were hooked up backwards.on all toyota the batt and brake light will come on when it is not charging.make sure all fuses are good and alt has power at the big wire on top.

Jun 17, 2011 | 2002 Toyota Camry

1 Answer

I have a 2002 F250 4x4 with the 5.4 triton in it. The automatic transmission over drive light started flashing and then it started to vibrate and jump in and out of gear I took it out of overdrive and...


Solenoids are starting to stick in transmission. First try to flush transmission fluid & install new filter & fluid. There is a excellent product called seafoam trans tune. Call around to auto parts stores lots of them sell it. It will clean the whole system,free up stuck solenoids & valves & get rid of moisture. Least expensive option to try first.

Jun 11, 2010 | 2002 Ford F250 Super Duty SuperCab

1 Answer

Replaced alt, belt & battery, battery light still comes on & off


Never was a belt problem. Not likely it was the battery. Now you have a new alt,it sounds,more like a bad ground connection or corroded cable,with too much resistance. If you have those replacement clamp-on cable ends, I would replace the cables. You really need to do a voltage drop test on, at least the battery cables. The alt is not sensing, it is charging correctly, in laymans terms.

Feb 15, 2010 | 2002 Chevrolet Cavalier Coupe

1 Answer

Fuel guage not working properly on 2002 silverado


todays fuel pumps have the signal gauge togethoir the only way is to change the fuel pump

Feb 25, 2009 | 2002 Chevrolet Silverado 1500HD

1 Answer

My 2001 dodge ram 1500 5.2 v-8 check gauges light comes on and the battery gauge is not charging half way and as soon as I drive it , the gauge goes to none charging but I can drive it and it doesn't give...


on the alternator did you put the little washers where the regulator bolts on back of the alt they must be tight and also the ground cable from the battery to the alt bracket must be tight and grounded sounds like a loose connection
the washers go between the alternator and wires coming out of the harness and the alt also it probalbly goes dead occasionally when you crank it up

Feb 02, 2009 | 2001 Dodge Ram 1500 Truck 2WD

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...