Question about 2001 Dodge Ram 1500 Truck 2WD

1 Answer

Po 108 fault code

I replaced the map sensor, reset code, engine starts really rough, idle goes from 500 to 1500 over and over, after warm-up, engine runs smoother, still has code PO 108. Turn vehicle off, after 2 minutes try to restart and motor wont run again, with foot on accellerator, rpm goe up and down, motor choking out.

Posted by on

  • 1 more comment 
  • getair777 Jan 09, 2009

    ther is no mass airflow device on this vehicle. do you think it could be the IAC

  • getair777 Jan 09, 2009

    I have checked all hoses for vacuum leak, checked the voltage on the plug to the Map sensor and have 5 volts. I even sprayed starting fluid all around the intake manifold gasket to see if it would effect the idle but got no response

  • getair777 Jan 09, 2009

    I have taken the IAC out and checked it for operation it is indeed moving in and out. Problem still exists. RPM goes up and down for about 2 minutes and then is fine. Still code PO108

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 141 Answers

Sounds more like a mass air flow sensor problem.

Posted on Jan 09, 2009

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I replaced the MAP sensor AND the MAF sensor. the car now has a rough idle. did those replacements cause the rough idle?


Did you disconnect the battery negative cable for 5 minutes after the parts were replaced? If not do so then drive it at least 20 miles in varying conditions of idle cruise and so on. See if that helps the rough idle. also rerun the fault code test and see if any codes reappear, I have a feeling you did not fix the problem but just threw parts at it.

Sep 29, 2016 | 2004 Buick LeSabre

4 Answers

2006 Chevy Trailblazer started to run rough in idle but only after it warms up. My mechanic got P0017 code on his scan tool and told me I needed to replace the Crankshaf and Camshaft sensors. Both sensors...


Bad coolant temp sensor or EGR valve stuck. You can remove and test temp sensor (the one for the ECM--has only one wire) using cold and then hot water and read resistance with ohm meter.

Jan 28, 2015 | 2006 Chevrolet Trailblazer Ext

1 Answer

Ranger problems


run fault codes and check for O2 sensor problem and MAP/MAF sensor problems. If it is misfiring then codes for injectors and plugs may also appear

Jul 18, 2014 | 2002 Ford Ranger Regular Cab

1 Answer

92 Thundebird 3.8...starts hard....really rough idle in any gear...sounds loud. Almost feels as if the engine is shaking


run fault codes and look for position sensors --MAP/MAF/VAF sensor problems and fuel /injector faults.

Jan 06, 2014 | 1992 Ford Thunderbird

1 Answer

Rough idle and code po1562


First u have to take it to ur car dealership they have scan tool the scan tool will read the fault code and tell u which part or sensor is in faulty that way it's easy fix

Jan 20, 2012 | 2001 Volkswagen Jetta TDI

1 Answer

I have a 92 yj 2.5l 5 speed. it has only after warming up a misfire/rough idle. its fine when its cold and once it warms up and idle comes down it misfires/idles really rough. may be lacking power also. i...


check that the EGR valve is not sticking or has a vacuum leak. This valve will not operate until the engine is warm.

check also the engine coolant temp sensor (ECT). This sensor tells the engine computer that the engine has warmed up, so if it is faulty, it could be sending wrong information to the computer. If the sensor is disconnected, wires to it broken, or faulty in full cold mode, it will tell the computer that the engine is very cold, like -40F. The computer will schedule fuel for cold conditions. This is usually way too much fuel for a warm engine and it will rich misfire, idle rough, and be difficult to start warm.

The ECT has two wires going to it and is dedicated to sending information to the engine computer. It has nothing to do with your dash gauge that shows coolant temp. That sender has only one wire and is dedicated to the coolant temp gauge.

Feb 21, 2011 | 1993 Jeep Wrangler

2 Answers

2001 Dodge 1500 4x4 fault code PO 108


look for vacuum leak at air filter to throttle body ..all along the snorkel use carb cleaner while running and waft areas described til motor changes personalitly

Jan 13, 2009 | 2001 Dodge Ram 1500 Truck 2WD

2 Answers

Po 108


if there is not a vacuum leak it seems that the signal wire to the MAP is either open or shorted to 5 volt reference wire. if not either of those may be the PCM

Jan 09, 2009 | 2001 Dodge Ram 1500 Truck 2WD

Not finding what you are looking for?
Cars & Trucks Logo

510 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...