Question about 2000 Ford Explorer

1 Answer

High idol when cranked

My 2000 ford explorer idols high when first cranked check engine light is on code say idol control sensor

Posted by on

  • Anonymous Mar 16, 2014

    my ford explorer is idleing high when i crank it up

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 129 Answers

The idle controll sensor is on the intake manifold replace it and reset codes

Posted on Jan 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1996 ford explorer and I got some codes that came up p0102 ,p1450,p0113 and p0455 how can I fix all of this ?


455 could be gas cap but could be leak in system,102 mass flow sensor,try to clean with spray like brake cleaner,113 intake air temp.1450&455 gas problem.

Apr 07, 2013 | 1996 Ford Explorer

1 Answer

What would cause my 2003 ford escape to idle around 2000 to 3000 rpm after it has been running for a while. it runs fine when it is first started up.


If your A/C is on , or you are running the climate control in the defrost windshield mode , the engine will idol higher than normal.
A Vacuum leak could also cause a high idol.. check the vacuum lines and be sure they are in good condition and all plugged in.

Jul 15, 2010 | 2003 Ford Escape

1 Answer

Po507 could that be the idol air control


did you replace both 02 sensors? 02 sensors and camshaft position sensor do most of the engine timing. A bad vacuum hose will throw the timing off as well.

Sep 21, 2009 | 2002 Mitsubishi Galant

1 Answer

Car idols high at start some times, slow to


3.1 AND 3.8 ARE KNOWN FOR UPPER AND LOWER INTAKE GASKETS

Jun 24, 2009 | 2000 Pontiac Grand Prix

2 Answers

Check engine light on,idols rough,fine at all other speeds.


It either has a vacuum leak or a dirty MAF. To test for vac leaks spray the engine with carb cleaner to see if the engine speed changes., if it does you fond the leak. The most common leak is pcv line coming straight off the back of the throttle body. Check there first. Also check to make sure there are no air leaks between the throttle body and the mass air flow. Don't replace the idle speed motor or the tps, they won't fix it. It is possible the o2 is the problem, but it usually isn't. P0107 Is usually always from the stuff i listed above.

Mar 01, 2009 | 2000 Ford Escort

2 Answers

Check engine light on,idols rough,fine at all other speeds.


I decided to check the idol air control valve,when I removed it I found the problem right behind it. The P C V valve hose was just about into where it fastens to the intake,the other end was bad also. Cost me aout $6.00 Where auto parts stores were telling me parts would cost two or three hundred $$.

Jan 20, 2009 | 2001 Ford Escort ZX2

2 Answers

2000 explorer 4.0 missing and skipping.


you may have gotten water in your gas it happens alot

Jan 12, 2009 | 2000 Ford Explorer

1 Answer

2000 Chevy Blazer 4.3 engine accelartor problem


LOOK at your throttle plate and see if it is wedged open. there is a piece riveted on that i have seen come loose and prop open throttle

Dec 01, 2008 | 2000 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

183 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...