Question about 1999 Oldsmobile Alero

1 Answer

My 1999 olds alero v6 starting driving a little sluggish and died, it started back up with a 'tick" under the hood, we took it to a repair shop who told us that we needed to replace 3 ignition coils and 6 spark plugs to the tune of 875.00 dollars plus have the engine rebuilt or replaced to fix the "tick", is it possible that all 3 coils need to be replaced but the car still starts and runs?

Posted by on

  • sarcasticall Feb 05, 2009

    i got a new cadyltic converter put into my car but it still stalls would this be from carbon build up

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 404 Answers

Hello!
I've only got a small portion of your problem up to started back up with a???
I am guessing Catalytic Converter failure? if this collapses or blocks up it restricts the exhaust gasses causing far too much back pressure sometimes resulting in backfiring and really poor performance.
Hope this FixYaZ problem!
Good Luck,
Paul 'W' U.K.

Posted on Jan 08, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1995 pontiac lt1 sluggish no power slight back fire


sounds like a fuel problem, may have water in the gas or needs a fuel filter , try a bottle of drygas before the filter

Jan 04, 2013 | 1995 Pontiac Firebird

1 Answer

My son's 1999 Oldsmobile Alero would not start after leaving it for maybe 20 minuts, he had some one boost him but nothing at all, not even a dash light so the next night i went to check it out and when i...


ticking noise in dash could be faulty bcm or body control module.it could be going bad.have car code scan to see if the bcm theft security system has trouble code.

Mar 25, 2011 | 1999 Oldsmobile Alero

1 Answer

I just got a 1999 olds alero the first thing i noticed was starting a little hard sometimes then it died driving down the road w no notice and always stars back up next it got little jumpy when starting...


DO A TUNE UP.CHANGE SPARK PLUGS AND WIRES.CHANGE AIR FILTER AND FUEL FILTER CLEAN FUEL INJECTORS WITH A CAN OF SEAFOAM. HAVE TRANSMISSION FLUID AND FILTER CHANGED. DOING A TUNE UP WILL TELL YOU IF YOU HAVE MINOR ENGINE PROBLEMS OR MAJOR ENGINE PROBLEMS. IF YOU BOUGHT CAR THAT A LEMON YOU CAN TAKE BACK IT. AFTER SO MANY DAYS.

Feb 20, 2011 | 1999 Oldsmobile Alero

1 Answer

99 olds alero 3.4 liter v6 starter not disenaging disconnected power wires nothing got it disconnected volt light came on battery drained charged battery took car off jack started car starter did...


WELL PROBLEM COULD BE BROKEN DAMAGED OVERRUNNING CLUTCH ASSEMBLY NOT ALLOWING DRIVE PINION GEAR TO DISENGAGE.OR BROKEN RETURN SPRING IN STARTER SOLENOID KEEP THE SHIFT LEVER DRIVE PINION GEAR ENGAGED.

Aug 04, 2010 | 1999 Oldsmobile Alero

1 Answer

99 olds alero; fuel pump and inst. panel isn't getting power


fuel shutoff switch is actually a fuel pump relay in the relay box under the hood, but it is not unusual for a fuel pump to work on and off before it finally dies. but it is a good idea to check the relay first.

try swapping it with the horn relay (if the horn works). pay attention to the direction the relay is in. on GM's, it's possible to put them in backward or even miss the connectors completely.

you also want to check for proper power and ground in the relay socket.

Oct 03, 2009 | 1999 Oldsmobile Alero

1 Answer

1998 olds lss dies on me


Check your throttle position sensor.

Feb 05, 2009 | 1998 Oldsmobile 88

1 Answer

2001 olds alero is tempermental


no matter what the mechanic says have the ignition module changed . i had the same problem it only will act up when it gets hot . try this.

Jan 07, 2009 | 1999 Oldsmobile Alero

2 Answers

1999 olds alero leaking coolant


problem could be heads bolts . i put new bolts in put a little sealer on them . make sure your bolt holes is clean free from debris. put a lillte sealer on intake gasket on top and bottom where coolants travel. if all was done . drain engine oil in clean container .set it aside. take radiator cap off .you a coolant pressure rise kit .put a pan under oil pan with drain plug still off .pressure your radiator about 10 psi. make sure you have antifreeze in radiator and engine . when you pressure up to 10 psi look under the car if coolant comes out oil pan. you got leaking head gasket. if not .put oil pan plug back on . put oil back in car . check your freeze plugs also.

Jan 07, 2009 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1999 Oldsmobile Alero Logo

252 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...