Question about 1998 Chevrolet Astro

3 Answers

2000 Chevy Astro Van while driving just stops running

I have a 2000 Astro Van w/approx. 115,000 miles on it. The vehicle runs good and strong but on occasion it will just STOP running. Sometimes it will just quit, sometimes it will be missing before it quits.  It can go for days or weeks at a time before this happens.  I have had a full tune up, plugs, new wires, rotor, coil and fuel pump and filter along with a new relay for the fuel pump. Once the van stops running it can take 10-20 minutes to get it started again. Looking for anyone to give me a possible clue. My mechanic says it is something in the ignition system but of course nothing shows up on the diagnostic computer shows up other than there is some kind of occurrence which brings the check engine light on.

Posted by on

  • 1 more comment 
  • spurdan Jan 09, 2009

    Thank you, for the advice on changing ignition module, I have had it changed and now I will wait to see if the problem goes away. in the past after an occurrence it could go for days or even weeks before it would happen again, so now I'm back to the nerve wreaking waiting game to see if this works  

  • spurdan Jan 17, 2009

    Well today is Jan 17 it has been van has been running good up until today, and it started doing it's thing again sputtering, missing then it ran good for about an hour, then it just stopped running, it took about an hour to get it started again, got it to a shop and was told it was showing a PO338 code and it needed a new Crank Position Sensor and also had a fault code of PO420 and was told that I needed a Catalytic Convertor, after a having them replace the Crank Sensor and leaving the shop and $271.63 lighter it stopped running an hour later, got it started again and has been running fine until the next time. At a total lose of where to go from here, This Van is in great shape both body and mechanically other then this problem have had it for  5 years now and this has been the only major problem with it. HELP

  • navigatingbe Apr 13, 2009

    i hv similar problem.i replaced all spark plugs and wires.still scan code showed P0300, multi misfires. i am going to check ignition coil. any body know where it is on 2000 astro van? somebody said it was under distributor on 1999 astro. same thing on this van?

    thanks

×

3 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 334 Answers

Change your ignition module in the distributor.

Posted on Jan 07, 2009

  • Greg Wilkins
    Greg Wilkins Jan 18, 2009

    Ok lets try taking the egr valve off i done some reading and it said you should be able to clean the egr valve that means take it off and use some carborator cleaner and spray where the plunger is to get the plunger to go in and seal properly. Let me know what happens this should be a low cost fix.Mean while i will catch up on me studying
    God Bless you Greg


×

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Hey I had my rotor and all that stuff replaced on my 2000 astro van, Intermittently it would not run, The problem was I hit a puddle one day and water flew up on top of the roter like 3 drops, it created a trace( it was arching) Thats why it was intermittent.Take a look at the cap look for like a discoloration on it clean it and put it back on.Sounds too easy but remember I had all new parts too.

Posted on Apr 23, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a (* astro and I had a problem with the fuel pump even after sevaral times in a dealer shop< now myself knowing cars the way i do I knew that it was in that area that the problem excicsted i can't recall now if it would actually die maybe it did but it deffinitly would surge and sputter at times, of course duplicateing the problem with a meach or dealer situation was a problem because as soon as i took it in it in the problem would happenn now i cant recall if it was an eletical problem or just a bad pump that was a while ago i believe at 60/ 78,000 mile i now have 195,000 on it and still going always change the oil at 3,000 mi etc anyway never had an eletricl problem w/it ...........

Posted on Apr 29, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

How can you check if fuel pump is bad on a 2002 chevy astro


Check your TPS Sensor. My 1995 Chevy Astro Van did the same thing and I thought it was the fuel pump but I was wrong.

Feb 15, 2014 | 2000 Chevrolet Astro

1 Answer

99 Astro van, While driving on highway 60 miles per hour, vehicle runs fine. Stopped at a light it shakes. The computer indicated a miss fire on cylinder one. Spark plug new, wire new. Recently had...


You most likely have an injector not pulsing or is restricted,try some lucas fuel treatment and see if it will clear it up,one bottle of lucas,and the least amount of fuel ,this will make it clean faster and better,you should see results in one mile or two,if it does not help,injector replacement might be the only solution.

May 20, 2010 | 1999 Chevrolet Astro

1 Answer

2000 chevy astro van turns over but will not start


those vehicles are pretty dependible most problems are the fuel pump it could be running but needs a fuel pressure guage put on it should read 60 pounds try that

Feb 16, 2010 | 2000 Chevrolet Astro

1 Answer

Engine Stalls When stopped and in Drive


Question, did you replace the throttle body, or clean the throttle plate, it will carbon up and block air needed for the idling speed to be correct. Also check for vacuum leaks, as the older vehicles didn't have good vacuum hoses. Good luck

Apr 18, 2009 | 1990 Chevrolet Astro Extended

1 Answer

I have 96 asto van.i was driving and was losing


Check your fuel pressure sounds like your fuel pump went out

Mar 18, 2009 | 1996 Chevrolet Astro

Not finding what you are looking for?
1998 Chevrolet Astro Logo

1,679 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...