Question about 1989 Ford F 150

1 Answer

1994 f150 dash gauges not working

None of the gauges are working including the gas gauge,temp gauge,alt gauge etc..the only gauge working is the odometer and speedometer

Posted by Anonymous on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Go to fuse panel left of steering column. Ck to see if #17, 10A fuse, is blown.

Posted on Jan 25, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

fknstart
  • 404 Answers

SOURCE: speedometer, rpm gauges not working

sounds like a fuse

Posted on Jun 13, 2009

  • 1 Answer

SOURCE: speedometer, water temp gauge, and

A common problem on the 2003 focus are the electrics, i had a problem recently where the displays where not functioning, i took off the panel, checked the iso connector and before putting it back in i gave it a quick spray with wd40 and it al seemed to work, been in contact with the garage and for a new unit with callibration you are looking about £140 or so with labour and parts

Posted on Jan 27, 2009

  • 532 Answers

SOURCE: 2000 ford focus speedometer stuck at max speed

it may have a static charge in the instrument cluster,try un-hooking the battery then turn the key on and even hit the brakes to try to drain the spark out of the system,hooking the 2 cables together with the battery disconnected may work as well to drain it.hook up the battery and see what happens,but make sure the key is off and nothing is on-lights,radio,wipers etc,it could send a spark to the computer.

Posted on May 31, 2009

roniecon
  • 6826 Answers

SOURCE: 1999 Ford escort, horn speedometer , odometer, gas

Most likely a fuse,or the ignition switch is bad.

Posted on Jun 06, 2010

  • 92 Answers

SOURCE: 2001 Ford Windstar Sport - odometer shows dashes and speedometer

Replace the gage cluster you should be able to find a cheap one on craigslist or ebay if not the salvage yard should have one.

Posted on Jul 01, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Dash gauges don't work. The lights are on. Signal lights work on the outside but can't see it on the inside. None of the gauges work, gas, temp,rpm, oil, etc


What make , model and year vehicle ! Sounds like the instrument cluster is bad or no data from serial data network ! No you know what that is ? C.A.N is on 2003 and newer but older vehicles had other networks . How to Diagnose Controller Area Network CAN

Jun 04, 2017 | Cars & Trucks

1 Answer

All my gauges quit on my 2003 silverado the dash lights still work but none of the gauges move


Hi, this is a pretty common problem on these Silverado instrument clusters. We can definitely help you out with that. Click here to learn more about these Silverado instrument cluster problems: Dr Speedometer Instrument Cluster Repair Speedometer Repair Guage...

Jan 09, 2014 | Chevrolet Silverado 1500 Cars & Trucks

1 Answer

Temp and gas gauge doesn't work 1994 gmc jimmy


check the fuse block for a blown fuse, the one that controls dash gauges should be identified in the owner's manual.

Nov 07, 2013 | 1994 GMC Jimmy

1 Answer

1982 chey van , none of the dash gauges work , have changed out gas tank sending unit , brown wire looks good , fus looks good


If none of the gauges work, there is a power problem.
The gas tank sender grounds the fuel gauge and the temp sender on the engine block grounds the temp gauge.
Could be a wiring harness issue or a problem with the printed circuit board too.

Jun 30, 2012 | Cars & Trucks

1 Answer

I have a 1994 ford halfton 5l engin and it seems to be running hot but it dont show on thedash instrument when i come back from a ride say about 10 mile it smells hot


Check the operation of the gauge on the dash by disconnecting the wire from the water temperature sensor (it will have just 1 wire), and then turning the key to ON, without starting. Touch this wire to ground while watching the temp gauge. It should swing to HOT when the wire touches ground, and go back to COLD when the wire is removed from ground. If it works as it should, you need a new sensor. If the gauge does not respond as outlined, the gauge or wiring is faulty.

Sep 25, 2010 | 1994 Ford F150 Styleside Supercab

1 Answer

None of the gauges (speedometer, gas, oil, temp).


check the fuses and fuse link wires by the battery pull the fuse link wire with your finger if it feels spongy or comes apart in your hand you need to replace it with a new fuse link wire

Jan 03, 2010 | 1998 Dodge Caravan

Not finding what you are looking for?
Cars & Trucks Logo

448 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...