Question about 1998 Mercury Mystique

1 Answer

Crank sensor problems

Why every ime i change my crank sensor it runs good for a week then car runs bad lose power back fires. this is the hree time i have changed the crank sensor and same problem.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,533 Answers

Try having the PCM checked at a dealership or repair service shop but before you do this have the timing checked and also check for vacuum leaks

Posted on Jan 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Back fire in the intake


Bad valve timing or sensor/s connections. Read the codes. you will need a repair manual with the codes in it.

Apr 13, 2015 | 1994 Oldsmobile Cutlass Ciera

1 Answer

1998 Plymouth Neon, Losing fire, when gas pedal is pressed it will die. It will idle all day long. After it dies upon pressing the gas, it may or may not crank back. Using a spark tester, when it just...


You need to put your test light away &
stop whatever your doing & have a repair
shop diagnose what ever the issues are

All your doing is guessing at nothing, with
no vehicle info or knowledge & you have
spent time & money on parts that were never
properly tested,or found to be bad & in need
of replacement

May 03, 2014 | Plymouth Cars & Trucks

2 Answers

1999 chevy silverado miss firing


When you change the crank sensor you need a scan tool to set them.The distributor has to be turned using a scan tool to get the crank sensor dialed in.

Jan 09, 2012 | 1999 Chevrolet Silverado 1500

1 Answer

Car starts and runs perfectly until engine reaches operating temp then loses power starts poping spitting firing all over the place until it dies. then it wont start again for 2-3 hours until engine cools...


Possibly the catalytic is plugged. How to know? Has this been getting worse over short time period week or two? Check out at exhaust shop..
Good luck.

Aug 18, 2011 | 1997 Chrysler Sebring

2 Answers

I have a dual over head cam 97 neon.It is not firing, i changed the crank sensor,the coil,and still no fire. the relay was switched.no fire. The last time it run yesterday, it run horrible. Backfiring,...


remove your valve cover and have someone try to crank it over while you watch the camshaft to see if it turns, your timing belt may have jumped a tooth ( causes bad running and back fire ) and then broke

Aug 07, 2010 | 1997 Dodge Neon

2 Answers

1993 chevy truck with 350 engine will turn over but not fire up. coil has spark, replaced fuel pump and fuel filter,changed oil, can hear fuel pump running, but still won't fire


Check the crank and cam sensor. If the magnetic pickup in any of these sensors are bad it will not send a signal to the computer for the correct spark in timing sequence. If they are very old and never been replaced I would replace these also for they do get weak from age and the heat from the engine. Magnets do lose their power from heat generating through them you know

Mar 26, 2010 | 1993 Chevrolet K1500

3 Answers

Engine just died while driving. turns over but wont start. replaced ignition coil. same problem, does not seem to be getting power to the coil. checked fuses also made suer it was getting fuel. 


Change the crankshaft sensor.That is your problem.They can fail anytime and when they do you dont get any power to the ignition coil.Let me know if you are still having problems.I think you will be fine after you have changed the sencor.Good luck m8

Dec 27, 2009 | 1990 Isuzu Pickup

1 Answer

Turns over but no fire


youre p0300 code is radom miss fire,usually cause by bad wires or bad coil pack,p0304 indicates missfire at cylinder 4,cause bad wire or plug.p0335 indicates crank sensor circuit malfunction can cause all of the above,because its part of the timing position for the spark at the plugs,iwould check crank sensor if its within specs!

Mar 14, 2009 | 2001 Hyundai Accent

1 Answer

Runs bad


check fuel line

Jan 05, 2009 | 1992 Buick LeSabre

Not finding what you are looking for?
1998 Mercury Mystique Logo

Related Topics:

370 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Fordexpert

Level 3 Expert

5331 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...