Question about 1992 Buick LeSabre

1 Answer

Every time i change the crank sensor he car runs good for a week then dies how do i fix that

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 409 Answers

Is the sensor being damaged in anyway. When you pull the bad ones out do they have metal particles stuck to them?  How many sensors have you gone through? Have you checked the wiring right at the jack plug for damage? ie: An open cicuit that closes when unplugged and replugged but opens again after a few days causing car to die. Are the ternimal in the plug fitting good and tight on the sensors pins?

Posted on Jan 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Truck won't start


If by your description I'm assuming you say "NO START" you mean it cranks but don't start..? Depending on the YR, make & model Poss. defective module? or switch itself, pickup (if app) Wrong plugs, mass air flow sensor (if app) Any C/E LTS? Scan PCM , also ck coolant system readings & ck emissions when running., crank & cam sensors are popular for that problem along with the module and pickup coil too. It's Long list but I would start with a scan of the PCM & check those crank & cam sensors 1st. Good Luck

Nov 26, 2015 | Cars & Trucks

2 Answers

96 Dodge Runs fine but after warms up it dies,cools n will crank n run good then dies again after warming up.


if you dont know anything about cars then take it to a dealer as it will be cheaper in the long run

Apr 08, 2012 | Dodge Cars & Trucks

1 Answer

Dies Going Down TheROad Wait About 1 Hr And Will Start Again I Replaced Cam Sensor, Now It Spits And...


This may not be the correct solution, but I do know that on my car I had to replace the CAM sensor, and within two weeks it was doing the same thing you're describing and as soon as I replaced the CRANK sensor, it fixed it. I asked my mechanic later and he said they tend to go around the same time. I would try that first. I hope this helps, good luck!

Apr 14, 2011 | 1997 Plymouth Voyager

1 Answer

So my jeep is in horrible condition and my bank accounts are beginning to look the same it had issues running frequent stalls now it will turn over crank and immediately die things I have fixed recently...


Stip by any good parts store (Autozone, Advance, etc..) and have an OBII scan done - they do this free. It will identify all faults that computer has tracked and will identify what is causing running issues.

Mar 14, 2011 | 1997 Jeep Grand Cherokee

2 Answers

My timing belt and water pump for Honda Accord 1990 was replaced and used the car for 2- 3 weeks. After driving about 15 minutes, entering the freeway, my car slowed down but the engine still running....


If you have never changed that distributor on your 1990 Accord, I would suspect it. Check for spark while cranking. The sensors inside the distributor would usually heat up, after 15-20 minutes of running, and would then die out, until the car is cooled off for a while. Look into that distributor.

Oct 07, 2010 | 1990 Honda Accord

2 Answers

Runs fine till warms up then losses power and dies


Does the fuel line still have 55 PSI when engine warmed up? Any other codes show up?

Aug 22, 2009 | 1998 Chevrolet Blazer

2 Answers

I have a 99 concorde runs good then out of no where rpms drop and a car will not get fuel,dies then will start some times soon or later and runs good


Change your Crankshaft position sensor, or your camshaft position sensor. Same thing happened on my car about 3 months ago.

Aug 05, 2009 | 1999 Chrysler Concorde

1 Answer

Crank sensor problems


try having the PCM checked at a dealership or repair service shop but before you do this have the timing checked and also check for vacuum leaks

Jan 05, 2009 | 1998 Mercury Mystique

1 Answer

Runs bad


check fuel line

Jan 05, 2009 | 1992 Buick LeSabre

Not finding what you are looking for?
1992 Buick LeSabre Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buick Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Buick Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...