Question about Cars & Trucks

1 Answer

2001 chevy venture 3.4 automatic having trouble with loss of power when I accelerate, I know its not the tranny I have no problems with my gears or idling starter is ok as well check engine light is not on, any help would be awsome :)

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check air filters this could cause alot of that ur transmission will have some filters also

Posted on Nov 07, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

chazman05
  • 48 Answers

SOURCE: Power loss / low idle speed

This could be a multitude of things but my first suggestion would be to change the spark plugs. They are cheap and can be bought at any auto parts store.

Posted on Dec 16, 2008

  • 2 Answers

SOURCE: missing, loss of power, etc.

sounds from afar like a problem i had after installing after market spark plug cables on a diff. car. make sure you have factory-quality/ even mits. brand cables. (right parts vs. after mkt.?- no contest.)

Posted on May 06, 2009

pippall
  • 1486 Answers

SOURCE: Check engine light and power loss

Air flow meter sounds like your problem.

Posted on May 27, 2009

polarcycle
  • 1392 Answers

SOURCE: P0300 Code 2001 Chevy Cavalier 2.4 twin cam

I would've started with the coil packs, modules, boots and plugs myself. They give many problems on the quad 4s?.

Posted on Jun 15, 2009

  • 14036 Answers

SOURCE: loss of power on acceleration. engine bucking.

check transmission fluid.change fuel filter and air filter.try changing up on where you buy gas .because bad gas causes problems.

Posted on Jun 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2001 Chevrolet venture I have a loss of power when I accelerate, ive had problems before with starting but I know this isnt the starter and does not feel like the tranny any help would be awsome


Are there any codes? does it feel like it is not getting gas. how is the temp gauge, how many miles on it. has it had a tune up lately.. Does it run good all the time. this is my linkhttps://www.facebook.com/TedsRepairs

Nov 07, 2012 | Cars & Trucks

1 Answer

99' chevy venture trans "slipping"


change it youll b fine i drive a 99 camaro with 165000 miles on it and i change my tranny fluid every 30000 miles if not comfortable doin that try slick 50 first

May 18, 2010 | 1999 Chevrolet Venture

1 Answer

2004 Venture hesitating and jerking


Was this there before the trans flush or after. Any other problems or repairs this year?

Sep 30, 2009 | 2004 Chevrolet Venture Passanger

2 Answers

My 2001 hyundai elantra (automatic) loss power while driving


The check engine light usually comes on when there is a faulty sensor. or circuit. Sounds like you may have a faulty throttle position sensor. It would be best to have engine codes read to pinpoint exact problem area. Many part stores do this for free.

Sep 25, 2009 | Hyundai Motor 2003 Elantra

2 Answers

Loss of acceleration and power on 2003 dodge ram 1500


The acceleration may be an issue with the clutch or with engine.  If it is a manual tranny, you may have a worn out clutch.  For automatic, you may need to have the solenoid cleaned or have the tranny serviced
Other issue could be on the engine, check first the fuel filter especially if you encounter loss of power when running.  

Jun 12, 2009 | 2004 Dodge Ram 1500

1 Answer

2001 2.4 automatic. problen is when put into gear


check tranny fluid if its ok,tranny need rebuilt.sorry.

Jun 05, 2009 | 2001 Pontiac Sunfire

1 Answer

After driveing 1 mile frome cold start van just revs but wont accelerate


Check in your radiator if you don't have transmission fluid in it. And pull the tranny dip stick to see if you don't have water or foam on it. There is a tranny cooler coil inside the radiator to help keep the tranny oil cool. You may have this leaking into the water, if this is the case and you don't take care of it fast it will ruin the tranny too.
I hope this helps.
Sam

May 14, 2009 | 1997 Chevrolet Venture

2 Answers

Transmission slips at 40 km/h


seems to me , the 3rd gear shift range is slipping.
You probably have internal failure.
You should take to transmission shop

Jan 24, 2009 | 2000 Chevrolet Venture

3 Answers

Chevy venture 2004 Transmission


Bring to tranny shop or repair shop, have it scanned for trouble codes, many electrical parts and solonoids in those trannys, possible it may just be a shift solonoid bad or needs adjustment, much cheaper than replacing tranny. good luck!

Sep 07, 2008 | 2004 Chevrolet Venture Passanger

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

38 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cars & Trucks Experts

yadayada
yadayada

Level 3 Expert

75005 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Randy Ohler

Level 3 Expert

14585 Answers

Are you a Car and Truck Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...