Question about Ford Cars & Trucks

Open Question

1998 ford taurus 3.0 v6 bogs after acceleration

Replaced fuel filter , cleaned throttle bore,replaced plugs and wires.engine idles great runs smooth. upon accelerating it's like it has no fuel. at like 20mph it bogs like it's starving .feather the gas it picks up ans goes ok

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

motor1258
  • 6674 Answers

SOURCE: accelaration loss of power

I'd have a fuel pressure test done to be sure, it isn't fuel related again. Takes 5 or 10 minutes so cost should be minimal. The other thing that comes to mind is a plugged exhaust. (catalytic converter) Quite possible on a 10yr.old vehicle.

Posted on Apr 11, 2009

  • 14036 Answers

SOURCE: loss of power on acceleration. engine bucking.

check transmission fluid.change fuel filter and air filter.try changing up on where you buy gas .because bad gas causes problems.

Posted on Jun 26, 2009

canbruce75
  • 1776 Answers

SOURCE: 1997 Ford F150 4x4 5.4L

I would take the truck to an autoparts store and have the fault codes retrieved from the computer. Most stores will do the scan for free. I would lean toward a faulty throttle position sensor, but that's just speculation. The fault codes should narrow the problem down. Hope this helped and best wishes.

Posted on Jul 25, 2009

  • 1201 Answers

SOURCE: 2001 Ford E150, V6. Stutter/hesitation upon

Have the throttle position sensor checked, might be faulty.

Posted on Oct 01, 2009

  • 1 Answer

SOURCE: 2002 Ford Taurus SEL, DOHC Misfiring

Disconnect the battery completely, try turning the key with the battery disconnected. Put the battery back together. The check engine light should be off now..

Posted on Aug 15, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

5 Answers

I've got a 1996 jeep grand Cherokee with the 5.2 v8 fuel injected Holley throttle body. My problem is while driving at soft or low acceleration it accelerates fine, but if you hit the throttle hard it


I would check the voltage on the throttle portion sensor with the engine off from idle to wide open throttle.If there are any dead spots, replace the sensor. If the tps checks out, you should check fuel pressure. If you have good fuel pressure, you may want to make sure there isn't a lot of slack in your timing chain. I don't believe you mentioned the mileage of your vehicle. Best of luck.

May 03, 2014 | 1996 Jeep Grand Cherokee

2 Answers

Car is hesitating during acceleration


Hi there i have a 2000 v6 camaro and i just rebulit the top end of the motor over the summer my car does this same exact thing ive diagnosed it as a tps but my throttle body is all one piece and i have fly by wire system so its about 500 to replace. when its really cold in the morning it doesnt like to idle smooth also because if my coolant temp. sensor. For you i would recommend doing a compression test on all of the cylinders, checking for spark, and also check and possibly replace tps( throttle position sensor)..

Jan 03, 2013 | 2004 Ford Mustang V6

1 Answer

I got a 1999 ford ranger with a 2.5l it runs smooth at idle, an runs smooth while drive but bad fuel economy. when u rev up at idle an let go of the throttle it runs rough an then smooths out. ive...


You have two coils on this engine. Test each wire for spark with the engine running. You'll find at least one wire not sparking. replace the coil that has the wire that's not sparking.

May 14, 2011 | Ford Ranger Cars & Trucks

3 Answers

My 2004 Taurus has a rough idle. Plugs, wires,


Any vacuum leaks? Timing good? egr and o2 sensors good?

Jul 11, 2010 | 2004 Ford Taurus

2 Answers

My 1998 Ford Explorer runs rough under hard acceleration


New plugs and wires?

Double check to make sure that you've got the routing and firing order right... if you have 2 switched, the car may still idle well but then pop and sputter on harder acceleration.

The next step would be to run some "Complete Fuel System Cleaner"... If that's the problem, you should see results within 20 miles or so.

Apr 26, 2010 | 1998 Ford Explorer

3 Answers

Can you tell the location of the idle speed valve on a 1998 escort gti please


You will find idle speed controllers in the area of the throttle plates. In order to work, air must bypass the throttle plates.

Nov 01, 2009 | 1998 Ford Escort

1 Answer

Loss of power on acceleration. engine bucking.


check transmission fluid.change fuel filter and air filter.try changing up on where you buy gas .because bad gas causes problems.

Jun 26, 2009 | 1999 Ford Taurus

2 Answers

Under heavy acceleration the car stumbles, runs rough


I am having the same problem with my mustang, have replaced tps, egr valve and sensor, clean maf, new plugs and wires, new fuel filter, cleaned throtle body and still having same problems....Please help!!!!!

May 29, 2009 | 2002 Ford Mustang

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

30 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

fordexpert

Level 3 Expert

5470 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...