Question about 1988 Chevrolet Suburban

1 Answer

88 chevy suburban sputters while in park after applying pressure to pedal. If you slowly apply pressure it seems fine. When going up hill, it sputters. Sounds as though its going but no power.

Can go up an encline and glass packs are loud but no power seems to slow down while going up hill, even though it sounds like its working hard. Thought it was spark plugs and wires, but changing out didnt fix the issue. Any suggestions?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 76,846 Answers

I would think that you need to replace the spark plug wires and the distributor cap and rotor here.

Posted on Nov 06, 2012

  • 2 more comments 
  • jwswanger
    jwswanger Nov 10, 2012

    i have changed the plugs and wires thinking that would fix the issue but it hasnt. The suburban sat for a year before i started it back up if that helps.

  • jwswanger
    jwswanger Nov 10, 2012

    could transmission possibly be a factor? Had it rebuilt about 2 years ago. I mean it does down shift to accelerate up hill but no power.

  • yadayada
    yadayada Nov 10, 2012

    Why didn't you mention the parts were already replaced and save us both some time? As Afr as the transmission goes have a transmission shop test drive it and see what they think , I can't really comment from a keyboard. Good Luck with this problem, it is a good one!

  • terry noname Nov 11, 2012

    before you go out and buy an exspensive catalytic converter have a friend sit in the car while its running have him rev it up a couple of times and while he is doing that you hold a light piece of paper over one of the mufflers and when your friend stops reving the motor see if the muffler trys to **** the paper in the pipe and if it does the converter isn't clogged.

×

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: Lack of acceleration

Hi, I had the same problem with my 2003 Impala and it was a clogged catalytic converter and fuel filter. I had both of those replaced and my car runs like new again. I'm 99% sure this is your issue. My car had the exact problems you're experiencing. It was horrible trying to get on the highway from an on ramp that went up a hill :o)

I also work with someone who has a 2002 impala and the same thing happened to hers as well.

I got mine fixed at a local repair shop for around 300.00. If you take it to a dealer, it would be a lot more.

Good luck :o)

Posted on Nov 25, 2008

  • 2 Answers

SOURCE: loosing power

Wow, I just went through the same problem and guess what it was a clogged converter and a bad oxyegen sensor. The garaged fixed it up for me by putting an eco converter on it and a new O2 sensor. I have a 2003 Chevy Impala,V6 3.8 engine. Good Luck!!!!

Posted on Mar 10, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When coming to a stop, the brakes work fine until I get almost stopped, then the pedal will push down further and brakes will come on hard, and stop vehicle hard, what could be the problem?


Sounds like your master cylinder is bad on your brake system. If you are stopped in your driveway(not on the street) leave the vehicle in park. Start the car and place your foot on the brake with light pressure and keep this pressure on the pedal. If the pedal continues to drop slowly to the floorboard your master cylinder is leaking past the primary piston in the master cylinder. If this is the case have this repaired immediately. Your brakes could just all of a sudden not be there the next time you apply them when you need to stop.

Apr 05, 2012 | 1995 Buick LeSabre

2 Answers

Car doesn't seem to get enough gas to engine


Have you done a tune lately on the car?
I would also suspect a fuel pump problem is you've done a tune up recently.

Jul 11, 2008 | 1994 Hyundai Excel

1 Answer

Stuck in 4hi and hear clicking noise under hood


this all prove that engine and transmission co-ordination seems to be poor.
  1. check accelerator sensor.
  2. " accelerator pedal--transmission ctrl liver.
  3. " transmission oil level.
  4. " proper grade of transmission oil.
  5. " pressure ctrl walls

Mar 04, 2012 | 1995 Chevrolet Blazer

1 Answer

03 cts i put it in park on a hill and let go of the brake then it started to click and slowly roll back


Your trying to ruin the transaxle.

Read your owners manual,no vehicle is designed to hold on a hill,with just the trans parking pawl

You never had it in park ,in the first place,what you heard was the parking pawl, trying to engage the teeth on the parking gear

Your suppost to put the trans in park,apply the parking brake,then let off the foot brake,on all vehicles.

Nov 10, 2010 | 2003 Cadillac CTS

1 Answer

When pulling into a parking stall the car raced forward


try removing the floor mat.. sometimes the mat gets caught on the gas pedal and as you apply the brakes it applies the throttle. It would seem that the harder you press the faster the engine races...

Jul 08, 2010 | 2000 Buick Century

2 Answers

I cant get my e brake to hold i've replaced the cables,pads,the rotors were slightly undersized so i replaced them the automatic cable adjuster seems to be working right but they still wont hold.help danny


there is an adjustment turnbuckle usually directly in the middle of the vehicle tighten this up to remove the slack its fairly easy and plainly visible on drivers side

Aug 25, 2009 | 1990 Chevrolet Corvette

1 Answer

89 chevy beretta gt- surges at idle, backfires and hesitates


Hi! I had the same problem with my 88 2.8 Ltr. Had dirty fuel Injectors. Put in fuel Inj. cleaner in gas tank, after a couple of days, runs like a dream,no more problems. Give it a try. Take care,Leo B. Flushme@shaw.ca

Jan 03, 2009 | 1989 Chevrolet Beretta

1 Answer

Sputtering at midrange rpm somtimes


Perhaps I'm too late and too long winded! But to answer your question about the fuel pump, yes the pump failure mode could be gradual. But as for your "sputtering" engine the root cause could be related to the fuel or ignition system. For clarification I have a few questions. (1) Realizing this may be an intermitent problem, can you make the engine sputter if you rev the engine with tranmission in park? If yes, this reduces the probability of the sputter being ignition related. (2) When you do rev the engine do you get full rpm's (> 2000rpm) or does it seem choked/limited? If no, your suspisions maybe correct and your engine could have a fuel system problem. (3) Or possibly the sputter only occurs/worsens when the engine is loaded? You can sufficiently load the engine by applying the park, service brake pedal, shifting the transmission into drive, and then slowly applying moderate accelerator pedal. It shouldn't take more than 25 to 50% of accelerator application to safely load the engine.

Two possible solutions: If the engine sputters with the transmission in park or you just don't trust the fuel pump you might want to check the fuel filter first before condeming the pump. The alcohol content in fuel could have cleared enough debris to plug your 3 month old fuel filter. You should be able to blow through the filter without much effort. When the fuel filter is clogged it will fatigue the pump and can lead to failure. It could also be poor fuel quality though. (2) If the engine sputters loaded check the ignition coils and module. One way to check a coil is to disconnect a plug wire set before trying to duplicate the problem. If the engine sputters worsens with a wire set disconnected that coil is okay. You will find the culprit when the sputter doesn't change with a plug wire set dis connected.

Oct 26, 2008 | 1993 GMC Sierra K1500

Not finding what you are looking for?

Open Questions:

0 Answers

1988 5.7 TBI Nightmare This is the start of what the problem was and is, I had a RV cam installed when the engine was rebuilt a year ago. the cam was not a computer friendly cam so after a round with the rebuilder and discovering the specs weren't the correct ones for the cam I installed a 3702 edelbrock cam and lifters with a 7800 timing chain and gear set after I had tried two chips from Jet and no improved performance and the 3rd chip was to be for the cam and that is what is in the ECU now and I have tried about 5 different BCC chips and the bottom line is the power is there but something is happening its hit and miss the idle will sometimes lope, is stalled when first started and acts as if its starving for fuel or its bogged with to much fuel. the fuel pressure is 10 - 13 psi and I have R/R the TPS, IAC, ESC and knocks device , EGR and Solenoid, MAP, Temp sensor, and the Dist is a Procomp 10001 with a MSD-5526 coil. the Throttle Body was rebuild and the ECM was replaced with a Rebuilt ECM. it will smell rich etc. but with the things that goes on it does not show any codes?? I have no clue just feel stupid this is been a simple thing that is kicking my **** and now its a challenge but still loosing the fight too far in and too much spent to stop,. LOL Help !!!! The BCC is a california vehicle AFBX, 5.7TBI TH400 A/T P.S. the key can be turned of and back on as the engine not dying and seems to correct the power and run problems but will not last goes back to running bad or with problems. ?

Jul 26, 2012 | 1988 Chevrolet Suburban

See all 1988 Chevrolet Suburban Questions

Cars & Trucks Logo

166 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22246 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...