Question about 2008 Nissan Navara 2.5

1 Answer

Loss of power when the engine gets warm

Vehicle loses power as if there is a fuel problem but all filters and fuel are clean and the pressures are ok

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 444 Answers

Is the vehicle over heating?

Posted on Nov 03, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: 1995 nissan maxima bogging

My 95 did this exactly to a Tee. After trying several things, like cleaning/replacing MAF, fuel injection cleaner to no avail, I ended up unplugging my battery overnight to reset the ECU. The next morning, I put cleaned old MAF and put it back on. Then hooked up battery. Started up, no bogging at 2000 rpms, no stalling, etc. The new MAF was an aftermarket that I bought on Ebay for $86. My car didn't like the aftermarket MAF, so I wouldn't recommend. Anyway, that was 2 weeks ago, and everything is still running good. Hope this helps.

Posted on Oct 17, 2008

  • 625 Answers

SOURCE: 91 nissan Sentra losses power at highway speeds

remove the front 02sensor and drive the car like that, remove means complety take it apart from exaust, if problem goes away or gets so much better then your catalitic converter at the exaust is restricted and need a new one

Posted on Jun 19, 2008

rparad1
  • 1 Answer

SOURCE: 88 Nissan z24i backfires through throttle body and loses power when in gear

Check your intake and exhaust modules. I have a 1987 D21 and had the same problem (if I understand your post). I replaced the modules located behind the driver side headlights and it fixed the problem. Good luck! I hope this helps.

Posted on Nov 14, 2008

  • 1 Answer

SOURCE: loss of power and misfires

It sounds like the catalytic converter. I had the same problem. What to check....after driving for a couple of miles pull over and look underneath at the converter, if it is glowing there is your trouble.

Posted on Dec 04, 2008

  • 7 Answers

SOURCE: after 25 minutes of running, vehicle starts to

did you have a compression test run.

Posted on Jan 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Loss of power while driving 2011 Ford Ranger XL 4.0L?


Testing Electric Fuel Pump Problems with Voltage Drop Test Don't guess , test ! Viewing scan data also is a good place to start .
Were are the fuel trims , are the O2 sensors switching like they are suppose to. What's the MAF sensor showing ?
002 Fuel System Tests Start Here
checking the coolant temp sensor , crank sensors , cam sensors etc... It 's nice you cleaned an inspected the MAF sensor , But did you view the MAF scan data .

Aug 04, 2017 | Ford Cars & Trucks

1 Answer

My tuscon looses power intermittently, sometimes when accelerating, sometimes when just driving. It will do this for 1-2 days then will be ok for a week before doing it again. I can put into neutral a


Could be be clogged fuel filter or air filter or poor output from fuel pump. Low fuel pressure etc will cause it to "starve" for fuel. Clogged air filters will do similar thing causing it to choke for air. You said it loses power, does that mean it stops running and the engine dies or is it just not giving you as much acceleration as you need.

Could also be the drivetrain like torque converter or transmission depending on the model if it is automatic. If it is standard then it would not sound like a drivetrain problem, my first suggestion if to get your fuel filters cleaned and then have a fuel system cleaning done.


They will physically clean the throttle body and add a solution to the intake while it is running as well as pour an additive into the fuel tank.


First things first, fuel system cleaning, then fuel filter/s. Then check fuel pressure output.

Sep 20, 2014 | Hyundai Tucson Cars & Trucks

2 Answers

Why does 2005 Kia Sorento die while driving


If it is a diesel vehicle check the pressure of the diesel pump. It would appear that the diesel pump on this model wears out and it loses pressure. If the pressure is ok there is switch/filter on the common rail that might be blocked. Unfortunately it appears that this switch can not be cleaned but must be replaced. hope this helps.

Jun 06, 2014 | 2005 Kia Sorento

2 Answers

My toyota innova manual transmission engine lacks power accelerating and its really hard to get 120km


Another cause of power loss in diesel engines is clogged fuel filter. Some vehicles have additional fuel filter INSIDE the fuel tank. I had my tank taken down and the inside filter cleaned and it fixed the problem. Some petrol stations and repair shops provide this service. If replacing the fuel filter in the engine compartment doesn't fix the problem, try this one. See FB "Toyota Innova Owners Phils" for more pictures.loss-engine-power-engine-still-running-ndjw3npn5oz5feiqbiqgnn35-5-0.jpgloss-engine-power-engine-still-running-ndjw3npn5oz5feiqbiqgnn35-5-2.jpgloss-engine-power-engine-still-running-ndjw3npn5oz5feiqbiqgnn35-5-5.jpgloss-engine-power-engine-still-running-ndjw3npn5oz5feiqbiqgnn35-5-9.jpg

Apr 03, 2014 | Toyota Cars & Trucks

1 Answer

Loss of power when hot


Have you tried to change the fuel filter. This may be due for a change, or have some contaminant slowing the fuel down.
Also have you tried a fuel additive to clean the fuel system.
Try adding some methylated spirits. This will mix water with petrol and take it out of your fuel system. You can add 1/2 pint or 300 ml to a tank full of fuel without any change in performance. You do not need to do this often.

Jan 29, 2014 | Cars & Trucks

1 Answer

Loses power only drives 15 mph


Is your vehicle equipped with a tachometer? If so are you losing rpms? Just a shot in the dark here are the fuel injectors clean? Fuel line clean? Clean air filter? Can you rev the engine in nuetral?

Jan 17, 2014 | 2001 Ford Econoline

1 Answer

Why is there a loss of power on a 1993 mercury villager after engine gets warm


Very old vehicle, and highly likely it needs a new fuel filter and major tune-up (including all new spark plug wires, spark plugs, cap, rotor, and ignition coil).
Verify proper fuel pressure at the fuel rail, and service fuel pump and fuel pressure regulator as necessary. If you have been using ethanol blend fuel in the vehicle over the past few years, I recommend removing ALL FUEL from the vehicle and replacing it with new. Please read my "Tip" on Fixya regarding the problems with ethanol blend fuels in older vehicles (such as yours).

Aug 02, 2012 | 1993 Mercury Villager

1 Answer

I have a problem engine idles good but when I press on the gas it back fires and wants to quit running


a couple of problem areas to check first is fuel -most likely problem is fuel filter clogging -other problem s to look at are air filter -egr valve clogging ,builds up with carbon robs power remove and clean off carbon and fuel pump can be causing loss thru pressure [leak ]or pump losing pressure [going bad]

Oct 23, 2011 | 1998 Chevrolet S-10 Pickup

2 Answers

1990 Buick Silouete loses power when accelerating, as engine warms it gets worse. Changed filter and had gas tank cleaned out recently did not solve the problem. It drives ok at normal speeds, it spudders...


You are a 1990 Oldsmobile sihouette with a 3.1 these vehicle are speed density in other word you are equipt with a MAP (manifold air pressure) when this sensor fails you loose the ability to accelerate or hesitate as you accelerate make sure the vacuum hose is connected to it and it is no leaking vacuum if the hose is okay and it is electrically connected correctly your fix is to replace the MAP sensor

Aug 05, 2011 | 1990 Oldsmobile Silhouette

Not finding what you are looking for?
2008 Nissan Navara 2.5 Logo

Related Topics:

398 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...