Question about 2001 Ford Windstar

1 Answer

Washer fluid pump will not work, on my 2001 Ford Windstar

Have replaced both front and rear pumps, fuse and still no good. Could it be the switch inside maybe.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Check for power to the pump, making sure the wiring is not severed. Check the fluid lines, and especially the tips. If the pump operates and still no washer solution check the tips. The solution dries right at the tips and is so thick and crystalized that no spray is possible.

Posted on Jan 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2010 Reg Ford Focus 5 door hatch rear screen wash not working. Front is OK. How do I fix it?


the washer fluid could be empty / the fuse for the wiper blew / the relay went bad /if you tried to use the wipers without clearing ice away you blew the fuse/ if you just put water in instead of washer fluid it's frozen/ if the wiper works and there is windshield fluid in the tank and not water and all fuses are good the pump motor for the fluid went and is easy to change

Feb 25, 2015 | Ford Cars & Trucks

4 Answers

My windshield washer does not work


have you check the electric switch on it...?

Jul 12, 2008 | 2005 Kia Spectra

3 Answers

Do the front and rear window wash pumps run off the same fuse?


wiring problem possibly, do you have a millimetre? check to see if the pump is getting power then go from there!

Aug 06, 2014 | 2002 Dodge Grand Caravan

2 Answers

2000 chevy blazer has front and rear ws washers with separate switches. the front washers do not work. fuse is good. plugged in a new mulitfunction switch and still nothing. rear washers work fine. one...


check the washer line it maybe blocked. un plug the pipe from the water pump and blow down it if nothing take the jets off and try again on jet at a time. if pipe is fine then check the jets using a needle pock the holes with a needle and blow out keep doing this until you can blow the same way the water comes out. also on the line there is a one way valve this can block up so that may need changing.

Oct 13, 2013 | Cars & Trucks

2 Answers

Ford explorer 1998 rear washer doesnt work but wipers and motor do any suggestions


unhook the hose at the rear wiper,test, maybe the nozzle is plugged, or hose bent.

Aug 25, 2012 | 1998 Ford Explorer

3 Answers

1999 ford explorer rear wiper don't work


hi there
this is pretty typicalof rear wipers check fuse first to make sure it is good if that doesnt work it is probably the motor which goes out and you can pick one up at your local auto parts store hope this will help you and have a great day

Aug 21, 2011 | 1999 Ford Explorer

4 Answers

My 2004 Ford Expedition will not spray windshield wiper when the button is pushed. The wipers do turn on, but no spray. Would this be caused by a fuse (the wipers do turn on) or is the motor bad?


Can you hear the washer pump running when you operate the washer switch? The washer pump is in the bottom (side) of the washer fluid reservoir. You should hear it running. If not, you can disconnect the wire connector at the pump and use a test light to check to see if there is power and ground at the connector when you operate the switch. If there is power and ground, replace the washer pump motor. If there is no power or ground, you most likely have a bad washer control switch. (You have to replace the entire Multifunction Switch)

If you can hear the pump running, check for washer fluid pouring on the ground. If this is the case, you have a broken hose between the washer pump and the jets that spray on your windshield.

Also note that there is no way possible that your problem could be CAUSED by a fuse!
For more information on this subject, please review this article: Where's The Fuse?

May 17, 2011 | 2004 Ford Expedition

2 Answers

My front windshield washer fluid is in op. wipers work but fluid doesn't spray. is it electrically connected to the rear windshield washer motor? could it be a fuse? how do I trouble shoot?


no the front is not in power with rear they are seperate. check wire plug (connector) at pump,( i assume pump is mounted on or in reservoir ) with test light for power while a helper depresses the spray switch. check for a blown fuse, check switch, check wiring

Jan 13, 2011 | Ford Expedition Cars & Trucks

1 Answer

Front windshield washer does not pump washer fluid on window. Rear washer works fine. Any ideas?


Do you hear or feel the pump run?
Fuse good,pull resevoir and replace pump
Dealer item,parts counter,take old one with you

Dec 01, 2010 | 2001 Mercury Mountaineer

Not finding what you are looking for?
2001 Ford Windstar Logo

272 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61292 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...