Question about 2006 Saab 9-3 2.0

1 Answer

Engine won't go over 5-10 MPH

101,000 miles, no problems before. Tuneup 3 weeks ago. No dash lights on to indicate problem. Battery works fine, synethic oil level full. Drove 3 miles; when restarted engine sounded like it was revving, put into gear & even with accelerator pedal to floor would not go above 10 MPH, usually staying at 5 MPH for 3 mile trip home. Any ideas?

Posted by on

  • Dena Radley Nov 04, 2012

    Update: Gas tank was half-full so added STP gas treatment & filled gas tank. Engine started right up & seemed to be running better. Accelerator pedal to floor still yielded nothing.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 13 Answers

You need to take the car to the dealer, because you need to recalibrate the electric throttle body with a TECH 2 Scanner, because the system went into a Limp mode.

Posted on Feb 01, 2013

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

markmayes66
  • 786 Answers

SOURCE: 04 SAAB 9-3 THREE CODES P1743, P0735, P0734, TRANSMISSION WON'T SHIFT

Could be that a sensor has failed.My suggestion would be have local shop scan it....Could be so many things.......

Posted on Aug 17, 2012

dddsouve
  • 64 Answers

SOURCE: Check Engine light

It sound like you are having a electrical problem.You need to check your electrical/ignition system,not all electrical problem the diagnostic machine can read.

Posted on Aug 22, 2008

  • 30 Answers

SOURCE: engine misses, then shut off, won't start again

not sure about the 2008 model, but the earlier ones had coil pack problems. it looks like part of the rocker cover with around four torque screws holding it down and one multi plug at the end on the n/s of the engine. oh they used to blow the fuse at the same time for the engine management. 30amp dooor pillar/"A"post area. test by removing the coil pack, fitting the spark plugs into the plug outlets. earth the body of each plug and crank the engine, you shoukld see a spark, if not then there are other tests before confirming the coil pack. let me know how you get on.

Posted on Apr 01, 2009

seanpwright
  • 2030 Answers

SOURCE: 2002 saab 9-5 with 95,500 miles has check engine

The message light does not check all internal systems.

Have someone at a local parts store do a free code scan for you, this will tell you what code is making the light come on, and what that code indicates is wrong.

Posted on Dec 07, 2009

  • 1 Answer

SOURCE: engine knocking noise in 2000 saab 9-3 SE?

It's a common problem with these cars i am actually fixing mine as of now. That car is all about oil pressure and when it is low you'll start to get a tap and or what sounds like a knock due to the lifters not having enough pressure. Try taking your oil pan off and check your oil pick up line going from the oil pan to the turbo. A lot of times it gets a lot of sludge build up and makes the pressure little to none. If that looks clear check the slump inside the oil pan and see if that has sludge build up. Well hope this helped

Posted on Jul 23, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Could this be the battery?


This is a bad earth connection . Run a new cable from the battery to the engine or transmission , then run a cable from the engine or transmission to the body . No more trouble.

May 12, 2014 | 2006 Chevrolet Uplander LT

1 Answer

2004 malibu: 101,000 miles no prior problems, engine runs great Problem started 2 weeks ago, I was getting into left turn lane and engine stalled.Put it in N and it cranked right up. Have had a couple...


The security system can actually turn off the fuel pump, or the injectors. Read up on this link for some good info, symptoms, and alternatives to going to the dealer and spending 800 bucks.

http://vatspasslockpasskeysecurityhelp.yolasite.com/

Apr 22, 2011 | 2004 Chevrolet Malibu

1 Answer

I was driving down the freeway at 65 mph with cruise control on. Light on dashboard was on. It read 'security'. 20 miles later the engine shut off with no warning. Engine now will turn over but not catch...


If no dash lights or any type of reading try looking at your ground connection to the frame. I had a similar problem a couple of weeks ago, truck just died while moving, grounding was the issue...

Aug 26, 2010 | 2000 Chevrolet 3500

1 Answer

98 Jeep Grand Cherokee, The low beam lights went out, the high beams work OK. Has anyone found the common problem yet with this issue? 101,000 miles.


If your headlight switch is the type you pull out, left of the sterr column on dash, switches tend to go bad, I replaced mine and only had 50,000 miles. try checking headlight relay in engine fuse box first.
.

Mar 02, 2010 | 1998 Jeep Grand Cherokee

1 Answer

2002 Tahoe will not start


check and recheck all conections on battery and starter and grounds on battery and the ground on engine bblock and body ground or grounds,if not sure make another one ,check connections at battery ,it does sound like a bad ground to body and eng just make ur owne and see what happens

Jun 28, 2009 | 2002 Chevrolet Tahoe

1 Answer

Transmission will not go in to automatic


The transmission shop did not adjust the shift lever indicator correctly for the dash. Take it back!

May 16, 2009 | 2003 Mazda Protege

1 Answer

2002 Sebring -Odometer Lights Flicker then bing battery indicator


have the engine wire harness checked maybe a communication problem between modules.

Mar 27, 2009 | 2002 Chrysler Sebring

Not finding what you are looking for?
2006 Saab 9-3 2.0 Logo

719 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saab Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

rgbypoet

Level 2 Expert

166 Answers

Are you a Saab Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...