Question about 1994 Saturn Sl

1 Answer

I am experiencing a hesitation, studder under a load.. seems to be in lower rpms, less than 3000rpm! Idles fine and no problems while in neutral! Any suggestions?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Master
  • 1,007 Answers

Check the following:
1) HT leads for resistance or leakage. If these haven't been replaced in a few years, then replace them anyway as these break down over time and may cause a drop in performance.
2) Spark plugs for any oil residue or carbon build up or wear.
3) Air filter for contamination.
4) Fuel filter for contamination and/or blockage.

Posted on Nov 03, 2012

  • 4 more comments 
  • stephen thatcher Nov 03, 2012

    HT leads?? I'm not familiar with that

  • Jamie Alton
    Jamie Alton Nov 03, 2012

    The HT leads are know as High Tension leads, and carry the high current needed to power the spark plugs. The insulation on these leads tends to break down over time, eventually causing current leakage, and a failure to adequately power the spark plug.

  • stephen thatcher Nov 03, 2012

    Other wise, commonly known as spark plug wires! Thanks for your help & suggestions!

  • Jamie Alton
    Jamie Alton Nov 04, 2012

    No problem. Good luck!

  • stephen thatcher Nov 05, 2012

    change the plugs, wires and air filter.. seems to have corrected the problem! thanks for the advice!

  • Jamie Alton
    Jamie Alton Nov 05, 2012

    Great stuff! Glad to hear your issue is solved.

×

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 149 Answers

SOURCE: my 1998 Saturn SL2 idles rough.When I step on the

check ur fuel pump and the plugs

Posted on Apr 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1996 Dodge B2500 fuel problem. Fuel pump OK. Getting P0001 code(Fuel Volume Regulator Control Circuit/Open).


if that is the code then replace the pressure regulator
it is not allowing pressure to be maintained at the correct operating pressure (50-65 psi) all of your stated problem will occur

Mar 06, 2017 | Dodge Cars & Trucks

1 Answer

186 red motor. Why does it have a missfire under load?


Engine is under max load in the situations you describe, so any weakness in spark or low fuel prssure can cause this, even a weak ignition module.

Aug 11, 2015 | Holden Cars & Trucks

1 Answer

2005 Dodge Ram 1500 4.7 Engine. Starts fine, Idles fine, but when engine shifts into high gear and RPM lowers engine runs really rough under load


Have you checked for a broken valve spring. Repaired a dodge engine with the same running issue as you have described and it was a broken intake valve spring.

Feb 22, 2015 | 2005 Dodge Ram 1500

1 Answer

What can cause my truck to hesitate at low rpms but idle fine and run fine at higher rpms?


-There is couple things cause that. Possibly:
-Spark plug too dirty, pack w/carbon, oil.
-Broken plug wire.
-Bad injector.
-dirty air flow sensor.

Good luck

Mai

Oct 23, 2014 | 1995 Chevrolet K1500

1 Answer

My 1995 jeep grand cherokee laredo 4.0 inline 6


Something mechanical, ignition, or fuel.
It can run rough under a load such as in gear and ok in neutral with no load. Have you checked the plugs and dist cap ?

Feb 11, 2014 | Jeep Grand Cherokee Cars & Trucks

1 Answer

2002 protage 2.olt hasites under load but clears up after 3000rpm


You are dealing with a misfire.It clears up at 3000.RPM A jump timing belt can do this or a broken valve . Also a failed coil pack. Lets go with a failed coil pack.Because of the strategy that is used a failed on the engine smooth at 2000RPM (neutral) No. 1 and No. 4 are fire simutaneously and No. 2 and No. 3. simutanueously. with the engine running lift the plugwire to number 4 does the engine stumble if it does this is the working cylinder and there is nothing wrong go to number 3 you may have to use number 2 engine running wire pulled out does the engine stumble if there is no change you found the problem.Basically what yopu are doing is checking for spark at all the cylinders

Feb 23, 2012 | Mazda MAZDA5 Cars & Trucks

1 Answer

1996 windstar with 3.8L idles fine in park or neutral but if its in gear with a/c on it studders and dies but starts right up again...doesn't seem to do it when the a/c is not on...


The most common cause of your problem is the TPS. The Throttle Position Sensor regulates the idle under all conditions ie cold, warm, AC on. Unfortunately, it's electronic and can't be adjusted, only replaced. Another less likely cause is a loose or worn serpentine belt. This would prevent the alternator from properly replenishing power back to the battery. When the AC is on, it's a bigger draw than normal on your electrical system and could cause stalling. Although it's less likely, it's worth looking into prior to making a more expensive repair such as the TPS. Most chain auto parts stores and some service stations will do a free test on your charging system to ensure your problem isn't electrical.

Jun 03, 2011 | Ford Windstar Cars & Trucks

3 Answers

Santa fe studdering and won't accelerate right? RPM's jump and then steady with continuing studdering?


Engine performance problem causes are many. Try this first.
1. Disconnect the battery cables (both of them)
2. Touch/connect the postive and negative battery cables together for 30 seconds.
3. Reconnect the cables to the battery.
4. Drive vehicle to see if this solved the problem. Let me know what happens.

Apr 25, 2009 | 2003 Hyundai Santa Fe

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

97 people viewed this question

Ask a Question

Usually answered in minutes!

Top Saturn Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8270 Answers

Are you a Saturn Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...