Question about 2007 Chevrolet Aveo Sedan

Open Question

I have suzuki alto vxr 2007. the vehicle is giving problem in starting when cold on cng. if i park the car during day for more than half an hour and start it back on, it wont start on first self or will take long self.. have got tappet adjusted recently and tunning of cng and petrol but problem persists.. can anyone tell wot can be the reason

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

scott gibson
  • 34 Answers

SOURCE: 2002 Trailblazer - won't start

what engine ?
And dont leave the battery hook up.

Posted on Jul 01, 2008

  • 393 Answers

SOURCE: hard start wont run more than a few minutes

sounds like the air bypass valve may be stuck ,try pulling off a small vaccum line. the valve is used instead of a choke plate. when engine is cold it bleeds air around the throttle plate raising the idle.

Posted on Dec 06, 2008

  • 4 Answers

SOURCE: 1988 chevrolet celebrity cranks but will not start

try turning on the key and having someone stand by the GAS tank and listen for the pump to kick on? They may have to get lower to the ground to hear it turn on but they/you will know if you hear it.

Posted on Jan 22, 2009

  • 1 Answer

SOURCE: 1996 lumina chevy

sounds to me like you may have some trash in your fuel lines or tank try flushing your fuel lines and possibly take the tank off and make sure there is nothing that may be inside blockin the flow of fuel to the engine if that doesn't work check your fuel pump it could be something as simple as needed a good fuel injection cleaner or something more serious like a blockage in the line itself

Posted on Apr 01, 2009

  • 1 Answer

SOURCE: 2000 chevy silverado 5.3 liter

Like you gays say, it's was the crank sensor,just replace the sensor yesturday5/12/2009,it's working very good.Thank you so much.

Posted on May 13, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have alto. Outside CNG . when i start car.CNG switch shout. No idea how to repair this...


What is the make, model and year of vehicle? Is this a factory installed fuel system?

May 12, 2016 | Cars & Trucks

1 Answer

How do i program alto keys


a non USA car. right>? and this is USA (calif ) forum..

2010, the operators guide answers that. glove box , day 1.
lost them both?
is that it?
get one at suzuki or ask them what to do .
or go online try to find (google it) alto help on keys.

Feb 08, 2015 | 2010 Suzuki Alto 1.1

1 Answer

Disable passenger airbag suzuki alto


Unless the vehicle is fitted with a manual 'OFF' switch, then presumably there is no other simple way of disabling the passenger airbag without disconnecting the air-bag module. This is not recommended however and may disrupt the operation of the SRS system.

Jun 20, 2014 | 2010 Suzuki Alto 1.0

1 Answer

My car is making noise in staring as well as in balance rod could u please find me a solution of this. and secondly can i use R 13 tyre and rim in Alto vxr car, but in manual guide r 12 is recomended


Noise in starting check the starter , the starter motor for play , the starter pinion. The balacne rod make a noise due to the play after wear off due to bad road conditions.It can be replaced or tightened,
Please stick on with the correct size designed as being a small car the effficiency depends on the designed size.

Sep 19, 2010 | Suzuki Swift Cars & Trucks

1 Answer

Hi I have a Zuzuki Alto (2002)Auto , I am the third owner and It has done 63,000KM`s. I bought it lats week , and found that sometimes the engine does not start, specially after a journey. Haven`t...


you have just solved the question yourself.....you have to take it out of park to start it...some cars you have to put the car into park to remove the key,try the park relay/switch

Aug 21, 2010 | Suzuki Swift Cars & Trucks

1 Answer

THE GLOW PLUG TURNS ON WENT ENGINE IS COLD


Yes it does. Let the glow plugs warm up for 7-10 seconds (the light on the panel should go off) and then crank the engine. If the weather is cold, half an hour of running does not warm up the engine completely so you need to use the plugs for the first few startups during a cold day.

Dec 17, 2008 | 1995 Mitsubishi Montero

1 Answer

Battery dies in extremely cold weather


Sounds to me like you have a weak batt. also if you rear lights are sticking on some times that could drain it

Dec 13, 2008 | 2002 Jaguar Vanden Plas

Not finding what you are looking for?
2007 Chevrolet Aveo Sedan Logo

Related Topics:

154 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75066 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7754 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...