Question about 2005 Ford Focus

1 Answer

I was driving and my car just turnd of. the fuse from the engine epandante got burned, so i put a new one and when i wanted to turnd the car back on and the fuse popt again...

Posted by on

  • 4 more comments 
  • valentin_831 Jan 04, 2009

    i just check the stereo cables and nothing is burn. when i puss the botton for the rear window so it could defrost it makes a sound by the stering wheel. everything workz just that and the fuse keepz on blowing up. 

  • valentin_831 Jan 04, 2009

    my bad its cald the engine management fuse..

  • nightcookies Jan 07, 2009

    i am having the same problem!!!! help

  • Greg Wilkins
    Greg Wilkins May 11, 2010

    Did you say you added the stereo before this happened?

  • yadayada
    yadayada May 11, 2010

    What is a engine epandante ?

  • Greg Wilkins
    Greg Wilkins May 11, 2010

    have you put anything on your car recently? look around the where the fuse is and see if there is anything burn't or if there is any bare wires

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 59 Answers

There has to be a short some where so check all the wires and make sure they are not bare. also check out the generator it may be bad and is pushing out to many volts

Posted on Jan 04, 2009

  • Eric Peelman Jan 04, 2009

    there has to be a short some were cosing the fuse to blow so check all wires and make sure there good. also check in the steering clom

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Van wont turn over not a sound i put in a new battery


if it works jumping it then the starter is fine. check fusible links to see if one is blown. check all contacts, engine grounds too, for corrosion and clean if necessary.

Sep 16, 2012 | 1995 Toyota Previa

1 Answer

Ford v10 triton engine alternator won't charge brand new


I had a similar problem on my 98 Tioga (Ford v10). Turnd out to be just a blown fuse in the cab (wich controls the alternator's regulator.) First, confirm its the charging system and not the battery it's self. To do this, start the engine and take a voltage reading at the battery. It should be above 13 volts. If you don't have a tester, with the engine running, disconnect a battery terminal. If the engine stalls, it's proff the alternator is not out putting as it should. Check for a blown or missing fuse. Anything labeled "intrusment cluster" or "Alt" (maybe 14). If the fuses are ok you'll likely need to replace the alternator it's self. On those engines it's not hard to do. Only takes about 20 min and the the alternators are around $130. But defiantly check the fuses first.

May 10, 2012 | Ford Super Duty Cars & Trucks

1 Answer

MY 2000 3.0 JAGUAR S-TYPE WAS ALSO RUNNING FINE ONE DAY WHEN I WAS COMING HOME 4RM THE STORE PULLING INTO MY DRIVE WAY MY CAR WAS ALSO RUNING FINE NO SIGNS NO SHAKING NOTHING AT ALL AND IT HAD HALF TANK...


SOUND LIKE FUEL PUMP NOT WORKING.TURN ON IGNITION SWITCH LISTEN FOR FUEL PUMP NOISE.SEE IF PUMP RUNNING IN FUEL TANK.IF NOT CHECK FUEL PUMP FUSE AND RELAY.IF ALL IS GOOD FUEL PUMP FAULTY.HAVE CAR CODE SCAN FOR FAULTY PCM AND ECM WHICH CONTROLS THE FUEL PUMP PRESSURE TO THE FUEL INJECTORS.

May 05, 2011 | 2000 Jaguar S-Type

2 Answers

I have a 1997 f150 ext. cab the other evening we were cooking out when we heard a muffled exsplosion luck haven it we were just up the drive from my truck. welooked toward the truck and we could see smoke...


You might want to contact Ford. There was a class action lawsuit regarding bad brake pressure sensor that caught fire. Gentleman in Iowa died in garage fire attributed to defect. Might want to contact a lawyer.

Mar 21, 2011 | Ford F-150 Cars & Trucks

1 Answer

I had a problem with my battary staying charged so I put a new alternator in and still the was not charging so then I looked at the electrical I found the harnest wire that connects fom the alternator to...


It sounds like you have a wire directly connected from the battery to the starter motor by passing your ignition switch. double check that the new harness that you put in with the new alternator is correctly installed. hope this helps good luck.

Nov 20, 2010 | 1988 Ford Mustang

1 Answer

Will crank but wont turn over as no gas is in it


try a new fuse if it pops again there is a short in weiring or bad fuel pump did you put new gas in it

Mar 10, 2010 | 1999 Cadillac DeVille

1 Answer

97 civic new battery wont hold a charge alternator is fine....any ideas... thnks gf


remove pos batt cable from batt install test light in line. One end on batt other end batt cable. See if test light burn.s bright with car turnd off' Unplug fuses one at atime until you find on that makes the light go dimmer. then look in maual to see whats on that ckt'

Jun 24, 2009 | 1997 Honda Civic

1 Answer

2005 ford focus zx4


there could be a short in one of the wires that is poping the fuse so check for bare or exposed wires

Jan 04, 2009 | 2005 Ford Focus

1 Answer

Dead battery.


Here is a link to the factory owners manual, the info about the fuse is in the manual.

http://www.motorcraftservice.com/pubs/content/~WO1TAU/~MUS~LEN/41/01tauog1e.pdf

Oct 11, 2008 | 1996 Ford Taurus

Not finding what you are looking for?
2005 Ford Focus Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...