Question about 1986 Mercedes-Benz 300

2 Answers

1986 300 e gas - runs rough when it runs - very hard to start - quits running altogrther after 10- 20 mins- could it be a timing (chain) issue?

Posted by on

  • hap_slappy Apr 28, 2009

    I alos have an 86 300 if u start it cold it fires upo and runs for like 10-20min and quits then its a real ***** to start after that and runs terrible ..but nest morning same thing...starts good for 10-20 min



2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

1986 mercedes 300e starts hard runs 20 minutes shuts off
very hard to srart. especially when cold

Posted on Mar 30, 2011

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

More then likely it is the timing chain going its probably stretched out and needs replaced

Posted on Jan 03, 2009


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Car starts hard then idles roughly for 2-3min then stalls and dies

It sounds like some thing you have done if the fault started after the tune , did you check the gap on the new plugs, check the firing order as it may be messed up . 4 cylinder 1342 6 cylinder 153624 in direction of rotation.

Dec 03, 2015 | 1996 Nissan Altima

2 Answers

Starts and runs fine for about 10 min. then runs rough then stops running

Idle air control valve and possibly the throttle position sensor contacts are worn the both of them expand from heat and break contact but try first using carbon conductive grease on the plug contacts there could be oxidation or corrosion in them causing the problem before you start spending $$$$ you spent big money already with no result ?good luck stephen

Feb 11, 2018 | 1986 Ford Crown Victoria

1 Answer

Just replaced timing chain and gears noiw wont stay running

I would guess you have to go back over your work
with regards to the timing chain & cam gear settings
If your at a professional shop, they can look at various data,
to get an idea if timing is an issue since that work was just

Jul 10, 2013 | 2001 Pontiac Sunfire

1 Answer

Runs rough, wont start at proper timing setting

usually when the camaro runs rough that could be bad fuel injectors-o2sensor and fuel filter-thats my guess i had the same problem and i put bad gas in and the fuel filter went bad

Dec 16, 2009 | 1992 Chevrolet Camaro

1 Answer

My 2001 Chevy Tracker quits running after a while and will restart after about 10-15 minutes. It originally runs rough after it restarts. I have been told to replace the camshaft sensor. Also, when I...

Had the same problem with my tracker. Replaced the camshaft position sensor(easy to do yourself, takes about five mins.) Now can drive at highway speeds for about a half hour and stop at the gas station and she'll start back up and run fine. Before i had to wait at least 15-20mins before she would start. Also, if your service engine soon light is on take it to the national chain auto parts stores and they will hook up the code reader for free. The sensor runs about $120.

Sep 26, 2009 | 2001 Chevrolet Tracker

1 Answer

93' 4.3 chev runs rough at times

Have someone turn the key on while you watch the injectors. If any gas leaks out of the injectors, without cranking on it) replace the o'rings around the injectors.

Mar 12, 2009 | 1992 Chevrolet C1500

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

341 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers


Level 3 Expert

77932 Answers

Joseph Prosser

Level 3 Expert

772 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides