Question about Lexus Cars & Trucks

1 Answer

Obd code p0171

Car turns on fine while cold if turned on while engine is warm it shuts off so i have to keep pumping gas til it levels out and stays on ,ive replaced all oxygen sensors,fuel filter,throttle body and its gasket,maf sensor ive checked for vacum leaks other than the one i found in the throttle body and nothing not sure what else to do to get rid of this code really beyond aggravation need help asap!!!!!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Master
  • 14,553 Answers

P0171 System too Lean (Bank 1)

Posted on Oct 31, 2012

  • chagy Oct 31, 2012

    i know what the code means ive checked everything and replaced alot of parts and the code won t go away

×


6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 17 Answers

SOURCE: I cant find out what is causing these lean codes on bank 1 &2.

vacuum leek,bad computer or you have a linkage out of adjustment on the throttle body

Posted on Feb 23, 2009

  • 2 Answers

SOURCE: I have a 92 camaro rs. it is a 305 fuel injection

try changing your knock sensor and check all of your vacume lines for cracks or disconnects

Posted on Sep 01, 2009

  • 73 Answers

SOURCE: 1994 lEXUS ES 300, the car start but when the gas

it is the computer. send it to auto computer exchange in davie fl they can fix it.

Posted on Oct 02, 2009

Testimonial: "I went to the Junk yard got a computer i just did'nt want to spend alot more money, and gest what it work perfect."

  • 128 Answers

SOURCE: Chevy 1500 1996 doesnt start just keeps turning

see if your fuel pump is geting power to it stick your ear in gas filler take off cap an have someone turn key thats first your fuel pump relay thats on the fire wall in the engine compartment might be no good thats what turns on pump its on the left side of fire wall with a black cover over it

Posted on Aug 21, 2010

emissionwiz
  • 75797 Answers

SOURCE: Check Engine Light. I have a 03 escalade that

Your fuel pressure is WAY to low, it should be at least 55 PSI, (spec is 55-62 PSI) You will need to replace the fuel pump and the fuel filter then clear the codes and retest, the fuel pump is located inside the fuel tank, the fuel tank must be removed to access the pump. after the fuel pump is replaced if any lean codes come back from the O2 sensors the intake maniold gaskets will need to be replaced as well, they are a common problem as well but your main problem is very low fuel pressure, this alone will set all the codes you have.

Posted on Oct 28, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Starts fine runs fine. After turned off, will not start. Wait or try again and it starts. What's wrong?


Car will sometimes not start after warm. - CarGurus

www.cargurus.com > Questions > Pontiac > Grand Prix

CarGurusJan 2, 2013 - When i start my car, for the first time during the day- I have no problem.... When I go somewhere and shut it off, sometimes it won't resatrt. ... I have to keep my foot on the gas and rev it up to keep it running- then it's fine. .... When your carstarts fine cold, then fails to restart while warm, it is usually a coolant ...

Blazer has to be jumped, then i shut it off and won't start.

www.cargurus.com > Questions > Chevrolet > Blazer

CarGurusDec 21, 2013 - I jumped it and it ran fine, but as soon as I turned it off I couldn't start it again. No clicking just like the battery is drained. ... Then run the car for ten minutes and shut it off and if does not start, replace the battery. ... Blazer starts fine first time but after shutting off,has hard time starting-takes up to 10 key turns or ...

Engine Performance Problems Due to Crankshaft Position ...

repairpal.com > Problems > Mercedes-Benz > ML320
"Crank no Start" Due to Failed Crankshaft Position Sensor on Mercedes-Benz ML320... It usually ocurs after I've turned the car off and try to restart after about 15 minutes. I typically allow it to ... fine. Stalling and starting problems intermittent at first, but now more frequent. ... Car runs fine then without out warning it won't start.

Jan 05, 2016 | Cars & Trucks

1 Answer

Where does the water go in a 1999 ford explorer?


First of all use a 50/50 mix coolant and water WITH THE ENGINE COLD on the radiator remove the cap by pushing down and turning fill to top start engine and water will go down a little add more till full turn off engine replace cap push down and turn follow the tube from the cap on the radiator to the overflow tank and fill it half way Start run til all warmed up. shut off let cool all the way and then check levels and fill to top and half if necessary

Mike

Dec 08, 2015 | 1999 Ford Explorer

1 Answer

1991 Ford F-350 runs rough at cold start, dies if gas peddle depressed?


because the combustion inside the engine is going wrong the quantity of air getting inside is not the needed quantity maybe less than or more in cold will cause such problem once the engine warm up than the engine temperature is up you will not find this problem because the point of firing will be near

Jan 02, 2014 | 1991 Chevrolet C1500

1 Answer

Won't stay started after it warms up


First did you reset the computer after replacing each of these sensors? If you did then i would check the fuel pressure it should be 48-55 psi with the key on and the engine off.If its not within these specs then replace the fuel pump and filter.

Aug 17, 2012 | Cars & Trucks

1 Answer

1990 Volkswagon Jetta won't turn back on after long drive.


Then you have a start up problem and it reside with the cold start valve,The cold start valve operates even if the vehicle is warmed up,the cold start valve can be plugged up,or even have a bad connection,The cold start valve operates by a thermotime switch.This switch located on the near bottom of the radiator may have gone bad or disconnected,Here is the easy cost effective route, replace them both,it will cost more to trouble shoot it than just replace it.

Aug 07, 2012 | 1990 Volkswagen Jetta

2 Answers

Stalls when warm 95 camry


sound like your have the bad distributor, when you have trouble starting remove the distributor and have the auto part check it.

Nov 23, 2009 | 1995 Toyota Camry

1 Answer

MY 1998 FOR TARUS HEATER WILL NOT WORK.WAS DRIVING


It is most probably the problem with blend door or blend door actuator. But just in case I would suggest to follow the entire procedure:

First you have to identify what causes the problem.
To do this you have to:
1) When engine is cold check the level of coolant. If it is low fill it up.
2) Start engine and check if engine reaches regular temperature. If your engine is not heated enough it means your thermostat does not work properly and should be replaced
3) If engine temperature is normal, then check the temperature of pipes that go to/from heater core. These pipes are located up the fire wall (easier access is from the passenger side). If pipe/pipes are cold (even engine is warm) it means you heater core is plugged and should be flushed. Keep in mind, flushing the whole cooling system is different from flushing heater core.
4) If pipe/pipes are hot/warm, turn off the fan, switch controller to the hot position, wait for 3-4 minutes and turn on the fan. Note if the cold air blows first or warm air blows first but it cools down in 5-10 seconds. If the air blows cold than it is most probably the problem with blend door or blend door actuator.
5) If air blows warm first and then cools down, then while running engine and remaining the transmission in PARKING position, press on the gas pedal until your engine reaches 3,000 RPM. Check if your heater blows warm/hot air. If it does, then your water pump does not work properly and should be replaced. If the air still cold, I would suggest flushing the heater core.

Oct 17, 2009 | 1998 Ford Taurus

2 Answers

2006 Subaru Impreza. Oil warning light stays on dimly when starting from cold but fades as engine warms up to normal running temperature. I did an oil and filter change about 2 weeks ago. Oil level on...


No, just keep an eye on it to see it does not start staying on longer and longer. The oil pressure sensor my be a little off,and at worse the oil pump is a little weak. Just keep up on the oil changes.3500 miles max.

May 19, 2009 | 2006 Subaru Impreza

1 Answer

Chugs, acts like it's not getting gas once warmed up. Idle's fine


This problem can be several things. When your engine is cold, your computer is in a "closed loop" and just pretty much keeps the engine running until warmed up. After reaching operation temperature, the computer starts reading all the sensors. If one sensor is not connected or is defective, you will experience performance problems. Most of the time this will turn on the check engine light, but not always. Second is the fuel pump. This too will cause erratic engine problems.

Apr 10, 2009 | 1991 Chevrolet Silverado 2500

2 Answers

Fuel pump not running only in cold weather


Pumping the pedal on an injected engine does nothing, except varying the air intake amount. I would change the fuel filter (if badly plugged, it may be causing the pump to shut off early) and clean the idle air control valve.(which should regulate idle air flow, eliminating the need for playing with the pedal) The valve itself is not difficult to service, but is a bit delicate. It can be cleaned with carb cleaner. just make sure you do not turn the valve end around while cleaning, and re-install it perfectly straight. You may have a bad drain back valve in the pump, but this is less common than what I outlined above.(there are tests for this)

Jan 12, 2009 | 1995 Jeep Grand Cherokee

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

213 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexus Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

881 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Are you a Lexus Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...