Question about 2000 Ford Expedition

1 Answer

Signal light doesn't work

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 61 Answers

Check the fuse, or signal light relay.

Posted on Oct 28, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

On my 2004 impala, the front right turn signal doesn't work, (only works with hazard lights). And the back right signal is fast. The signal "clicking" sound is non stop but on the other hand...


If the turn signal filament of the right front park/turn lamp is known to be OK and the hazard switch is in the normal position, the hazard switch or the turn signal/multi-function switch could be defective

Oct 16, 2012 | Cars & Trucks

1 Answer

My 2000 lincoln ls doesn't crank or click when trying to start it, it does nothing? all the lights work, radio, signals and horn, I checked the fuel relay and the starter relay and the ignition fu


Sounds like an Ignition Module or similar device. Does it have an alarm? Turn the key to ON - not start - and put into Drive and then back into Park. It may be the shifter isn't fully engaged. Also, w/your FOOT ON THE BRAKE shift to Neutral and try to start it.

GL,
Td

Oct 01, 2012 | 2000 Lincoln LS

1 Answer

My 2001 ford expedition right hand rear turn signal and brake light doesn't work but right front signal works


Multi-function switch,(Wipers turn signals cruise) , this may sound crazy, but if you can get to the screws & remove it, smack the unit on a table top 2-3 times & re-try.
Let me know what happens. This DOES work on all Ford U-Haul trucks!

Jul 12, 2012 | Ford Expedition Cars & Trucks

2 Answers

Turn signals in my 98 Toyota Camry don't blink. And the the front passenger window doesn't work. Niether does the car lamp inside the car.


If just one window doesn't work, that is a separate issue, and probably a bad motor for that window. The inner door panel would have to be removed to investigate if it is the motor or a wire not connected.
For the radio and lights, all I could say is check the fuses.
For the blinkers try a new flasher. I've never heard this before, you must be pretty adept at it by now. Wiggling it to make it work means either the connection is poor or the flasher has a foot ******- Replace it!

Jun 17, 2012 | 1998 Toyota Camry

1 Answer

Hello, I have a 85' buick regal and I'm having


This is a tough one with out being able to see the wiring. i will enclose a wiring diagram for the complete lighting system.
You will need to locate the correct wirng and make sure its going to the correct light. Most times a bad ground wire will make the light do funny things like your car is doing. With the diagram i enclose locate the ground wire to the rear lights and make sure ground is good, even if you must cut old ground out and run a new ground to a good metal ground.
3_18_2012_3_37_44_pm.gif

Mar 18, 2012 | 1985 Buick Regal

1 Answer

97 Olds Bravada My brake & hazard lights don't


There are TSB's for this issue. I chased this issue for months on mine. Go find the TSB's, there's troubleshooting pointing out the faulty part. It could be, the brake light switch, the hazzard light switch itself, the multi-function switch. I had replaced all of these and still had the problem. Wiring that goes from the brake switch to up near the fender was shorting against the fender. I replaced the pigtail, problem fixed. Best bet to help you, is find the TSB's for this problem.

Jun 28, 2017 | 1997 Oldsmobile Bravada

1 Answer

No dash lights, power locks don't work, fuel gadge doesn't work, radio doesn't work.


all these circuits share some common fuses, check fuse #6 ( 10 amp ), fuse # 11 ( 15 amp ) & fuse #12 ( 10 amp ) all in the inside fuse box at the left end of the dash.....good luck

Jun 20, 2011 | 2000 Mitsubishi Diamante

Not finding what you are looking for?
2000 Ford Expedition Logo

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...