Question about 1995 Ford Windstar

1 Answer

95 windstar down shifts too soon

New speed sensor, wiring OK doesn't happed with OD off, possible PCM?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I'm assuming it's automatic... Try unhooking the battery for 30 seconds, This will reset the computer for the van. Hook up and take for a drive, the computer will adjust to the settings of the driver.

Might not work, but it's cheap affordable and if it does work then you save money.

Posted on Jan 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My 99 grand cherokee is making a buzzing noise from underneath when its in neutral or park


looks like problems are stacking up here.???
to get help with a buzz, we need to find it.
if its a black box. how may wires go to it and what are the colors of said wires. or look them up, in the schematics.
the speed sensor is bad. or the wires fell off the connector or the connector is corroded.
the 02 are bad, and same suffix, fell off, corroded or melted to exh pipe.
OD lamp is a OD lamp and a warning lamp the operators guide tells you that , it will say, scan the PCM for tranny errors, but you already did that? right and the speed sensor is dead, and no tranny shifts right with a speed (VSS) sensor dead. in fact it goes to limphome mode,

see 99 TJ here

http://www.jeep4x4center.com/knowledge-base/index.htm?utm_source=cj#service

Apr 06, 2014 | 1999 Jeep Grand Cherokee

1 Answer

1997 Mercury Mountaineer Overdrive flashing


When the OD light flashes it means the transmission has developed a fault. As to what the fault may be is yet to be seen without the system being scanned. In many cases the light indicates the transmission is slipping, you may not feel it slipping, but the computer (called the PCM) senses it through the internal speed sensors that measure main shaft input speed and shaft output speed in RPM. Other problems like shift solenoids can cause this as well. Another factor can be the transmission fluid is worn out, it should be replaced along with a new filter every 60,000 miles minimum.

Mar 24, 2014 | 1997 Mercury Mountaineer

1 Answer

I suspect my 1995 windstar may have a bad modulator valve the fluid level seems to go away with no apparent leak and now it takes off in 2nd gear and won't shift to 3rd or od and the od light on t


I've been doing research on these vans. Seems I remember that if the OD light flashes >>> fluid level is low. Also, I read where Ford wants you to overfill fluid so as to allow you to go around corners without loss of lubracation. By this time you may have melted it down and bought a Honda. I have a 95 Teal color and just in flawless shape, however it won;t go in reverse. Just follow the hood ornament and don;t look back...right ! ?

Feb 28, 2013 | 1995 Ford Windstar

1 Answer

Transmission is shifting hard and slow to pull on a 95 silouette also makes clucking sounds while accelerating


Shift suddenly become very hard. When going from park to either reverse or drive it slams into gear. 1-2 and 2-3 shifts are also harsh. All gears seems to work. Problem may be intermittent: Check TPS for smooth and linear electrical response over the entire range of motion. If not, replace.

Extremely harsh shifts from P or N, normal shifts at WOT: EPC (Electronic Pressure Control) solenoid failed. Easy fix in pan. Fix as soon as possible or hard parts will eventually break.

No 1st or 4th available; trans shifts 2nd to 3rd by itself in D or OD and locks the converter : ShiftA solenoid failed. Easy fix in the pan. Or a wiring problem from PCM to trans.. or PCM.

Car goes into gear but feels very sluggish like the brakes are dragging, but it will roll easily (starts out in 4th gear), you manually shift to 2 to get it moving, once it's moving you put it back in OD and the car shifts 3rd to 4th on its own and locks the converter at the appropriate time: ShiftB solenoid failed: Easy fix in the pan. Or a wiring problem from PCM to trans.. or PCM.


Mar 05, 2010 | 2002 Oldsmobile Silhouette

1 Answer

95 ram 2500 4x4 wont shift into od


ckeck linkage they might have undone iy and not put back in right place

Nov 02, 2009 | 2001 Dodge Ram 2500 Truck

2 Answers

2002 ford wind star o/d light started flashing after car wash


Two things that it could be.
1 - Look under the hood, there is a wire coming out of the master cylinder, there was a problem with some of the windstars that leak brake fluid, run down the wires and drip on the neutral safety switch, which would cause the light to come on.
2 - This one solved my problem. It could be the transmission valve body that needs to be updated or changed out. There are many issues with these valve bodies. Slipping from 1-2, OD light blinking, shift 1-2-3-2, late down shift from 3-2. I had all of these.
If you do some work on cars, then you should be able to change out the valve body yourself, with a torque wrench. I picked one up on ebay for $180 with shipping both ways, and took my about 2 hours. My Windstar never drove so good.
-fyi, The OD solenoid is inside the transmission.

Jul 03, 2009 | 2003 Ford Windstar

2 Answers

95 grand cherokee 4.0 4wd w/ auto trans. starts in 3rd gear, manually shifting to 1st only gives 2nd gear, won't shift down on own, won't go to OD & OD selector button does nothing, no light, no shift,...


it sounds like it is in limp in mode. try disconnecting the battery for ten minutes and reconnecting. this will reset the pcm and clear the fault codes. if it was just some sort of fluke if should be ok, if there is a problem it will return to limp in mode. if it wasn't acting up beforehand, it's more than likely an electrical, or computer problem, not a mechanical issue,

May 19, 2009 | 1995 Jeep Grand Cherokee

1 Answer

1999 ford windstar o/d light blinking


Sounds to me like it may be a sensor in the transmission. Possibly the shift seleniod or the od sensor itself.

Feb 07, 2009 | 1999 Ford Windstar

4 Answers

1998 Ford Explorer


there is an sensor on the speed odmeter cable on the side of transmission. it will kill thr overdrive and cruise control but not the speedometer. about $50.fixed 2 explorers that way

Jul 09, 2008 | 1998 Ford Explorer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

132 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...