Question about 1999 Cadillac Seville

2 Answers

Only cold air from heater

1999 Cadillac Seville/4.6L North Star engine.
Cannot get hot air from heater. Engine temp gauge reads half scale and radiator hose is hot. Also hose to heater matrix. But return pipe from heater is cold.
No fault messages displayed.
Is this a water pump problem or is there another cause?
Regards Mike.

Posted by on

  • redkite Jan 07, 2009

    Thanks Robert, spot on. I managed to back flush the heater core and cured the problem.
    And thanks to FixYa for getting me a quick respose.
    Regards, Mike.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 5,158 Answers

The heater core would appear to be plugged and need replacement if you are not getting hot hoses on the inlet and outlet of the heater core

Robert

Posted on Jan 03, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,913 Answers

Chec kconnection of heter power supply has some problem.

Posted on Jan 03, 2009

  • kishor khatri
    kishor khatri Jan 03, 2009

    chec kconnection of heter power supply has some problem.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Heater blows cold air and the temperature guage reads cold after driving for 20 minutes


Best case scenario is your thermostat is stuck open. When this happens the engine will take a long time to warm up and will never get up to full temp. Worst case could be a serious problem such as a blown head gasket. If there is no coolent in the engine the temp gauge will not register either.

Dec 15, 2013 | 1999 Ford Explorer

2 Answers

Heat gauge goes way up,then by reeving motor it will go down.blows cold air


Check out related help links with solutions to troubleshoot the problem:---
Click the link below:---
2004 Toyota Tundra: Oil Gauge and Temp Gauge Not Working?


http://howtobyme.blogspot.in/2012/05/2004-toyota-tundra-oil-gauge-and-temp.html

---------
Toyota 4Runner: Temperature Gauge Sensor http://technoanswers.blogspot.in/2012/04/toyota-4runner-temperature-gauge-sensor.html

-----------
Temperature gauge sits over half way mark? http://schematicsdiagram.blogspot.in/2012/04/temperature-gauge-sits-over-half-way.html
----------
Heater blows intermittently and temp gauge goes erratic?


http://technoanswers.blogspot.com/2012/01/heater-blows-intermittently-and-temp.html
------------- No heat on Oldsmobile Silhouette? http://technoanswers.blogspot.in/2012/02/no-heat-on-oldsmobile-silhouette.html
-------------
Temperature gauge does not move and no heat when heater is ON? http://technoanswers.blogspot.com/2012/01/temperature-gauge-does-not-move-and-no.html
----------
Temperature gauge keeps fluctuating up and down close to red? http://technoanswers.blogspot.com/2012/01/temperature-gauge-keeps-fluctuating-up.html
----------- Temperature gauge on the dash quit working on Pontiac Grand Prix? http://technoanswers.blogspot.com/2012/01/temperature-gauge-on-dash-quit-working.html
-----------
Dodge neon gauges not working? http://technoanswers.blogspot.in/2012/02/dodge-neon-gauges-not-working.html

---------
Heater blows cold? http://schematicsdiagram.blogspot.in/2012/02/heater-blows-cold.html

----------
Heat blows cold on drivers side and hot on passenger side? http://schematicsdiagram.blogspot.com/2011/12/heat-blows-cold-on-drivers-side-and-hot.html

-----------
1992 Lexus LS400: Engine overheats, Antifreeze out of reservoir and heater Blows Cold Air? http://whatisbyme.blogspot.in/2012/05/1992-lexus-ls400-engine-overheats.html

-----------
These details will help.
Thanks.

Nov 22, 2012 | 1997 Ford Taurus

1 Answer

1999 ford taurus se 155thousand miles, 3.0 V6


sounds like your thermostat is stuck open, if its takes a very long time for the engine to warm up and you get nothing but cold air from your heat then thats the first place i would start.

May 21, 2010 | 1999 Ford Taurus

1 Answer

The heat will not work it will just blow cold air


Since your blower is working and it is a heat issue,thats where we'll start,First thing is have you checked the coolant level in the radiator when engine is cold,make sure it is filled to top,next verify you have coolant in reserve ,Start your van and get it up to normal operation temperature,If your heat gauge on the dash works correctly it should be 190 degrees,Now lift the hood and locate the two heater hoses going into the heater assembly at the fire wall,Both hoses should be hot to hold on to,if both are hot and no heat inside your problem will be the blend air door in heater assembly.
if neither hose is that hot you need to replace the thermostat in the engine to get it up to 195 degrees.
if one hose is hot and one is luke warm then the heater core is blocked and to blame. hope this helps you.

Jan 05, 2010 | 1988 Cadillac Seville

1 Answer

My heater is blowing lukewarm air but my cold & hot gauge is fine engine is not overheating


just had same problem with 2000 Buick regal , the thermostat was stuck open just a little , just enough so coolant didn't get hot ,so heater doesn't get hot .. not good on cold mornings !! temp gauge never went more than a quarter, should have been almost half

Jan 05, 2010 | 1991 Toyota Camry

2 Answers

1999 Oldsmobile Bravada Heating Problem


when engine is cold remove radiator cap and check coolant level,sounds like it is really low and has an air pocket in it.

Dec 02, 2009 | 1999 Oldsmobile Bravada

1 Answer

Engine overheats when heater pipes connected


I think you could be right about there being air trapped in the system.
Or the heater core(radiator) is plugged.
Either way you need a pressurized radiator coolant pump to put the coolant in without air being trapped.
Although,i have seen it done by jacking the vehicle up high enough that the radiator was now higher than the heater core level, and then the coolant was put in.
But this is dangerous to try.

Jan 29, 2009 | 1999 Ford Escort

Not finding what you are looking for?
1999 Cadillac Seville Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...