Question about Chevrolet S10

2 Answers

I have a 94 blazer 4.3 it run bad I've change pretty much everything I could think of even to out the converter the truck starts up fine but when I give it gas it back fires and no power I disconn

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 58 Answers

Sounds like you may have a fuel injector stuck and putting in to much fuel causing it to back fire . try injector cleaner .

Posted on Apr 26, 2014

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 75,197 Answers

Time to see a dealer on this.

Posted on Oct 25, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SOURCE: 1996 ford ranger -3.0 ltr

Had a similar problem and it just ended up being the sensor for the EVAP controls.  Stupid I know but it fixed the rough idle. Error code was P1443. Worth a try.

Posted on Jun 12, 2008

emissionwiz
  • 75197 Answers

SOURCE: I went to Midas with

I have no idea, you will need to contact the dept of consumer affairs and file a compaint with them.

Posted on Nov 04, 2008

  • 195 Answers

SOURCE: my 94 s10 4.3 vortec was running very rough

Hello;
Make sure the distributor wires are hooked up and making a goodconnection at the base of the distributor. Also make sure the coil wire is fully in the socket. Make sure no wires got pinched for the relays. Hope this helps;
Thanks;
Rich
RPM Northwest

Posted on Feb 07, 2009

  • 14 Answers

SOURCE: O2 sensor problem, running rich. Please help

was the code for rich or lean? may try cleaning mass air flow sensor. it is in the air intake tube and has a flat wire connector. take out of tube and take four torx bolts out and clean with mass air flow cleaner or brake cleaner and put back in when dry. or it could be a bad wire on the o2 harness. look for chaffing or broken wires in harness by o2. also could be the exhaust system has a slight blockage. could also be some other things but try these first.

Posted on May 07, 2009

  • 3 Answers

SOURCE: 1998 Chev Blazer - hesitates, sometimes backfires, initial take-o

I fixed a van with the same problem. I had to reprogram the computer. It shuold be the same idea with your truck.

Posted on Jul 30, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 dodge 2500 ram4/4....71,000 miles. Run fine without slide in camper on it. Put camper on it and it run fine until it's gone maybe even as little as 40 miles then starts to loose power and bla


Has the exhaust ( catalytic converter) been check for proper flow? I would try a test pipe to by-pass converter and see if that helps. You used to be able to buy them, but a good exhaust shop can make one pretty quick, and then try it.

Feb 19, 2013 | Dodge Cars & Trucks

1 Answer

My 94 full size blazer starts and idles fine in park and in neutral. When I put the truck in gear and hit the gas, it'll start, then act like it wants to die. The Catalytic converter is off, I'm...


This could be a bad ground on the ECM. When it is in park it is open loop. When you put it in gear, the ecm goes closed loop with the oxygen sensors and with no ground it dies.

Jun 11, 2017 | Chevrolet 1500 Cars & Trucks

1 Answer

My 94 full size blazer starts and idles fine in park and in neutral. When I put the truck in gear and hit the gas, it'll start, then act like it wants to die. The Catalytic converter is off, I'


yes try getting the fuel pump pressure tested by a mechanic. the other thing it can be is the injectors are plugged try running some lucas fuel system cleaner.

Jan 19, 2013 | Chevrolet 1500 Cars & Trucks

1 Answer

So i've recently run into a problem where the bike


If it was a two cycle I'd say it was clogged exhaust ports. But you have a pretty exotic bike. So I guess it's a timing issue dealing with the exhaust Ox sensors.

Aug 30, 2012 | Cars & Trucks

1 Answer

Lincoln mark 8 starts but won't stay running


Yeah... particularly the O2 sensors.. running rich ... weak
and intermittent...

Been there... Ultimately gave up a took mine to dealer.
After floundering around (and seeing I had already been EVERYWHERE they were looking) for two weeks...

They found one of the catalytic converters was collapsing blocking the exhaust... (jobbed it ou to a local muffler shop).

I have still never identified an elegant way to diagnose this issue...

Got to a point where it would not run...

At that point (had I known) I would have liked to try to remove the catalytic converter at the header to see if it would actually run
(CAN'T... one piece)

Liquid wrench, & ear plugs would figure prominently in this process...

ELSE
do look up you muffler & cat prices BEFORE going to an EXHAUST SHOP ($$$$)...

I figure I paid $1700 where a mere $700 would have been pricy
(installed... I bet you can do better).

1994 LINCOLN MARK VIII 4 6L V8 Catalytic Converter RockAuto

Carnac the Magnificent

Mar 01, 2017 | Lincoln Mark VIII Cars & Trucks

1 Answer

Ok so i have a 99 chevy blazer 4wd and i've had


There is no one answer for a problem like this.

Jun 07, 2012 | 1999 Chevrolet Blazer

1 Answer

Blazer runs out of gas at half tank?


defective or missinstalled fuel pump would be my first guess.

Dec 07, 2008 | 2001 Chevrolet Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7772 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...