Question about 1997 Ford Escort

1 Answer

Fitted a new fuse box

Got no power to windscreen wipers heater blower and indicators everthing else works ok though when i put a tester on the fuse box no live to these 3 fuses yet its a brand new fuse box from the ford garage

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 280 Answers

Then the fault is deeper...
There are a few "fusible links" (Read BIG FUSES) under the bonnet, check if any of these are blown theyre under a flat-topped black or clear box (you know the type) , if you had a bad fusebox then these fuses are there to protect your car, check them out... They are 10, 20, 30, and 60AMPs I think, stocked at all auto shops.

Posted on Jan 21, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

5 Answers

Front windscreen wipers not working has been to the local garage and they cant find whats wrong with it they have tried the usual fuse motor and switch but no joy so any ideas please


Any good garage would check your fuse panel for a bad fuse. You might find a wiring diagram at Autozone.com for FREE. Just register your car and scroll down to the wiring diagrams.

Check either wiper motor by providing a ground wire and then put bypass power to the correct terminals. The new motor should be forced to work this way if it is any good. Then that would mean if it works, that the switch is not getting power or the switch is bad. Check for a bad wire from the switch to the harness. Do a power OFF continuity check on the wires running between the wiper motor and the switch to eliminate a broken wire.

Mar 15, 2012 | 2005 Renault Megane 1.6

2 Answers

Windscreen washers stopped working. all fuses ok,wipers working ok.front & back washers not working


Hi, First check that you have wash liquid in tank. second make sure that it will not freeze by putting alcohol in your mix of water and soap. You can buy it already mixed at most service stations. Check pump for corosion on contacts.
Good luck.

Dec 15, 2011 | Honda Cars & Trucks

1 Answer

Need to fit new windscreen wiper assembly, cant get new one to go back in


How to change a wiper assembly & repair wiper mechanism on 2001 Audi A6

First time you must diagnose why windscreen wipers going slow and/or stopping.
In order to find out the cause of wipers stopping you can try follows:

1. Carefully extract the wiper arms from their axles (two pieces). In some cases you need to use an extracting tool. Heed of the windscreen !!!
2. Disassemble the plastic covers from the bottom of the windscreen.
3. With the bonnet up you can start the engine, (transmission in "N" or "P" position and parking brake on). Now you must switch on the control lever of the wipers, and go to the engine compartment. If the wiper motor runs let the wiper motor running for a few minutes and switch off. Go to the step 4. If the wiper motor do not runs you must check first the electrical feeding of the motor. It is necessary to unscrew three bolts of the mechanism and disconnect the electrical coupling (difficult assurance). If the electrical feeding is OK you must replace the motor - steps 5, 6, 7. If not you must check electrical connections, the control switch of wipers and electric cables.
4. Now you must check the two bearings of wiper mechanism with your hand. In the most cases the left bearing is out of order (is very hot). This is the most encounter fault of the wipers running at Audi.
5. For have enough space to manipulation the wiper motor together with their mechanism you must extract the plastic cover of the engine computer box, and extract also the box screws. Then you can move slowly the engine computer box, just for a few milimeters.
6. You must disconnect the electrical coupling of the motor (difficult assurance), unscrew three bolts of the mechanism and extract together with the motor. You must move them slowly between windscreen and engine computer box until the wiper motor go out together with the mechanism. This is the most difficult operation!
7. Now you can repair the bearings, replace entire wiper mechanism or replace the wiper motor. It is not very simply, but it works.
Heed of the windscreen !!!
Refit all in reverse order.

Please do rate my response. Thanks!

Feb 15, 2011 | 2001 Audi A6

1 Answer

My Heater is not working in my 2003 Honda Element


First check and confirm the fuses related to heater in your car.Fuse #12 (40A) in the under-hood box powers the blower motor. Fuse #14 (10A) in the under-dash box powers the blower motor relay as well as the A/C compressor clutch relay, A/C condenser fan relay, power mirrors, radiator fan relay, recirc. control motor, and rear defogger relay.If the fuses are blown then replace the fuse and check.But if the problem is still there then Its a heater relay problem,.The blower motor relay is in the under-hood fuse box. It's larger than the rest, on the back side, labeled RY6.Remove the relay. With the ignition off, use a 12V tester to locate the constant-power socket, which powers the motor via the relay. Then with the ignition on, locate the switched-power socket, which powers the relay. Verify that neither of the remaining two sockets is powered, then with the ignition off use a continuity light to determine which is ground. The last socket goes to the motor. (If the continuity tester lights on both, it's probably because the motor has fairly high resistance, and you'll need an ohmmeter to determine which socket is ground and which goes to the motor.)With a fused 12V power source, power the relay's coil contacts and check the other two contacts for continuity. If the relay doesn't work, replace. But if the relay is also checked ok.then in that case the blower motor is faulty causing this problem.Make sure it has power at the connector and that the connector is properly seated. If the power and ground connections are fine, then the motor is bad. ----------- This troubleshooting procedure will help you to confirm the possible problem.Thanks.Helpmech.

Nov 12, 2010 | 2003 Honda Element

1 Answer

My front wipers arent working, could it just be the fuse? if so which fuse do i change as the list only has my rear wiper on it.


Fuse nr.31, F31, (25A) = Windscreen wipers
This fuse is placed on fuse box / relay plate engine bay 1, under bonnet in engine compartment area!

If the fuse F31 is OK.
You must diagnose why windscreen wipers going slow and/or stopping.
In order to find out the cause of wipers stopping you can try follows:
1. Carefully extract the wiper arms from their axles (two pieces). In some cases you need to use an extracting tool. Heed of the windscreen !!!
2. Disassemble the plastic covers from the bottom of the windscreen.
3. With the bonnet up you can start the engine, (transmission in "N" or "P" position and parking brake on). Now you must switch on the control lever of the wipers, and go to the engine compartment. If the wiper motor runs let the wiper motor running for a few minutes and switch off. Go to the step 4. If the wiper motor do not runs you must check first the electrical feeding of the motor. It is necessary to unscrew three bolts of the mechanism and disconnect the electrical coupling (difficult assurance). If the electrical feeding is OK you must replace the motor - steps 5, 6, 7. If not you must check electrical connections, the control switch of wipers and electric cables.
4. Now you must check the two bearings of wiper mechanism with your hand. In the most cases the left bearing is out of order (is very hot). This is the most encounter fault of the wipers running at Audi.
5. For have enough space to manipulation the wiper motor together with their mechanism you must extract the plastic cover of the engine computer box, and extract also the box screws. Then you can move slowly the engine computer box, just for a few milimeters.
6. You must disconnect the electrical coupling of the motor (difficult assurance), unscrew three bolts of the mechanism and extract together with the motor. You must move them slowly between windscreen and engine computer box until the wiper motor go out together with the mechanism. This is the most difficult operation!
7. Now you can repair the bearings, replace entire wiper mechanism or replace the wiper motor. It is not very simply, but it works.
Heed of the windscreen !!!
Refit all in reverse order.

Jan 13, 2010 | 2006 Audi A3

2 Answers

VW passat windscreenwiper not working


the switch is the most likely culprit i have had this befor ewasher works but wipers dont

Jul 19, 2009 | 1999 Volkswagen Passat

1 Answer

I need to locate the fuse box diagram the electrics dont work


Isimply put a new fuse box in the car, and check all the electric wire .

May 04, 2009 | 1998 Ford Escort

1 Answer

Stop lights,indicator lights,dash lights &wipers not working on 2002 mini.the car starts up &runs ok.


You either have a blown fuse or more likely the fuse box has corrosion where the fuses fit in and also on the spade terminals. This a very common problem and most people fit new fuse boxes and new terminals to the wiring.

Oct 30, 2008 | 2000 Mini Cooper

2 Answers

Intermittent windscreen wipers not working


I have solved the problem of the intermittent windscreen wipers not working. It did turn out to be the relay (R1 - engine compartment fuse box). As the main wipers continued to work it seemed unlikely to be this relay. However the relay has a number of connections and different wiper operations use these different connections. I discovered the solution by using relay R19 (heater blower) as this is the same type. It can be found in the passenger compartment fuse box. It worked. Also the blower still works with the old wiper relay as it seems to use only the same part of the relay as the main wipers did. However, I will replace this one just to be on the safe side. Hope this is useful.

Aug 12, 2008 | 2002 Jaguar X-Type

Not finding what you are looking for?
1997 Ford Escort Logo

130 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61292 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...