Question about 2003 Oldsmobile Alero

2 Answers

Rear defroster on 2002 alero does not work

All connections to the lines on rear window seem fine, light comes on and cycles off, just does not defrost

Posted by on

  • 3 more comments 
  • Anonymous Jan 12, 2009

    I have the same problem...and I just replaced the relay. I'm going to try the suggestion...thanks!

  • Anonymous Jan 18, 2009

    Where is the Fuse for the rear defrost?

  • mkosu04 Jan 19, 2009

    2004 alero - rear defrost doesn't work... I checked to voltage at the window. When the connectors are unhooked it reads 12 volts, when they are attached it reads 0 volts.

  • spzero_x Mar 13, 2009

    my car has the same problem,i need to change the module, is used in a different make and model? or is just for oldsmobile?

  • Anonymous Mar 25, 2014

    My rear defrosterdoes not work, does not light up. I doo not have theowmers manual, where is the use? Also none of the buttons light up in thesame row.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

I found this on another site... it seems like a credible post so I thought I'd share... I'm going to check it out next weekend.

"Just an FYI. The rear defroster issue is due to a bad Antenna Buffer Module / Antenna Module. The power to the rear defogger goes through a module that separates the antenna amplifier signal from the 12 volt power to the defogger. The defogger elements also act as the antenna. The module is behind the rear pillar right behind the rear passenger door. The inside plastic has to be gently pulled off, the seat needs to be folded down to get the lower part of the trim off. One screw at the bottom, unplug the wires... (two connect to the window grid, mark which one is which)... and the module is free.
The module may require re-soldering of the pins joining the main power connectors to the internal circuit board. If you feel you can do this (or have a friend do it for you), go for it... else get another module from the dealer to replace it."

This is the most credible of the several posts that I've seen talking about this module. I know its there... I saw it yesterday when I was working on the car.

Posted on Jan 19, 2009

  • bob obo
    bob obo Dec 26, 2013

    100% correct

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Oldsmobile Master
  • 6,674 Answers

Use a 12volt test light, or multimeter and ground it to good ground source near back door. Climb in with defroster turned on, and touch test light, or positive probe on meter to lines in back window (grid) each line, from end to end, when touched with tip of test light should light it up, or with meter should show 12 volts or more.

Posted on Jan 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2004. Why doesn't rear defroster work?


The rear defroster fuse may have opened but failure of the switch, the connection to the rear defroster grid, or the grid itself could be the cause.

Nov 07, 2015 | Honda Accord Cars & Trucks

1 Answer

Rear Window Defroster


There are only 3 things to look for, 1, is there power at demister checked with a volt meter on the wire connector on the back window. 2, is the earth wire connected again with a volt meter at the back window. and lucky last,3, check the ohms on the back window

Mar 20, 2015 | 2000 Oldsmobile Alero

1 Answer

My rear defroster stopped working. I press the rear defroster and i hear a click coming from the fuse area but the light does not turn on nor does the rear defroster work. Checked the fuse but the fuse...


Check to see that the wires that connect to the rear window are indeed intact...then you will need to look at the lines in the window to be sure none of then are broken...to go further, you will need a voltmeter...hook up the voltmeter across the two leads that connect to the window and turn on the system to see if it delivers 12 volts to the window...if so then the connections are either bad or the wires inside the glass are open

Jan 21, 2011 | Hyundai Motor 2004 Sonata

1 Answer

I have a 2003 Alero, replaced relay switch and fuse under the bonet for the rear defrost, all wires hooked up...no lines broke.. rear defrost button lights up , but rear defrost dont work. Are there any...


There is a connector going to rear defrost on the rear window. Disconnect this and check for voltage with defrost on. If this is good, check resistance for the connection to window. This will tell you if the electrical is working or the element is bad for the window if there is a open reading on multimeter.

Dec 03, 2010 | 2003 Oldsmobile Alero

2 Answers

When I turn on the rear defrost of a 1999 Olds Alero, the light comes on but the rear window does not defrost. What can/is causing this?


You should take a test light & check for continuity between the feel & ground at the window. If there is no power check the switch as it is probibably burnt out.

Dec 02, 2009 | 1999 Oldsmobile Alero

2 Answers

Rear defrost isn't working, replaced the relay and the fuse. The light comes on when you press the button but the defrost still doesn't work


check for power at rear wires if good look at defroster grid if any breaks auto stores sell a repair kit sometimes the grid breaks or cracks from cleaning window

Nov 12, 2009 | 2003 Oldsmobile Alero

1 Answer

2005 pontiac sunfire rear defrost doesn't work


sounds like a broken grid(the lines across the rear window) or thepower wire has broke off the window
to check this you need some FINE STEEL WOOL
turn the rear defrost on and move the steel wool across the grid not up and down slowly and litely if there is a break in the grid the steel wool will SPARK then mark it keep checking there could be more then one break
then you will need a repair kit
hope this helps

Nov 08, 2009 | 2006 Pontiac Sunfire

1 Answer

The indicator light works for the rear defroster on a 2000 Alero. However, the rear defrost does not work. Where do I start looking for the problem. The fuse has been replaced.


Have there been any children playing in the back window? Children are good at sctaching the small defrrroster grid lines. Look for small breaks in any of the lines, on break and the defroster wont work. these can be repaired and here are a couple of links if that is where your porblem is.

http://www.glasslinks.com/tips/defrost1.htm

http://www.popularmechanics.com/how_to_central/automotive/1272291.html#

Oct 26, 2009 | 2000 Oldsmobile Alero

1 Answer

Rear window defroster does not work. the light on the button turns on, then a few minutes later turns off, but the window does not defrost. Checked the connectivity on the tabs on the rear window and...


inspect every line/grid in the glass as an open circuit can be there...continuity must be present in the connectors at the window. There are products available to repair open spot(s) in grids on glass...

Sep 27, 2009 | 2001 Oldsmobile Alero

1 Answer

Rear Defroster Problem


1 st of all check all the fuses if all are good it may be the switch itself .......if you are referring to just the defroster ensure both connections are connected to th rear window if there are any breaks in the defroster lines as you will they sell a metal fill type repair kit not expensive and with the use of tape and this mixture you can easily repair the breaks in the defroster lines ........but first ck your fuses and connections maby determine with the use of a test light and check for power at both the switch and the rear wire connections for power to them otherwise it is most likely the switch

Sep 12, 2009 | 2003 Pontiac Grand Prix

Not finding what you are looking for?
2003 Oldsmobile Alero Logo

3,059 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

70387 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6879 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...