Question about 1999 Oldsmobile Silhouette

1 Answer

HEATER ISNT GETTING HOT,OVERHEATS,

IT WAS SNOWY AND ONLY HAD WATER IN RADIATOR STARTED VAN STARTED DRIVING NOTICED HEAT NOT HOT.AND IT STARTED TO OVERHEAT

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

You may have a cracked block if all you had in it was water...water expands when it freezes so id try to get some coolant in it to see if it dosent help

Posted on Jan 01, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When you run the van the radiator cap does not get hot


Sounds like a cracked head or blown head gasket

Mar 02, 2013 | 1998 Oldsmobile Silhouette

2 Answers

Engine overheat and no heat


Maybe your radiator is clogged.

Mar 12, 2017 | 2001 Nissan Sentra

1 Answer

Heater blows cold air


soun ds like heater core is plugged. did you try back flushing the system?

Sep 27, 2012 | 2005 Jeep Grand Cherokee

1 Answer

93 nissan quest overheats


Replacing the thermostat should solve your problem. If they fail they can cause it to overheat. Driving without the thermostat is doable as a temp fix but should not be done for a long period of time.

Mar 21, 2017 | Cars & Trucks

2 Answers

Car overheats when driving but not when stopped


For car running hot and overheating issues, I suggest to you go through this help links. Click this link below and go through the troubleshooting procedure to take care of the problems: ----Car runs hot? http://howtobyme.blogspot.com/2011/11/car-runs-hot-in-traffic.html
-----------All types of car overheating problems and troubleshooting?

http://technoanswers.blogspot.com/2011/11/all-types-of-car-overheating-problems.html
Car freeze overnight and started overheating while driving?http://technoanswers.blogspot.com/2012/01/car-freeze-overnight-and-started.html-----------Engine Overheats and heater blowing cold?

http://howtobyme.blogspot.com/2011/11/engine-overheats-and-heater-blowing.html

---------------------------

Car overheats and Air blows hot at idle?
http://howtobyme.blogspot.com/2011/11/car-overheats-and-air-blows-hot-at-idle.html
--------overheating? http://schematicsdiagram.blogspot.com/2011/12/buick-century-overheating.html
----------Car engine Overheats and transmission starts slipping?http://schematicsdiagram.blogspot.com/2011/12/car-engine-overheats-and-transmission.html
----------This details will help.Thanks.

Feb 12, 2012 | 2000 Pontiac Grand Am GT

3 Answers

I have a 1997 mercury villager van it started blowing cold air instead of warm out of the vents I replaced the thermostat and still having the same problem the heat only works on and off and now the van...


You have fitted the thremostat in the wrong way around ,the body of the stat goes in towards the engine and thats why you have a hot hose and a cold one the water isnt circulating,when you get it sorted then if still cold heater put some cardboard in front of the radiator to stop the air flow then it work right

Jan 07, 2011 | 1995 Mercury Villager

1 Answer

Hello Sir, I have replaced the radiator, radiator heat sensor, radiator cap, and all hoses. There are no leaks coming from the engine. I have also replaced the anti-freeze with BMW manufactured...


After the car is cool and has been sitting for a while, remove the radiator cap, have someone start the car, the coolant in the radiator should drop a little, and there should be movement, if there is no movement, let the car run for a while, with some systems it won't cycle enough to notice until the engine warms up. If there is still no movement, you likely have a bad water pump and/or thermostat.
Another method as a "just to be sure", drain the coolant overflow tank, and fill it with clean distilled water. Drive the car for a few days (carefully not to overheat it obviously, if the engine is getting too hot to drive normally don't do this test). If after a few days of driving the fluid in the overflow tank is still clear (water), then there is no circulation in the system.
It's usually best to start by replacing the thermostat, and then re-check. If that doesn't fix the problem it is most likely a water pump, or in very rare cases a plugged radiator or coolant passage.

Jul 18, 2010 | 1998 BMW 7 Series

2 Answers

I have a 1998 dodge caravan with 117k orig miles. it was a 1 owner van and i noticed a small smell of antifreeze after i get out of the van when it is hot/warm. nothing is leaking on the bottom emd like...


well it is 11 years old now so it could well be a rotten rubber water hose or a gasket showing its age,, try putting in some red food coloring in the rad that should stain where the water is leaking out of?
antifreeze will stink even from a pin hole,,,in the heater rad?

Oct 30, 2009 | 1998 Dodge Caravan

Not finding what you are looking for?
1999 Oldsmobile Silhouette Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

77499 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8826 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...