Question about 2006 Mitsubishi Lancer Evolution

1 Answer

Fuel pump problem evo 8

I have an evo 8 mr fq 320. There is no power going to the fuel pump. i have checked all fuses and checked the pump everything is fine just when i turn it on there is no power going to the pump. it may be a relay but i dont know which one the fuel pump relay is and where it is located can you help me with this.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 26 Answers

Check out the fuel pump relay may be bad.

Posted on Jan 01, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Holden barina fuel pump relay


Mr. ALI, you are in the correct way. Check first for the fuel pump fuse,if is not blown then go for the fuel pump relay. both will be find in the engine bay by the left side fuse and relay box.
Good Luck.

Apr 03, 2014 | 1992 Holden Barina

1 Answer

Truck fires but wont stay running....... but everything was working great 8 hours ago


check oil pressure switch
after prime 3sec. the run relay for the fuel pump passes through
oil pressure switch on block before run on fuel pump can carry
fuel pres to injector rail

Feb 22, 2012 | 1999 Chevrolet Silverado 1500

1 Answer

No fuel coming to the fuel rail. is it a relay, or fuel pump problem


  1. Check the power going to the fuel pump. If it gets around 12 volts when the key is turned to the On position, replace the fuel pump.
  2. If the fuel pump is not getting around 12 volts, check and replace the fuse for the fuel pump.
  3. If the fuse is fine, replace the relay for the fuel pump.

Feb 18, 2011 | 1994 Mitsubishi Expo

1 Answer

Bmw 320 e30 fuel pump not working no power to fuse pump fuse where do i check now


hi i have 325i 1989 i stoped all winter crank but doenst start i check no power on the fuel pompe and no spark on the spartplugs

Oct 30, 2010 | BMW 3 Series Cars & Trucks

1 Answer

93 gmc sierra 5.7 liter engine, injection carb, will turn over won't start, replaced fuel pump fuse, replaced fuel pump relay, replaced fuel pump inside gas tank, no gas flow to carb , gas gauge has always...


you say you replaced the fuse, but does the fuse have power? the gray wire at pump should have power when cranking, or for 2 seconds when turning key on. At fuel pump relay, put power onto gray wire, the pump should run if the wiring is good. if it doenst run then ck for power at fuse while power is on gray wire.

Oct 19, 2009 | 1995 GMC Sierra C1500

1 Answer

6 cyl 2.9. drove to work fine. turned off. 15


all i can say is check for power and ground at the fuel pump. get someone to turn the key to the on position (not crank!) and use a test light to see if you are getting power.

Aug 27, 2009 | 1987 Ford Ranger

4 Answers

Chevy s10 pickup fuel pump does not work


i have a 98 chevy s10 zr2 and we changed the fuel pump and aint gettin no power to the fuel pump checked the fuses and relay under the hood no power and the gauges inside are not working other than lightin up.are there another fuse link some where

Mar 18, 2009 | 1999 Chevrolet S-10 Pickup

1 Answer

Starting and running problems


check the fuel pump relays are operating fine this happened in my mates wrx and it was those relays would go first thing but once going relays seem to get a tad warm and then fail leave it 4 a day and it starts up again hope this helps

Oct 21, 2008 | 1994 Toyota MR2

Not finding what you are looking for?
2006 Mitsubishi Lancer Evolution Logo

1,207 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Experts

yadayada
yadayada

Level 3 Expert

78267 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22326 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8836 Answers

Are you a Mitsubishi Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...