Question about 1999 Chevrolet Silverado 1500

1 Answer

1998 350 Silverado will not start

Car will turn but not fire up. Have checked fuel pump, filters,fuses,pins and sockets on Relay. Fuel is going through the pipes fine but still will not start. Checked Oil as check Gage sign is showing. Temperture is normal also. Battery is not being drained, Have also checked the seals on the fuel pipes.
Car has been sitting for a while as someone borrowed it and said it just spluttered to a halt.
Petrol Gage shows half a tank but there was no gas, have put 20 litres in. Battry has also been charged,

What else would you suggest could be the issue.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 98 Answers

I believe that you have throttle body injection (TBI) Take off the air cleaner and have someone crank the engine look at the injectors and see if fuel is seen..Do you or have you smelled fuel when you were recently attempting to start truck???? if so this sounds like you are not getting spark....if you havent smelled fuel try priming TBI with gas and see if the truck fires...If so you know that problem lies in fuel delivery... On TBI systems it is very important that a conicle spray pattern is delivered by injectors for proper ignition if injector drips fuel into TBI this could cause a no start condition...To see if spray pattern is correct you can use a timing light if available...Hook it up as normal (red positive post and black negative post and pick-up on #1 spark plug wire) point light at injector and have assistant crank engine light allows visibility to spray pattern.....also check the fuel pressure regulator and vacuum lines....Hope this helped you..let me know if I can help anyfurther....Good Luck!!!!

Posted on Jan 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why am I not getting fuel to carb? New fuel pump, filter, relay, fuses. Van was running, shut off for a half hour, but will not start. Not getting fuel, replaced relay again, checked fuses again. Jumped...


Are you getting the ignition activated voltage to the relay? If you are, and you can jump across the relay to turn on the pump, I would say your relay is defective. If you know the relay pins for the ignition input and ground, you should be able to test it outside its plug in socket. You should hear it click when +12V and ground are applied to the proper pins/connectors for the ignition voltage. An ohm meter could be put across the supply +12V and fuel pump pins/connectors to really check the operation. If you think your relay is good. I would start checking for a bad +12V connection for your ignition supply, as well as the +12V that is switched through the relay. And the grounds to all. Use some contact cleaner on relay pins and socket. Ignition switch contacts can cause issues too. If it stays broke at least it should be easier to find than something that is intermittent. Based on what you stated, most of your troubleshooting should be at the relay socket (knowing which connectors do what) to isolate the issue to the relay, your ignition voltage, or your fuel pump voltage. After that it is knowing which step to take next.

Mar 02, 2015 | 1988 GMC Safari

2 Answers

Turns over will not start; will start with starting fluid, anything I should check before removing fuel pump?


yes, check ECI relay first. Fuel pump is a big job, and relay is cheap. Relay is probably in the engine compartment relay box. If you want to check the relay before replacing it, carefully open it and put it back in the socket. Then have someone try to start the car while you watch to see if the relays are closing. Let me know if you have questions.

dad6325.gif

Oct 22, 2010 | 1987 Chrysler Conquest

1 Answer

When trying to start, engine will crank over but will not fire. Seems to not be getting fuel. Also when key is first turned to run, fuel pump does not run for initial start up fuel. What may be the...


It could be a bad fuel pump, fuel pump relay, or fuel pump fuse. I would check them starting with the fuse, then the relay. Checking the fuel pump requires a lot of work and unless you are a savvy mechanic, you probably want to get it checked at a repair shop.

Sep 16, 2010 | 1999 Chevrolet Silverado 1500

3 Answers

No power to fuel pump car was running fine just quit repalced fuel pump no power to pump, car will start when spraying starting fluid in to intake, is there a fuse ? also replaced ECM, fuel filter,...


Check for 12 volts power at the fuel pump harness. If no power is going to the pump, check the fuel pump relay. Also, check the fuel pump inertia switch. Ford usually has it on either inside left or right rear trunk fenders.

Apr 09, 2010 | 1987 Ford Taurus

2 Answers

Car turns over fine just won't fire? where should i start? checked all plug wires and car does have gas, I am broke and without car, any help would be great.


check the ignition module fuse.if fuse is good.have car scanned to look for ignition control module fault codes or crankshaft sensor fault codes.by using or have somebody with diagnostic scanner to check for codes this way you wont spend extra money guessing.

Nov 26, 2009 | Oldsmobile Alero Cars & Trucks

1 Answer

Will not start, turns over but no go. Replaced in


First determine if spark or fuel problem. Try spray starting fluid. If it fires at all, then you know it is a fuel problem. Or try inductive timing light to check if there is spark. Seems most likely to be ignition module or distributor pickup. But you can take each in for free check at most parts places like Car Zone.

Sep 12, 2009 | 2001 Chevrolet Silverado 1500

1 Answer

Turns over, doesn't fire. No gradual problem, just didn't start this morning. No fuel to fuel filter, wondered where the fuel pump relay is, is there a fuel pump fuse, and where is the ground wire f


Yes it has a fuel pump relay. It's located somewhere in your Main Fuse box.It can be found under the hood near the Fiewall or the front end of the vehicle.

May 31, 2009 | 2002 Chevrolet Blazer

2 Answers

92 topaz fuel pump


listen at tank if pump starts when turning key to start car,if yes pump is bad, if no noise check pump fuse ,relay,power at pump

Feb 23, 2009 | 1992 Mercury Topaz

1 Answer

Car wont start,97 t-bird,got fire but car wont turn over


Check out the Starter Relay and Fuel Pump Relay in the Fuse Box under the Hood. If they are good you might Try Installing a New Fuel Pump and Filter.

Jan 23, 2009 | 1997 Ford Thunderbird LX

2 Answers

1996 silverado 5.7 vortec cranks but wont start. fuel pump, gauges, "idiot" lights, blinkers do not work. flashers and all the rest of lights operate. Just replaced coil and this happens


Had the same problem with my '96 Silverado with 350 Vortec. The truck would only crank. It would start if fuel was poured down the throttle body. Could not hear the fuel pump hum. Fuse was good, but could not hear relay click. Relay was good, Did some electrical wiring trouble shooting. Turned out that one of the connectors that clasp onto one of the pins of the fuel pump relay wasn't making a good connection, too loose. I just stuck a peice of wire into the connector and pushed the relay back in. Relay clicked, Truck Started. It's been more than 4 yrs. since I made that McGuyver fix. Still firing.

Jul 26, 2008 | Chevrolet Silverado 1500 Cars & Trucks

Not finding what you are looking for?
1999 Chevrolet Silverado 1500 Logo

445 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60541 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21927 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...