Question about 1997 Ford Ranger SuperCab

2 Answers

97 Ford Ranger 4.0L V6 Idles rough only when cold

Only when you first start it... and only on cold days. Replaced MAF sensor. checked for vacuum leaks, none found. Replaced 2 O2 sensors. bank one and 2 lean. Im running out of Ideas.

Posted by on

  • 1 more comment 
  • Ryan O'Rand Dec 31, 2008


    1. Check Codes-clean EGR exhaust tubes and replaced sensor

    2. Replaced Throttlebody vacuum hoses

    3. Checked Intake for vacuum leaks

    4. Checked Fuel Pressure

    5. Replaced MAF Sensor for lean codes and rough running

  • Ryan O'Rand Dec 31, 2008

    oh and yes I did replace the PCV valve

  • davidkay61
    davidkay61 May 11, 2010

    I replaced everything once, nothing worked, until I realized I didn't
    replace everything, the cheapest thing is what I forgot, the PCV valve.

    Did you try that already?

    I'd try it...$2.45. Also, the troubleshooting guides in the front of
    the Haynes manuals have helped me solve what I otherwise thought were
    simple things.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 22 Answers

It's the intake gaskets more than likely. I am about to do that job tomorrow on my Exploder. It has the exact symptoms as yours. It is a Ford customer care recall for the gaskets. I believe it's a 6 yr. 75,000 mile recall. The gaskets are only $15 dollars, worth a shot if you have all day. I have owned a lot of Fords and they are ****!

Posted on Feb 05, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 59 Answers

Orand

Ther is a air Idle control valve located on the side of the throttle body. unplug it remove it spray it and clean it with carb cleaner replace it plug it back in and you will be a Happy person again.

Lugnut61

Posted on Feb 01, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Error codes P0507 and P0102 after replacing MAF sensor


P0102: you need to make sure the sensor is clean; sometimes it get dirty as you are working on an old car. Check the voltage manually. Make sure there is no air leak near it

P0507: high idle... this sounds like a vacuum leak. get starter fluid and start the car. Spray around and check for change in car idle

Dec 09, 2013 | 1998 Pontiac Grand Prix

1 Answer

Had a question bout my mazda rx8 I was driving it one night it was running fine the next day went out and it won't turn over it takes awhile bit it finally starts and idles real rough and you give it...


Too many possibilities

Won't turn over is one problem -battery,cables,grounds,
starter,solenoid,etc

Idles rough-- vacuum leaks,spark plugs never replaced,
egr valve etc

Worn O2 Sensors
Dirty MAF Sensor
Old Fuel Filter

You have to go into a lot of technical detail & history
on your vehicle, for us to even guess.

May 23, 2011 | 2005 Mazda RX-8

1 Answer

1996 Ford Ranger 4X4 4.0L V6 Manual Trans. Replaced Catalytic and rear O2 Sensor. Throws a Code P1131. Sprayed Carb Cleaner along as much of Air intake as I could, no change in idle. Where should I be...


The first thing i would do is check the fuel pressure it should be 35-45 psi with key on engine off,because low fuel pressure will cause this code too.Also check fuel pressure regulator pull vacuum hose off and if there is any fuel in hose replace regulator.

Apr 22, 2011 | Ford Ranger Cars & Trucks

2 Answers

Rough idle


what was the code?

Jun 27, 2010 | 1997 Ford F150 Regular Cab

1 Answer

I have the same problem as stated here and don't


there are two common problem with that 4.0! throttle position sensor aka tps causes hi/lo idle and iac motor aka idle air control valve motor!

Mar 18, 2010 | 1993 Ford Ranger SuperCab

2 Answers

86 Ranger 4X4 2.9 fuel inj runs rough when warmed up


1988 ranger 2.9 runs great cold then after a few minutes when warmed up hesitates with intermittent black smoke from the tail pipe until i hit the the throttle then clears and will repeat this behavior...

Jan 26, 2010 | 1986 Ford Ranger 2WD

1 Answer

1994 ford ranger extended cab 6 cyl fuel injected 2 wheel drive automatic


This year of ranger had a few flaws, In one case, a break power booster was robbing the vacumm, you can test this by plugging it off and seeing the differance, but you will have limited brakes. This model year had a problem with a vacuum leak on the manifold. You can check these in many ways, but please don't use starting fluid. The rear of the manifold usually on the drivers side where it seals to the block.
Also, in 2 other cases a cracked head has gave me the same problem. It is caused from a loss of vacuum.

Jan 01, 2009 | 1994 Ford Ranger Supercab

2 Answers

97 ford taurus GL idles and kills when putting it in gear


check the vacuum hoses and make sure none of them are off and check the timing and also the drive belt

Dec 31, 2008 | 2006 Ford Taurus

Not finding what you are looking for?
1997 Ford Ranger SuperCab Logo

1,010 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60867 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...