Question about 1995 Oldsmobile Cutlass Supreme

1 Answer

Acceleration problems my car doesnt want to accelerate...it takes a long time for it to reach speeds of 25-30mph...there is a popping sound and it goes faster as the car goes faster...i can feel it in my pedal....what is wrong with my car......when im at a light the engine stumbles ...sometimes cuts off...

Posted by on

  • atburkhardt May 11, 2010

    (might be a dumb question but...) Catalytic converter?

  • kion sumerall
    kion sumerall Nov 10, 2013

    i had a car like yours and i had my timing chain replaced cause of slack in the chain, that fixed problem

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,920 Answers

It sounds like your converter is clogged

Posted on Dec 31, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

94 Ford Taurus popping noise on hard acceleration


What about the CV joints or the splined shaft that goes into the hub ?

Jul 05, 2013 | 1994 Ford Taurus

1 Answer

04 saturn L300


Next time the engine light comes on, get the codes pulled and get back to me

Apr 15, 2013 | Cars & Trucks

1 Answer

My 1997 Jimmy runs fine in idle when I take off the vechile is fine until it reaches 20 mph it won't accelerate and the rpms increase up to 3000 but no speed. What's wrong it's a 4 wheel d


Sounds like 2nd gear in the transmission is slipping. Cars usually shift at 15-20 mph from first to 2nd. First check the trans fluid.

Mar 17, 2013 | 1997 GMC Jimmy

1 Answer

When i accelerate 1500 rpm in my 1998 wrx ( ej207) it accelerate very good but when RPM reach 4500rpm the acceleration decrease ?


it sounds like a problem with your computer and will need to be hooked up to a computer with diagnostics info for wrx

Jan 14, 2013 | 1998 Subaru Impreza

1 Answer

I have a 2005 land cruiser. It has a slow acceleration and begins to vibrate from underneath as the acceleration increases. Can you advise please? Thanks


do you hear a loud hissing sound when you take off?
Could be the cat converter.

if not that, I've seen CV axles that caused poor take off and vibration.

let me know what you find.

Dec 11, 2012 | 2005 Toyota Land Cruiser

2 Answers

Boggs or runs rough during acceleration


sounds like you need a tune up or a coil is bad

Jun 11, 2009 | 2000 Ford F150 Flareside SuperCab

1 Answer

94 ford explorer problems with acceleration


first off, it's a ford. this sounds like a dealer issue and i don't know alot about fords. what i do know is that the cruise control in these vechiles have a default. moisture enters something, i forgot what, shorts out, then vechile accelerates on it's own, even with braking hard. as for not wanting to accelerate, sounds like a tranni problem. sorry i couldn't be more useful.

Feb 06, 2009 | 1995 Ford Explorer

Not finding what you are looking for?
1995 Oldsmobile Cutlass Supreme Logo

Related Topics:

255 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...