Question about 1998 Mercedes-Benz M-Class

1 Answer

1998 mercedes wont start when warm

Starts and runs fine cold but when warm it cranks and backfires but wont start

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 120 Answers

Replace your air filter and run a fuel system cleaner

Posted on Dec 31, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1997 E-320. Why doesn't it start?


Do you have it in N -neutral?

97 E320 Engine Won't Start - MBWorld.org Forums

mbworld.org/forums/e-class.../298412-97-e320-engine-won-t-start.html
May 15, 2009 - Hello ladies and gents, I bought a 97 E320 on February with 82k miles on it. ... hours I got out of work and try to start the car, it cranks but the engine justwon't start running. ... Drives: 1997 s320, 1997 e320 ... Cognomen is in homage to the late great Janis Joplin "Oh lord won't you buy me a Mercedes Benz". 2003 E320 cranks but won't start...
Oct 20, 2013
E320 cranks over but won't start
Mar 9, 2013
HELP....KEY WONT TURN ,CANT START CAR
May 17, 2011
W210 won't start.
Feb 13, 2008
More results from mbworld.org

1997 E320 Wont Start - PeachParts Mercedes ShopForum

www.peachparts.com > ... > Tech Help
Jul 2, 2008 - My 97 E320 wont start. ... 1997 E320 Wont Start ... So, we know that any engine won't start if it has no spark or no gas, so that is where we have ...

1997 E320 Trouble Cranking - YouTube

? 0:31
https://www.youtube.com/watch?v=AJu0k_rRb_o
Apr 4, 2013 - Uploaded by Roy Carlsen
1997 E320 Trouble Cranking ... 1998 Mercedes E Class (E320)Start Up and Review 3.2 L V6 - Duration ...

Dec 10, 2015 | Mercedes-Benz E-Class Cars & Trucks

1 Answer

Why wont my isuzu kb 280 dt rev


Sounds like one of two problems, it is not easy to diagnose a problem if you are not standing in front of the engine.

1. You might have a diesel pump issue, when it's cold there is enough pressure until it's warm then pressure drops as it expands. follow the fuel line to see if you have any leaks when it is warm or have the pump tested for pressure. sometimes you might also have a backfire noise due to fuel shortage but his might be very seldom or soft miss fire.

2. also check sensors for co and if you have a newer model, crank or cam sensor. they tend to stop working if they are warm, and if left for a while they start working again till it's warm again.

email me if you have not found the issue and I will see if I can help otherwise. ianjvr@ananzi.co.za

Aug 07, 2014 | 1998 Isuzu Trooper

1 Answer

89 K5 Blazer 350 TBI cranks but won't start... the rad hose blew, i fixed it then the next day it bogged and backfired, ran fine cold, but when warmed up it would lose power and stall when trying


Have you checked Google I found this hopefully it's not your timing or it may be flooded but doubtful have you tried spraying starting fluid into the intake while cranking it

Jun 01, 2012 | Cars & Trucks

2 Answers

93wrangler6cyl,auto when cold backfires, sputters until warms up


Check EGR value, clean or replace. Also PCV valve replace it is cheap.

Dec 16, 2009 | Jeep Wrangler Cars & Trucks

1 Answer

It cranks, but it does not run


Have you check the plugs, cables, cap/rotor ?

One thing you can try since it starts good in warm weather, is to ,on a cold morning, take a hair dryer and warm up the suspect part to warm weather condition. Then try and start the car. If it start ok you have probably found the weak part.

May 31, 2009 | 1991 Mercedes-Benz E-Class

1 Answer

93 s10 blazer wont start until after about 20 minute trying


does it make any difference if the engine is cold or warm ? if when its warm and it starts ok your spider part is not working properly or not plugged in right check it again .. check it by using starting fluid if it starts ok its the spider part bad .. did you replace it with new ? holler if you need more Jerry

May 12, 2009 | 1993 Chevrolet S-10 Blazer

1 Answer

Car wont start up right away


Crank or cam sensor probably as plugs bad plugs would start but miss the sensor will either give a start or no start condition and on 1 truck the crank sensor went out and it would run cold but miss like crazy when warm,I work in a chyrsler shop and have never seen that happen and even a scan tool didn't pick it up.

Mar 09, 2009 | 1998 Jeep Cherokee

Not finding what you are looking for?
1998 Mercedes-Benz M-Class Logo

Related Topics:

231 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

61037 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

164 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...