Question about 2000 Mazda Millenia

2 Answers

2000 millennia Heater problem

The car heater blows luke-warm air even at the highest setting, already replaced the thermometer, and also no heat comes up under the seats for the back. The fan works fine, and the lower temperature is ok.. what else can i check.. help!

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

Make sure your coolant fluid level is good, than check the valve that controls the amount of coolant that flows to the heat exchanger inside your dashboard, make sure it is wide open. (find it by having someone inside the car move the heat control from hot to cold and back while you are under the hood looking for the valve. Sometimes the cable that goes from the dashboard heat/temp control to the coolant valve comes off.

Posted on Jan 09, 2009

  • Norman Wagner Jan 11, 2009

    The valve I am talking about is not the thermostat. The thermostat controls the flow of coolant from the engine to the radiator, so that when the engine is cold the coolant circulates through the engine only until the coolant/engine heats up then it starts to open and allows coolant to flow to the radiator. There is a second smaller radiator inside your dashboard, also known as a heat exchanger, which supplies heat for the interior. When you adjust the temperature control on your dashboard you are actually opening and closing a valve that controls how much hot coolant is allowed to flow into the heat exchanger. So, when you put your heat control to the max hot setting the valve in your engine compartment should be wide open to allow the hot engine coolant to flow freely into the heat exchanger. If your fan blows air from your heating/cooling system but it is not more than warm then the valve may only be partially open. I have seen this problem before where the cable controlling the valve came off the end of the lever inside the dashboard leaving the valve in whatever position it was in when it broke. Some heating/cooling control systems use an electrically actuated valve and not a simple cable system. Either way, if you can locate the valve under the hood, experiment by moving the valve from wide open one way to the other to see what effect it has on the heat coming out of the dash. It is fairly easy to find the aforementioned valve by following the thick, hot, rubber hoses carrying coolant. The valve is usually near the firewall where the hose enters the passenger compartment. Good luck!

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 962 Answers

The thermostat do you mean ? If you drained the coolant and refilled , you have to bleed the coolant. You fill it with half mixture of coolant and half water. You replace the cap and start the car and run it for about 15 minutes. Turn off the engine and let it cool off. Then turn the radiator cap or bleed screw counter clockwise. You will hear a hiss . Remove the cap and refill it with coolant and water the same mix. Repeat the process until rediator is full of coolant.

Posted on Jan 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Heater temp on high only bows luke warm air after driving. A/C works just fine.Plenty of cold air from it


heater blows cold air idle chrysler 300 Questions & Answers ...

www.fixya.com > Forum > Tags
Find solutions to your heater blows cold air idle chrysler 300 question. ... blow warmair for a few mins then back to luke warm. i replaced thermostat ... HEAT BLOWSCOLD AIR WHEN IDLING ONLY GETS HOT WHEN START DRIVING ... About 15 minutes after driving the diver side vents start blowing straight cold air but the ...

Heater only works when pressing the gas? - DoItYourself.com ...

www.doityourself.com/...repairs.../459521-heater-only-works-when-pres...
Nov 3, 2011 - When I press the gas, the air from the vents is nice and hot. .... So am Idriving a car with a ton of problems, or could the power steering ... Just anotherquestion, when warmed up does the engine temperature ... When the heater is on and I'm not pressing the gas pedal, luke warm air blows from the vents.

Heater blows cool air when stopped and warm air while ...

https://www.reddit.com/.../heater_blows_cool_air_when_stopped_...

RedditFeb 12, 2014 - Heater blows cool air when stopped and warm air while driving 2008 Kia Spectra (self. ... just fine but appears to blow cool air when I was stopped at a stoplight. ... My temp gauge would also be pegged high when at idle / low RPM. ...thermostat only blocks coolant going to the radiator, and the heater core, ...Missing: 300m ‎luke

Why is My Car AC Blowing Hot Air? - BlueDevil Products

gobdp.com/blog/car-ac-blowing-hot-air/

Jan 27, 2016 | 2000 Chrysler 300M

1 Answer

I have a 2000 ford expedition and the heater blows air just not hot air or even warm air.. weve already changed out the thermostat, heater core, heater control valve and it still isnt working.. what could...


Check the vacuum hoses from the switch to the engine compartment. If you manually operate the heater valve on the firewall (follow the 5/8" hose) you will get heat.

Feb 08, 2011 | 2000 Ford Expedition

2 Answers

After replacing all heater hoses the heater does not blow warm air as well as it used to, . even when the engine is very hot the air is only luke warm, any suggestions appreciated.


You have a vapour lock. With engine running, disconnect heater line for a second or two to let air locks out & replace hose & retighten. Make sure the antifreese is topped off & have heat on high when doing this procedure. Good luck!

Dec 14, 2009 | 2001 Ford Taurus

2 Answers

I already changed the thermostat on my 2002 Jeep Cherokee and the heat actually seemed like it was working but now it is not blowing any heat at all. What could be the problem?


Air in the system or a clogged heater core. If it's air in the system, it needs to be burped. Click on my screenname, go down to Tips and Tricks, and follow the tip there on how to do so.

If the heater core is clogged, you'll need to blow it free. Follow the two heater core hoses from the firewall out to the engine. Disconnect them both, put one in a bucket, and use the blowgun attachment for an air compressor to blow into the other one. Then swap - put the one you blew into, in the bucket, and blow into the one that was in the bucket the first time. Reconnect the heater core hoses, and burp the system (again, follow the Tip instructions for that). Usually that will take care of it.

Dec 10, 2009 | 2002 Jeep Grand Cherokee

2 Answers

Air, no heat '98 Astro. No leaks, engine


It sounds to me that you may have 2 problems. 1). Air Lock in the Heater Core. 2). Inactive Heat Damper in the Plenum.

But since you state that the Heater Hoses do not get warm that is indicative of an Air Lock in the Heater Core. This is a relatively simple fix. It is best performed COLD but requires a method of pressurizing the Cooling System. All reputable Auto Parts stores Sell and/or Rent Pumps that temporarily replace the Radiator Pressure Cap for Leak tests and curing Air Lock. The Collant Level must be filled FULL then pressurized and then loosening the Highest Heater Hose at the Firewall so that Air and a Small Amount of Coolant escapes. Once all the Air has escaped tighten the Heater Hose Clamp, remove the Pressure Pump, Restore the Collant Level to FULL, re-install the Pressure Cap and Start the Engine. As it Warms up you should be able to feel coolant running through the Heater Hoses and they should become warm.

Dec 07, 2009 | 1998 Chevrolet Astro

1 Answer

Why would my 2002 Jeep Grand Cherokee only blow luke-warm to cold air when the fan is on high? First the heat went on the highest setting, so i used the second highest. Then it started to coll as...


Sounds like you need a blower motor resistor located down under dash on pass side next to blower motor. This is a comon problem and I have changed many of them. thats just the fan speed problem. Ive seen the blend doors break easily on those jeeps. thats inside the heaer core box and moves the flap from hot air to cold air. If it is stuck halfway -or mostly to cold- you may only get luke warm air. If they had the heater core out-maybe they possibly broke it.

Dec 04, 2009 | 2002 Jeep Grand Cherokee

2 Answers

My 2000 s10 chev does not blow hot air on heat.the heater core is clean.the ac works fine.when you move heater control to heat just luke warm air comes out with temp at 195


PERHAPS SOMEONE HAS REMOVED THE THERMOSTAT. OR MAYBE THE HEAT CONTROL VALVE IS NOT OPERATING IN FULL RANGE. HOPE THIS POINTS YOU IN THE RIGHT DIRECTION. PLEASE LET ME KNOW. THANK YOU FOR USING FIX-YA. AND THANKS IN ADVANCE FOR ANHONEST RATING

May 07, 2009 | 2000 Chevrolet S-10

1 Answer

Heater is blowing luke warm heat


Double checking, does fun shut off when switched to heat instead of defrost?

Jan 24, 2009 | 1993 Ford Ranger SuperCab

1 Answer

Heater does not blow hot air on full heat setting


the problem is caused by the motor that operates the air temp blend door motor in the heating ducts, it blends air between AC and heater core tro give desired outlet temp.

Dec 12, 2008 | 2000 Chevrolet Silverado 1500

Not finding what you are looking for?
2000 Mazda Millenia Logo

503 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...