Question about 2005 Chevrolet Cavalier

2 Answers

My Temp. gauge is broken

My temperature gauage has broke and is laying on my 10 mph speedometer so now when I'm driving 40mph it says I'm going 50 mph because the stupid temp. gauge is in its way and even when my car is off my speedometer has to just lay on the 10 mph mark because the other arrow is in the way. What do I do? Is it the cluster? And how much am I looking at paying for that if so? Can I just take the plastic off and move it by hand out of the way for now? I know I have alot of questions but hey I'm a girl and dont know to much about this kinda stuff. Help

Posted by on

  • 2 more comments 
  • Anonymous Jan 09, 2009

    First my temp gauge started going and now it's caused problems with the speedometer. Sounds like this is a common problem. If someone knows a solution please share!

  • Anonymous Jan 16, 2009

    I have the same problem. I don't know how to fix it. I took it to a mechanic and it was not acting up at the moment. He said that on all the computer tests my car is fine, but I know once I get it back and take a long drive it will happen again.

  • dennisdaisey Jan 18, 2009

    my temp gauge first went to 220, then on over till it effects the needle on the odometer. Also prior to the odometer would hang up off and on, finally fixed itself for about the fourth time. I have been to it is a part on the panel costing from 200 and to replace up 600 dollars.

    thinking about just finding a way to hold the temp needle out of the way of the odometer and putting in a single temp gauge I saw for 17 dollars at an auto parts store. Have never done that before, wonder if that can be done on this type of car

  • kstephen Mar 11, 2009

    My problem is with the fuel gauge and the temp gauge. Same issue. My son had the same problem with his Cavalier. I think we all need to try and go back on GMAC as this being a manufacturing issue and should be a recall.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I first filed a complaint with the BBB Autoline. After getting this on record and printing numerous problems with this vehicle and this issue off the internet, I approached my dealership in Memphis where I have my car serviced. Talk ONLY to the service manager.

He was very kind and agreed this should not be happening to a car just out of a warranty. They did a diagnostics test, made sure it was the cluster, and ordered this part. They replaced it for me for only $100 and this included the diagnostics and all labor. Press this issue, they will work with you.

Posted on Mar 30, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It must be a manufacturing problem, bc the same thing has happened to me. I have a 2005 Chevy Cavalier and the temp gauge has gone so far past the red that it rest on the 20 mph mark on the speedometer. It eventually went back down, but now it is doing it again. Idk what to do, but obviously if this is happened to others it should be the manufacturers place to fix.

Posted on Nov 20, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

A/c doesn't work, temp gauge doesn't work, speedometer doesn't work until it gets to 30 mph, and rough idle in the mornings. could all this be the result of a bad computer?


Very unlikely that it would be a computer problem, it does not control the A/C, or temp gauge. Sounds like multiple problems. A/C could be just low on Freon, if pressure is low, it will not turn on. Temp gauge and rough idle may be related, if temp sensor is bad, the computer wont know the engine temperature and thus not mix the fuel correctly. But there are many things that can cause rough cold engine idle, like dirty throttle plate, or bad idle air control valve. You did not say what engine you have, so this is just general information.

Mar 27, 2014 | 1999 Ford Ranger SuperCab

1 Answer

Car won't shift into 3rd and 4th. If you put it in neutral then down to drive it's okay but then goes back into neutral. Did a ****** filter change and no luck.


Year, brand, model would be helpful. You sure a speedometer cable is broke? If you have a newer car most of them have speed sensor(s). If a speed sensor is not working, it could be the problem with the shifting. Please rate my answer so I get points awarded.

Jan 18, 2012 | Cars & Trucks

1 Answer

I have a 2005 mustang and the gas gauge is all over the place and the speedometer is lower than nomal. It will read 30 mph when we are going 50. The temperature gauge is also incorrect. Is the problem the...


This is due to a problem with the gears in the gauges; there was a manufacturing defect that ford fixed in later years. The cheapest solution is to replace these gauges. I found a local mechanic that knew how to fix it, and did the job for $30 a gauge. I recommend checking craigslist for a local person, because this is a very common problem.

Jan 22, 2011 | 2005 Ford Mustang

1 Answer

Temp gauge shows high temp also makes clanking sound can't go faster than 20 mph or scared it will stop


definite overheated clanking anything from valves to rods burnt up possible head cracked/warped --driving vehicle when temp high/overheating even at 10 mph will cause internal damage even seize engine if not already

Jan 21, 2010 | 2002 Jaguar X-Type

1 Answer

Guages Quit


Check fuses first.

Oct 03, 2009 | 2004 Pontiac Sunfire

2 Answers

Temp Gauge went to high


It could be 3 things: Temp sensor, thermostat, or fan relay. Fans don't usually turn on until car has been idleing for a while. I first would change thermostat, then relay, then temp sensor. Coolant must be 50/50 mixture for water pump to have proper lubricant from antifreezer. Do not go any further than a 60water/40antifreeze mix

Jul 08, 2009 | 1999 Honda CR-V

1 Answer

The indicator light that give miliage/temp/ will not come on. 2002 dodge intrepid


Are you trying to say that the light that illuminates the temp gauage and the speedometer gauge don't come on? If so you need to replace the bulbs from behind the instrument cluster. If help needed reply on this post.

Mar 25, 2009 | 2002 Dodge Intrepid

1 Answer

2005 Mustang Speedometer Issue


This is pretty common on the 2005 Mustangs, it's caused by failing stepper motors in the instrument cluster, they control the movement of the gauges. There's a guide on how to fix them here - 2005 Mustang speedometer problem

Jan 17, 2009 | 2005 Ford Mustang

1 Answer

Speedometer jumps to 40mph right from start


i would look into the speed sensor located on the trans

Nov 14, 2008 | 1997 Honda Odyssey

Not finding what you are looking for?
2005 Chevrolet Cavalier Logo

531 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63801 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21990 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...