Question about 1998 Chevrolet Camaro

1 Answer

Camaro not starting...

I left my radar detector on in my Camaro for a week while I had it sitting in the garage due to snowy weather. I got in it to drive it and the battery was completely dead. I took it to get charged and load tested and put it back in my car. The car cranks fine but before I turn the key all the way to "start" my fuel pump should prime for about 2 or 3 seconds. Now when I turn the key it clicks on for about a second and then stops and I crank the car and nothing happens. I checked my fuel pump fuse and switched the relay around with another one and still I get the same thing. I even replaced the fuel filter. Any suggestions as to why this is happening?

Posted by on

  • Anonymous Jan 06, 2009

    I tried the key trick but no luck. Its a 98 camaro z28 with a fuel injected LS1 V8. I had my buddy hook up a scanner and all 8 cylinders have no misfires. The fuel pump just clicks on still even after I went and purchased a brand new optima battery just to make sure that there wasn't a short in my old battery. All the fuses are good. I changed my fuel filter. However before all this happened the car seemed to try and die at idle when I'd first turn it on in the garage. It bogged down and then would just die after dropping to like 500 rpms and this happened before my battery originally died and the car won't start at all now. I turn the key still and the fuel pump just buzzes on for less than a second when its supposed to prime for 2 seconds. However I tried using starter fluid and still no luck. The only thing that would happen is that the engine would start to crank twice as fast when the fluid made it down into the cylinders but no start. I wanna say its the fuel pump but a verification would be nice.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 91 Answers

Hello I think there might be a security setting on the camaro ill check into it if you give me the specs like yr and engine size but first i would go put the key in the drivers door lock and cycle the key to lock and unlock 3 or 4 times and see if that resets the security if it does please give me a good rating if it don't just give me the info i asked for and ill find you a answer ...

Thanks,
Steve

Posted on Jan 04, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My millage comes up with P1684 Code what does this mean


Sounds as though you may well have water condensation in your fuel lines that froze. Bummer. Or your fuel pump failed due to same type of freeze, or was on it's last legs before the final insult.

Mar 02, 2015 | 2002 Chrysler PT Cruiser

1 Answer

What do codes on Cobra radar detector mean?


Here are some answers:
if its like most, x means dont worry unless your in hicksville alabama and the
cops steal their radars off the grocery store doors, k and ka means cop
when L goes off, it\'s most definitely a cop. L basically means "You\'re already
screwed, hurry up and pull the radar detector off your window to lessen the blow
there is no Sa on mine, just S which means strobe for emergency vehicles. mine S
hardly ever goes off, the X however goes off all the time

Jan 13, 2013 | Cars & Trucks

1 Answer

My keychain remote wont start my car anymore i replaced the battery but it still doesnt work. do you know what the issue could be? and how i could fix it?


The remote may have come un-synchronised. (Due to a heavy knock or interference from a radio transmitter source. Like someones speed radar detector, or possibly when the battery went flat.)

You will have to consult your nissan dealer for information on the synchronising process. This is an involved process but easy enough to do yourself at home!

Jan 24, 2011 | Nissan Maxima Cars & Trucks

1 Answer

My 2001 Kia Sephia sluggishly turned over twice and then clicked when i tried to start it, no go. Is it probably just the battery, it is a few years old?


yes ,and now that it is colder outside a low or bad battery really shows up. Also are you sure no lights,radar detector,cell phone charger was left plugged in or on ? Dome light? I would go buy a new battery and replace if the battery is performing more poorly than usual. also keep in mind is all the connections clean and tight? what you can do is charge your battery up and go to a local garage and have them do a draw test (battery) and charging test on your car. takes 2-3 minutes and usually they don't charge. DEALER WILL. Maybe they will make you a little deal on a battery. Have those test before you spend 60-125.00 on something you might not need.

Jan 10, 2011 | 2001 Kia Sephia

1 Answer

Hello, I havent driven my toyota for 3 weeks because of the snowy weather and when I drove it yesterday I could hear a cracking noise when I was moving the steering wheel left and right. what that could...


Possible that the ice formed on the linkages are breaking up , possible that the links have got tight, the pneumatics have tightened. This is extraordinary weather and the fault might clear once the mechanisms works for some time.
If however you notice there is any change or concern in the steering or movements of the wheels , then you MUST jack up the car to have a look at the front suspension/steering sections.
Hope the weather changes for the bettter.

Dec 14, 2010 | 1993 Toyota Corolla

1 Answer

Left my 2009 Lucerne sit for 10 days while on vacation. Came back and had to jump it. Am told that is normal?


I ever take vacation for 3 weeks with car stays in garage. I don't need a jump start to use the car.
Your battery is start to deteriorated ( unless otherwise there is problem with your car wiring).

Nov 05, 2010 | 2008 Buick Lucerne

1 Answer

1991 ford f150 xlt lariat 300 strait 6 had an ignition problem bypassed with push button start off solenoid worked fine now its -15 and it won't start barely cranks tried 2 batteries what could be the...


Check all wires and switch used to wire the push button ignition. Make sure none have melted due to the stress from hard starting in cold weather. If a thick enough guage of wire was not used it will get hot and could melt.

Jan 05, 2010 | 1991 Ford F150

Not finding what you are looking for?
1998 Chevrolet Camaro Logo

150 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...