Question about 1994 Chevrolet S-10 Blazer

2 Answers

Rough idle and runs real rough driving. Alot of fuel consumption!

It all started when my fuel pump went bad. R/R pump and filter. Started running very rough again. R/R plugs, dist. cap, button, TPS, Coil, and new computer. Did not change. it is real bad when idling. Sounds like it is skipping or flooding out. Checked all plugs an wires, all good. OBD1 will not comunicate. Can not get codes. Fuel milage sucks!! Maybe 12 mpg. I was told that if the intake temp. sensor goes bad it defaults back to -40 degrees and floods the intake with fuel. Problem is, I try to look up intake temp. sensor for 1994 chevy blazer 2wheel drive with the 4.3 vortec I get no results. What is the problem???

Posted by on

  • Anonymous Mar 16, 2014

    I have a 4.3 vortec willnot start it floods out .when you pull a plug out and turn it over it blows fuel out the plug whole

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

If you cant connect to the PCU I would start there, check every single fuse, and grounds for the computer, If they are all good test with a know good computer!

Posted on Apr 09, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 98 Answers

Try checking fuel pressure regulator

Posted on Dec 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Rough idle stalling, only runs when pumping gas pedal


Either not enough air or fuel. Check the air filter and gas filter. Also could be the exhaust system Catalytic converter clogged. No air out, no air in.

Mar 09, 2015 | 1986 Chevrolet S-10 Blazer

1 Answer

91 Explorer 6cyl XLT standard is super hard to start, the engine sounds muffled when starting and while running, quickly overheated once it was running, looses power when pressing accelerator.


Could be a clogged catalytic converter. It could also be a bad head gasket allowing some coolant to enter the cylinders. Check for milky grey oil.

Dec 18, 2011 | 1991 Ford Explorer

2 Answers

Ford F150 engine backfiring, running/idling rough


I Have a 1999 ford f150 4.6 that back fires and is just running really ruff when idling alot of nack fire a sord of like a pulse going on what is my problem?

Apr 16, 2010 | Ford F-150 Cars & Trucks

1 Answer

Car idles rough in park also runs rough in overdrive


Sometimes a rough idle like that is a fuel filter. As you've already done the plugs and wires the fuel filter would be my next bet.

Mar 15, 2010 | 1993 Buick LeSabre

1 Answer

Drove 1991 gmc sonoma 1700 miles and now it wont start or idle...


check the play in the distributor,and check that the fuel pressure is normal

Aug 19, 2009 | 1991 GMC Sonoma

1 Answer

I have a 93 altima that will crank but will not start...about a couple months ago i went to my work and shut off my car. it was running fine when i shut it off.. when i came back out and started my car...


this year model is notorious for fuel related probs...check the remainder of the fuel system, injectors, and the fuel pressure regulator also verify that the fuel pump is actually running and getting the correct amount of power to the pump itself..... it may not be bad just not getting enough power

Jan 24, 2009 | 1993 Nissan Altima

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

576 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...