Question about 1993 Lexus Ls 400

1 Answer

Coolant prob the car runs good when its cold when it warms up the car spits and sputters then blows out coolant but cant seem to find were it is coming from the water pump dont look like it is damaged or any hoses.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 651 Answers

Try changing thermostat.

Posted on Dec 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my 1994 prrotoge run fine when the engine is cold but when it heats up it sometimes spits and sputters like there no power especially when you first take off


Check coolant temp sensor. This acts as the choke on FI engines and when they fail it can acts as if you stil have the choke on when engine is warm.

Mar 02, 2015 | 1994 Mazda Protege

1 Answer

Im having an very intermittent problem with my 1990 Mazda b2200 pick-up. it seems like when the engine warms up the engine begins missing(more like sputtering and spitting!) but it stops as suddenly a


The computer is not the problem. Could be a defective coolant temp sensor causing the computer to keep the engine running rich after it has warmed up. Check for OBD1 codes. Could also have an intake manifold air leak or defective EGR valve.

Jan 14, 2015 | Mazda Cars & Trucks

1 Answer

My mazda 1992 mx3 it runs great cold but after warm up it spits and sputters and runs rich can you help please what could it be


Hi,

This sounds like you have a faulty coolant sensor switch which is telling your computer that the engine is still cold.

Replace this and you should fix this problem.

Thanks

Jason

Sep 18, 2010 | 1992 Mazda MX-3

2 Answers

Runs good until warm


I would suspect fautly spark plugs.

Dec 03, 2009 | 1987 Nissan Pathfinder

2 Answers

My 1990 ford ranger when the motor is cold it runs fine but when it warms up it spits and sputters so bad it barley runs


Check the egr valve. Then the O2 sensor(s). When it warms up it goes into "closed loop" using the O2 sensors..if bad it will run lean or rich or hunt for both.

Oct 07, 2009 | 1990 Ford Ranger SuperCab

2 Answers

The engine seems to overheat and the internal heater blows cold


The problem is your coolant level has gone too low check and top up when engine is cold, you will see the marks on the expansion bottle, if prob persists there may be an airlock in the heater radiator. keep an eye on coolant level or you will have cylinder head problems.

Jan 03, 2009 | 1996 BMW 318

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lexus Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Lexus Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...