Question about 1994 Jeep Grand Cherokee

1 Answer

It wont start

The fan belt  got loose  white smoke  came out of  the  motor  and  i put it back together but it  just makes  noise  but wont  start and i just changen the main computer a day ago

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 128 Answers

Well it may have overheated
if this has happend your motor may have died
did you check the temp gauge while the belt was loose

Posted on Dec 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hey! I have a s60 2001 T5 volvo and I recently changed the head set gaskets and the turbine, since it was damaged and the smoke of the exhaust was white. Even thought we changed the turbine, it keeps...


Don't forget any water that got into the exhaust system will take a
while to burn out of the muffler,cat ,ect.
If the belt whines like a supercharger ,it's too tight.
Not sure about this
model but if it's an automatic and has a modulator valve,transmission
fluid burns white .

Feb 21, 2013 | Volvo S60 Cars & Trucks

1 Answer

Loose fan belt


It can be worn out fan belt or the fan is got dried up and needs lubrication.Inspect fan belt.
Check the help link mentioned below:----

Engine makes noise and Cooling Fan belt Breaks?
http://howtobyme.blogspot.com/2011/12/engine-makes-noise-and-cooling-fan-belt.html
---------

Dec 09, 2012 | 2007 Chevrolet Kalos 1.2

1 Answer

The fan on my 1998 durango will not work but the engine turns over could it be a spark plug


Your water pump is seized and will need to be replaced. The part behind the pulley that wont move is the water pump. It has probably been making a lot of noise for a while?

Let me know if you have any questions and thank you for using FixYa.com!

Feb 20, 2012 | 1998 Dodge Durango

1 Answer

Honda accord 1993, I have a problem when I get up to normal speed 50mph and let off of the gas I have a grinding noise. If I slow down by not letting off the gas by holding the brake on,or put it in...


I'll bet it maks the same noise backing up too the motormounts are loose enough to allow the fan belt drive to run into something. with the hood open and someone driveing the car have them put the car in gear and watch the motor move around ( it should move around a little) as they put the car in reverse and hold the brake so the car doesn't move lean or the gas and you should see where it's hitting and make the repairs or reconnect something that's falling off like the raditor fans, the hoses for the air conditioner or other belt drive conponants. If this doesn't find anything look at the drive axels and see if their covers and shields are all in place and not runnininto something

Mar 08, 2011 | 1993 Honda Accord

1 Answer

I have a 1991 mitsubishi 3000gt and it wont start. the motor turns but not sound of it even trying to start like turning over. i see the belts move but no sound as if its even starving for gas just belts...


http://www.fixya.com/cars/r7030578-engine_turns_over_but_wont_start

Here is a link to a tip I wrote nate. It sounds like your timing belt slipped a tooth or ten. Or it may be broken. Does the starter motor seem like its turning the motor much faster than it normally does? You say that you can see the external drive belts turning, if this is true then your starter is engaging correctly. If your timing is off, or belt is broken, the engine will not make compression. Put your hand over the intake while someone cranks it to see if you feel that intake stroke pull on your hand. Read my tip in the link above for lots more info.

Nov 28, 2010 | 1991 Mitsubishi 3000GT

2 Answers

When engine fan engages makes loud squealing noise


Either tighten the fan/drive belt or replace it .. it is loose ...

Mar 22, 2009 | 2000 Mazda MPV

1 Answer

Heater Fan Quit working without warning no smoke no blown fuse.


Oh no, say it isn't so. I'm in the middle of the same task on my 85 model. I just got my parts from IPD, which I hope is not the source of your parts. I would start with the fuses and check for a blown one. Make sure you check closely as they can have fine cracks that can get missed.

Any chance you have a loose wire? - with all that have to come out for the repair it's possible you lost a groundwire connection.

Write back as I will have questions of my own on how you got yours put back together.

Jan 05, 2009 | 1987 Volvo 240

Not finding what you are looking for?
1994 Jeep Grand Cherokee Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21936 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...