Question about 1989 Chevrolet Corvette

1 Answer

No heat no A/C

Have no heater or A/C blower and no raido checked all fues's and all good

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 151 Answers

Must be fuses. Check the ones under the hood as well. How are you checking fuses? Use a tester if nothing else turns up.

Posted on Dec 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a 2000 s 10 blazer heater doesnt work..but all fues are good and tried replacing swith in cab..no effect..but blower works just fine? Any ideas


Sound like a heater core, the heater core would be under your dash..Another sign of the heater core being gone, is you would notice the floor board being wet..It is possible that maybe at some point the floor board was wet and you didn't know here it came from and didn't give it another thought..But if the blower works..I would bet heater core...Or it could be a thermostate..check the thermostate first it would be the easiest.. and the cheapest..

Nov 20, 2014 | Cars & Trucks

1 Answer

1992 323 mazda want blow heat out


REPLACE THERMOSTAT.IF ALREADY DONE.CHECK HEATER BLOWER MOTOR SEE IF POWER GOING TO HEATER BLOWER MOTOR.IF YES BLOWER MOTOR BAD.IF NO POWER GOING TO BLOWER MOTOR CHECK AC AND HEATER CONTROL FUSE AND CHECK BLOWER MOTOR FUSE AND RELAY IF ALL IS GOOD CHECK SEE IF POWER GOING TO AC AND HEATER CONTROL SWITCH IF YES THE AC AND HEATER CONTROL SWITCH COULD BE BAD.

Nov 10, 2011 | 1991 Mazda 323

2 Answers

Haeter blower not working blower good fues good


How many blower speeds did you loose before the blower quit if any?please advise

Jan 03, 2011 | 1996 Chevrolet S-10 Pickup

1 Answer

Ford f 250 heater blower motor fuse number


The heater blower fues is number 107 and is a 40amp orange maxi fuse. The manual can be found below. Page 198 shows the fuse number, page 196 has the diagram of the fuse block.

2004 Ford F250 Manual

Hope this helps.

Zeppelinx12

Nov 24, 2010 | 2004 Ford F150

1 Answer

No heat, heater core is good,blower moter works


Check the operation of the heater control valve. If it doesn't open up no heat. If the cable moves the control on the valve take the valve off and check it manually. The lever may work but the valve still doesn't open.

Sep 30, 2009 | 2002 Mitsubishi Galant

1 Answer

2001 Dodge Durango 4.7L 4x4. A/C is on but no air


Check the resistor pack next to the air motor blower, after you check the fues's the resistor pack is most likely blown but to be sure turn it on to heat and try the blower motor if it still does not run remove the restior pack and look and see if they are burned out, it will look like a fues thats blown. Two 1/4 screws holds it on and has 4 or 5 wires in it. If you need more help please post here.

Sep 05, 2009 | 2001 Dodge Durango

2 Answers

I have a 1995 Toyota Corolla the blower to the


pull dash apart and check your switchs they might be dirty

Jul 13, 2009 | 1989 Toyota Corolla 2 Door

1 Answer

1994 Lincoln town car/ no fan control on ac and heat


I aasume you mean blower motor for heater/a/c system.

Does it work on hgih speed only? If yes, replace resister.

Is this manual a/c or electronic?

Here is circuit for manual. check these three fuses first. 1, 17 & 10 in fues panel behind dash or kick panel by driver's knee.

0ecd810.gif
If you have electronic, you may have a bad "blower motor speed controller". Get used at car-part.com. page with asterisk is lowest price. New at tascafordparts.com

Jun 16, 2009 | 1994 Lincoln Town Car

3 Answers

93 Cherokee Heater/Blower/AC not working


Remove the insturment panel cover right behind the radio, remove the switch assembly look on the back right hand side there is a black plug connection (5 or 6 prong flat). this plug is and will always be a problem with jeeps. somtimes when a raido has been put in, the plug can be pushed away and there you go no heat, no fan. it could also be vibration from going down a rough trail.

Dec 11, 2008 | 1993 Jeep Cherokee Country

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...