Question about 1989 Ford Aerostar Cargo

1 Answer

Sputtering wont start no power

My ford arrow star van 3.0 is actting funny it wont stay running or runs real poor

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Most likely a fuel filter problem. try takeing a rubber mallet {not steel} and pound on the bottom of the gas tank. this will sometimes dislodge whatever is clogging the filter screen. Your engine fuel injected and needs a certain amount of pressure to operate correctly. You can have a repair shop do a pressure test on the system.

Posted on May 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

95 chevy g20 van started to lose power while driving and began to spit and sputter


Ck your alternator output, should be between 13.8 and 14.2 volts, A bad alt will cause the battery to discharge when driving, Once voltage drops to a certain level (9.8 I think ) the ecm starts to shut down causing all kinds of strange problems, like running bad ,trans not shifting right, even the radio ! It happened to me in my 95 chev p/u

Jul 31, 2012 | 1995 Chevrolet G20

1 Answer

My van just wont crank. It has power, gas, and just had the fuel filter replaced. I listened for the pump and you can hear it. My question is why does it act like it wants to crank but acts like its out of...


does your ck engine light come on? check your fuses and relays first, in particular the auto shutdown relay, that relay supplies power to all the nessary components required to run the engine, if they are all good, ck for codes, a cam or crank sensor can cause a no start or poor run condition

Jul 24, 2012 | 1999 Dodge Caravan

1 Answer

1999 mercury villager sputtering real bad it started after we did a tune up cap rotor and wires, plugs. the van ran fine around town on short drives then we took a trip and now where stuck 16 hrs later it...


You have a bad cam sesnor in the distributor- for certain. Rich Porter on ebay has the best reman for $200. Guaranteed fix. 99 was famous for this, runs cold for 15 mintues then acts up and quits, tach usually jumps around too.

Go here

http://groups.yahoo.com/group/villagerquest/

Dec 19, 2010 | 1999 Mercury Villager

1 Answer

Cranks turns over...almost starts but sputters out...if i choke the throttle body it will run but barley


timing chain or gear common problem, my first one happened in a 1931 model a ford, have had many do that since, i just lost the timing chain in my 1988 ford van, barely runs, wont go....

May 21, 2010 | 1987 Jeep Cherokee

2 Answers

When i take my foot off the gas pedal my speed drops a lot and van acts funny what could it be


FUEL PUMP IF BY FUNNY YOU MEAN IT STALS AND IT FEELS LIKE IT S GOING TO TURN OFF .
ALSO TRY THE IDLE SENSOR

Apr 19, 2010 | 1998 Ford Windstar

1 Answer

Van has poor pick up after short time of running


Did you replace the fuel filter as well?

May 20, 2009 | 1996 Chevrolet Astro

1 Answer

The van starts right up but shuts right back off


you might have a regular key instead of a microchip key. the micro chip key sends the signal to the computer. If you have a regular key it will start and a couple of seconds it will shut off and do it over and over again.

Oct 12, 2008 | 2004 Ford Freestar

Not finding what you are looking for?
Cars & Trucks Logo

137 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...