Question about 1996 Chrysler Sebring

1 Answer

1996 sebring quits running

My 96 sebring quits running while driving ,no warning, wait a few minutes will restart may run for awhile may not . i dont think it is in the fuel pump rplaced it 2 years ago, the distributor last winter.

Posted by on

  • 4 more comments 
  • eherman Jan 19, 2009

    usually when it is cold i would slow down to make a minor turn and the lights will dim and then the power steering goes then the car dies and i have to coast to a stop! I restart it and go on my way but now it quit for good i got home pulled it into the driveway and turned it off the next day it will turn over but wont start like the fuel injector gave out and now i cant locate the fuel pump or relay or anything to try to unfreeze it!

  • ppoumele Jan 20, 2009

    My car just dies out when I'm on the road sometimes I'll wait a few moments and it will start again and sometimes its just dead. I've taken it to three auto repairs and they say they ran it and it runs fine. It only last not that long. Can you help me with this problem?

  • Anonymous Jan 21, 2009

    where is the map air flow senor located

  • duersondavid Feb 18, 2009

    my car shuts off when i drive it for a while a i have to sit and then it will start back up

  • da40niners Apr 06, 2009

    I have a 1995 Chrysler Sebring and it shuts off while driving but after a few minutes of waiting it cranks.It is not the fuel pump and i put a new crank sensor in it.What could it be?

  • stevenmholme May 15, 2009

    I have a 1996 Chrysler Sebring Convertable jxi with a 2.5 liter engine. I have retrieved: the erro codes: 12,61,17,43. Can you tell me what this means?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

We just had a similar problem with my daughter's car. We replace the Idle Air Control Sensor ($225 including diagnostic and labor). It is running great now. Hope this helps.

Posted on Jan 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Car quit running at red light


Your no start condition is either lack of fuel(doubtful since it used to restart) or no spark. No spark could be from a failed crankshaft or camshaft sensor.

Mar 29, 2014 | 1996 Toyota Camry

1 Answer

2010 venza stalls while driving


ever do the 60k mile tune up, stated in the glove box , operators guide?

Feb 09, 2014 | 2010 Toyota Venza

1 Answer

1998 dodge neon stalls after awhile wait a little bit then it will start and go for awhile then stalls again.


Not trying to highjack your post. I just bought a 98 neon sport, manual sohc 2.0. Im having the exact same issue i think, car will run for a while then tac drops to zero and it dies, 5-40 minutes later i can restart but i usuall only make it a few blocks and it dies again, wait again and it will restart. Did you solve this problem with your neon and if not can anyone give me more places continue to diagnose. It has new cam and crank sensors, fresh plugs, wires and coil, new battery. I got the car cheap, thinking of fuel savings but i dont want it to became a parts money pit.

Jul 22, 2012 | 1998 Dodge Neon

1 Answer

96 Ford Explorer gets sluggish after running for awhile


i had the same problem and it ended up being one of the oxygen sensors.

Jun 19, 2012 | 1996 Ford Explorer

1 Answer

My car keeps cutting off during driving


Sounds like a problem with the ignition module. If the car runs fine for a bit then quits,,,, and if you wait a few minutes it restarts,,,, replace the module.

Jul 12, 2009 | 1999 Ford Taurus

1 Answer

96 sebring fan not running when hot or runs constantly


I have a 96 sebring jxi convertible, 2.5 I don't have relays for the engine fans in the fuse box under the hood. I have a 40 amp(orange) fuse and it's marked RAD FAN Check that fuse.

Jun 05, 2009 | 1996 Chrysler Sebring

1 Answer

2004 sebring 2.7 engine, will strt when cold but not when warm


more than likely a bad crank sensor but not knowing if there are codes might also be a cam sensor,it is deffently a electrical componet problem hot soak of the motor will break down bad electrical sensors,

Jan 23, 2009 | 2004 Chrysler Sebring

Not finding what you are looking for?
1996 Chrysler Sebring Logo

Related Topics:

472 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chrysler Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

chargerhp
chargerhp

Level 3 Expert

813 Answers

Are you a Chrysler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...