Question about 1996 Toyota Avalon

1 Answer

Check engine light come on when started when started car runs rough car loss of power car missing not as bad on level ground when driving up incline car seams to loose more power and begins to miss and back fire car has not been over 40 mph and less then 50 miles driven in this condition

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 88 Answers

Check spark plugs. and igntion coil.

Posted on Dec 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2007 Impala 3.9l has bad issue. On cold start if you try to drive it has no power, spits and sputters and the rpm gauge quits working, warmed up for 10 minutes car runs fine


Going with power lose. Check the grounds. Main three are from the battery to engine, battery to body, and engine to body. I wold check for codes, even if the light is not on. There could be some pending.

Aug 02, 2015 | Cars & Trucks

1 Answer

Driving along lights dimmed, instrument panel died, loss of power then engine cut out & wouldn't start. Starts with a jump but when i turn key to heat glow plug, instrument panel goes mad


I assume there's a problem with alternator. Check the grounding to engine, check continuity of a positive wire between alternator and battery. the energizing voltage should be checked as well. Might be the bad connection between battery and vehicle body grounding. Diesel cars are sensitive even in a little loss of connection and rust in the connection points.

Feb 18, 2014 | Cars & Trucks

1 Answer

1997 Olds LSS: 3800 engine, 198 K miles. engine running rough, loss of power; black smoke was coming out from rear of the engine compartment.


Sounds like one or two of the many sensors may have failed,. Like everyone else said... scan it...good luck.

May 06, 2013 | Cars & Trucks

2 Answers

Misses badly when accelerating or under a load. shift out of overdrive on incline due to power loss


Have you checked for codes?

Any dash lights lite?

Any testing done so far?

Have to do something then tell us,can't
guess and don't have the car to drive.

You most likely have ignition issues,if the
engine is hot & your going up hills

It down shifts based on shift strategy & vehicle
speed & many pcm inputs from sensors

Could be egr issues

Do you ever do any preventative maintenance?

Nov 26, 2012 | Cars & Trucks

1 Answer

POWER LOSS ON 98 TAHOE


even though you may have had a intermittent issue check the pcm there may be a code that will help you when/if this happens again

Oct 15, 2012 | 1998 Chevrolet Tahoe

1 Answer

Car want pulls hills or any inclines vey well 2005


P0304 code is a cylinder 4 misfire. If the plugs or wires are bad it will cause a decrease in power. I suggest changing the plugs and wires and see if that helps.

Jan 24, 2010 | 2005 Kia Rio

1 Answer

Starting problem - 1999 Dodge Neon


ask the car mechanic expert

Oct 29, 2009 | 1999 Dodge Neon

4 Answers

TDI loss of power


check the hose on the intercooler and around the turbo, check for split on turbo and the intercooler hose not too soft as they can collaps while driving

Jan 07, 2009 | 2000 Volkswagen Jetta TDI

Not finding what you are looking for?
1996 Toyota Avalon Logo

298 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...