Question about 2000 Chevrolet Blazer

1 Answer

Wont cold start without starting fluid

2000 S10 Blazer will only start when its cold if I use just the smallest amount of starting fluid. It will then run fine. Sometimes at average speeds I get a pulsation up and down.

Posted by on

  • Anonymous Mar 28, 2014

    2002 duramax

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 26 Answers

Sounds like fuel filter is stopped up or fuel pump is going out

Posted on Dec 27, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car wont crank but will start


do a fuel pressure test on your fuel pump

Apr 14, 2014 | 2000 Chevrolet Blazer

1 Answer

2000 chevy s10 blazer cranks but won't start????


Check for gas or spark problem on the engine. Check that starting fluid does start the car for a few seconds before dying, indicating a fuel delivery problem, like a fuel pump or circuit to it.

If the car won't start with starting fluid sprayed into the intake, then the ignition system may be at fault, or engine timing.

Dec 12, 2010 | 2000 Chevrolet Blazer

2 Answers

92 S10 Starting Problem


The rod connects the ignition cylinder to the starter/ ignition switch on the bottom of the column.

Aug 13, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

1999 s10 security light is staying on truck wont


if you have a spare key try that sometimes a worn key will trip the security

Jun 13, 2009 | 2000 Chevrolet Blazer

1 Answer

Fuel presure but no start


its the fuel pressure regulator!!!!!!!!!!

Jun 11, 2009 | 2000 Chevrolet Blazer

1 Answer

93 s10 blazer wont start until after about 20 minute trying


does it make any difference if the engine is cold or warm ? if when its warm and it starts ok your spider part is not working properly or not plugged in right check it again .. check it by using starting fluid if it starts ok its the spider part bad .. did you replace it with new ? holler if you need more Jerry

May 12, 2009 | 1993 Chevrolet S-10 Blazer

Not finding what you are looking for?
2000 Chevrolet Blazer Logo

Related Topics:

389 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...