Question about 2005 Chevrolet Silverado 1500 2WD

1 Answer

90 chev 350 runs bad

My 1990 chev pu started running really bad and was barley able to limp it back to my shop. I changed the fuel filter, no change. I have another engine, complete, same year so I swapped the TPS< MAP and all other sensors and still no change. As bad as it runs the (service engine soon) light does not come on. Is it possible that the ignition module is the problem or maybe even the computer?

Vince Burden

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 73 Answers

The ignition module in those usually work or they dont. But on the 90 model years , you have to have a pretty evident problem for the engine light. I would bet 1 of 2 things. The oxygen sensor at the "y" pipe is out, or the catalytic converter or muffler is plugged .ok that was 3 things, tell me how that works out for ya.

Posted on Jan 15, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rarely used PU. Has code 41 too lean. Starts and runs fine 1st 1/2 mile.


Having owned and fixed many Fords, I have a few thoughts for you.

1- run some gas line anti-freeze through it, the methyl hydrate can clean a lot of crap out. 2- Fuel inject. / carb.cleaner. 3- new air filter. 4- new fuel filter. 5- It's not very likely, but if the other fixes don't work, you could do a rad flush, improper heating/cooling can do strange things. Also, smell the oil, if there's a gas smell that could mean a variety of things, some bad, some not. Hope one of these works for you. Grimm

Apr 11, 2015 | 1990 Ford F250

1 Answer

I HAVE A 1993 CHEV PU 350. IT STARTS FINE AND WILL MOVE FINE FOR ABOUT 15 MINUTES. WHEN I STOP AT A STOP LIGHT NO PROBLEM BUT IT FEELS LIKE ITS RUNNING RUFF. AS SOON AS I ENGAGE THE ACCELERATOR IT DIES. I...


TRY THE FUEL FILTER FIRST IF THE FUEL PUMP WAS GOING BAD IT WOULD STALL AS YOU PUSH ON THE GAS PEDDLE AND PUMPING THE PEDDLE WOULD NOT HELP FUEL INJECTION AND PUMPING THE GAS WILL HAVE NO EFFECT ON THE RUNNING OF THE VEHICAL

May 20, 2011 | 1993 Chevrolet C1500

3 Answers

1990 chevy silverado 1500 single cab. 180K miles. Last few days if the truck sits for 8 hours truck has a hard time starting up. Takes a good push on the gas to get running. Oil changes and fuel...


yes sounds like the fuel filter is clogged when push gas pedal put it in clear flood mood and resets the fuel system and starts over thats why it starts when push to floor creates back pressure sucks debri bottom of filter

Sep 25, 2010 | 1990 Chevrolet K1500

2 Answers

Ford 460 loses power then dies. Starts back up. Idles fine.


It sounds like you might have a clogged catalatic converter on the exhaust system.

Apr 23, 2010 | 1999 Ford Super Duty F 450

2 Answers

90 chevy lumina 3.1 v6, dies off after bout 4 blocks, if you let it sit for bout 15 mins it starts back up but dies off after a few blocks, changed fuel filter, fuel preshure is 40lbs while running stays...


have vehicle scanned, if you do not have a obd2 scanner. any auto parts store will scan for free. it may be a bad crank sensor. the car will stall at warmup and go into limp mode. it will set a code if bad. please let me know if this helps.

Feb 16, 2010 | 1990 Chevrolet Lumina APV

2 Answers

In all looses power while driving, turn off the key and back on and starts to run right again.


let me guess 305 and scottsdale?....could be silverado....

it sounds like your trucks fuel filter could be plugged.....when this happens you wont get enough fuel to the TBI and it wont have the necassary ponys in reserve.

"change the fuel filter" make shure that it is getting enough fuel/.....

if your ride does not get better.....it could be that your engine has lost compression.....due to worn cylinder walls and worn piston rings.

when this happens it starts eating the oil.....and will be powerless and smokey.......

try changing the fuel filter first..

....and you might try running some "RESTORE" engine treatment ......"BUT ONLY IF YOU ARE DESPERATE......IF YOU DONT FEEL CONFINDENT DONT DO IT"

hope this helps...

Jun 02, 2009 | 1990 Chevrolet C1500

1 Answer

90 lumina 3.1 not starting after filter replacement


Is the filter on correctly? and if runs yes there is a filter inside the tank to. also since the prior owner did nothing to this car could be dirt inthe lines or the tank as well.
check the air filter too.

May 31, 2009 | 1990 Chevrolet Lumina

1 Answer

Ran fine then next day all went to /


that sounds correct and its probably electric and in the tank. turn the key to the start position then listen for a small humming noise coming from gas tank if theres no sound then thats most likely the problem.

Jun 10, 2008 | 1990 Chevrolet Corsica

Not finding what you are looking for?
Cars & Trucks Logo

167 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...