Question about 1994 Chevrolet S-10 Blazer

1 Answer

Starts then quits

I have a 1996 C1500 4.3L that quit running so I replaced the fuel pump assy and filter since I could not hear the pump run. I then could not get it to start so I checked for fuel coming from the injectors and found none. I replaced theSPCI fuel injector spider with the MFI and it would start but run for no more than 10 seconds. I replaced the fuel pump relay and bought a fuel pressure gauge but could only get a reading of a few pounds when the pump ran to prime. I then tried a jumper wire on the oil pressure/fuel pump circuit but no change. I don't think the pump runs after priming but don't know where to look next. 1996 S-10 4x4 intermittent slugishness, changed fuel filter which was horribly clogged. Truck started hard then and leaked coolant; I was told it was because I used starting fluid, and the OEM gaskets sre plastic. Replaced the top end gaskets and fuel delivery "spider", and afterward, no fuel presssure on the rail. Could hear the fuel pump relay engage, but no start. Replaced the fuel pump and nothing.

Posted by on

  • yadayada
    yadayada May 11, 2010

    Have u tested the ignition switch fuel pump run circuit?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 47 Answers

Was there fuel pressure before you changed everything? It could also be the pressure regulator sticking or bad. When you crank it over and let off the key you should hear the fuel pump run for a couple seconds and then shut off. If it is doing that then I would be looking to see if you have likes hooked up wrong at the back of the engine or try replacing the pressure regulator.

Posted on Dec 23, 2008

  • terry phillips Apr 18, 2013

    i;ve done all that and checked lines. can hear pump.when i hit the switch goes to 60 pounds but immediatly falls to 40 - 0 lbs

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Vehicle starts runs for 1-2 minutes then quits, Starts right up. Fuel is being shut down.


Also what no one is mentioning is to make sure you have oil pressure, or that the oil pressure sensor is working, alot of newer vehicles run the fuel pumps off of them oil pressure sensor so if your vehicle stops pumping oil and lubricating, it shuts the fuel pump off to protect itself from damage or further damage

Apr 08, 2015 | 1993 Lexus Es 300

1 Answer

Chevrolet Cavalier 2004 quits running while driving down the highway.


need to check fuel pressure, not just listen for pump to run, also check reading on coolant temp sensor, but sounds like fuel pump /filter issue. just because you hear pump run doesnt mean its putting our right amount of pressure. also check for plugged catylic convertor

Aug 30, 2012 | 2004 Chevrolet Cavalier

1 Answer

The car quit running after starting. When I tried to start it again, it acts like it's not getting fuel. It turns over normally, but won't fire.


Follow air filter hose to injector prime injector see if it starts if you keep priming and it wont stay running replace fuel filter if that don't work you have a bad fuel pump.

Sep 14, 2010 | 1996 Lincoln Continental

3 Answers

1996 GMC Suburban - Quit Running While Driving, Will Not Start


Listen at the back by the fuel tank for a 1 to 2 second prime cycle whirr from the tank when turning the key to run position after it has been off for at least 10 seconds.
No noise means no running pump.
....and no noise means.....
Most likely it will need a new fuel pump....80%
Fuel pump relay 10%
Fuse or bad wiring 10%

The quick fix to get home is to crank the truck to create oil pressure to fire the pump......and while cranking WHACK the tank hard with a 2by4 or something like that....to jar the pump..... and it may start running long enough to get it somewhere to be repaired.
This works 60% of the time on a dead pump.

If you do hear a whirrr.....you most likely need a ignition module or crank or dist pickup.

Sep 27, 2009 | 1996 GMC Suburban

1 Answer

1996 blazer will crank when cold but will not start. I spray starting fluid in air cleaner and it starts right up. once it is warm it will keep starting. Have replaced coolant sensor but still have same...


This could be many problems. But here is one to try. Turn your key on and make sure your fuel pump runs for 3 seconds. It will hum then quit. If you do not hear the pump running with the key turned on, replace fuel pump relay. This may solve your problem.

Sep 25, 2009 | 1996 Chevrolet Blazer

1 Answer

My trucks starts but keep quiting


I see you say that you have a new fuel filter but did you try replacing the fuel pump??? If not you can check the fuel pump simply by turning the key to the ACC position (thats as far as you can turn the key WITHOUT starting the truck) listen by where you pump the gas in and try to hear a low sounding whine if you cant hear it then it could be your fuel pump is dead and needs a new one....or it might be going dead.

Mar 29, 2009 | 1996 GMC Sierra

2 Answers

Truck sometimes starts, sometimes quits after running


It sounds like you have a defective fuel pump or a bad fuel pressure regulator.

Dec 18, 2008 | 1996 GMC Suburban

1 Answer

Starts then quits


Try the ignition control module located under the distributor cap $30 - $60. This is one of two parts on this truck that will cause it to not run or shut down after running for only a short time. The other is the fuel pump I think it is safe to rule that out as your problem

Nov 16, 2008 | 1996 Chevrolet C1500

Not finding what you are looking for?
1994 Chevrolet S-10 Blazer Logo

280 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

63242 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...