Question about 1992 Oldsmobile Ninety Eight Regency

1 Answer

Car gets no electrical power at all...won't start or take a jump.

I was driving...and the power just cut off ...the car won't take a jump, turn over, or the lights and power accessorys won't works...i heard a pop when it cut off and was driving down a bumpy road...its possible a fuse or relay poppped but i don't have the owners manual to know what fuse goes where ...any answers

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 405 Answers

Check the fusable link at the starter solenoid by pulling on each on, if it fill rubbery and streches then it is bad. Check for voltage at starter to ground also. If you have power to your starter then I would suspect a fusable link. also next circuit to test woud be from switch to smal terminal on solenoid. You should get power when key is in start position. Hope this helps you

Posted on Dec 22, 2008

  • David Johnson
    David Johnson Dec 22, 2008

    I assume of course you've checked your battery. If everything else checks out I would suspect a bad switch.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My car cut off while i was driving. I heard a ticking noise that sounded like it was coming from the engine right before it stopped.


I think you might have a timing belt that might be braking if it doesn't start your timing belt jump good luck

Oct 03, 2015 | 2002 Mitsubishi Galant

1 Answer

While driving a 96 chevy astro mini van I heard a popping sound and then the engine cut off and won't start again. When you try and start it the engine shakes, why is this


Sounds like you timing has jumped. Set the balancer at the 0 mark. take the distributor cap off. The rotor button should be at #1 position or 180 degrees off that. Any other place , the timing jumped.

Mar 22, 2015 | 1996 Chevrolet Astro

1 Answer

My car won't turn on it was working fine last


Just because you charged the battery it doesn't mean it is any good. Modern sealed batteries fail; just as you described, fine one moment and then nothing, they go open internally.

Jul 19, 2013 | Cars & Trucks

1 Answer

My jeep would not start or even turn over but radio,lights all work


Any clicking noises? My first thought is lithe starter has failed. Typically if all the other accessories are working and the starter doesn't when you turn the key it's likely the starter. Usually an a single click is heard everytime you turn the key to the start position. If you heard a series of rapid clicks when you try to start you likely have a weak battery. A jump start may get you going.

I’m happy to assist further over the phone at https://www.6ya.com/expert/jeremy_d728a59f986299fa

Apr 11, 2013 | 2006 Jeep Commander

1 Answer

88 Mustang GT won't turn over unless I jump the starter relay.


Hi Kevin it sounds to me like your solenoid that is attached to your starter motor needs replacing had this with a ford cortina mk 5

Apr 10, 2013 | Ford Cars & Trucks

1 Answer

After jump starting trunk latch,sunroof,door locks and map lights won't work


when jump starting volvos turn the lights on this will stop the power surge from blowing fuses or relays that have stopped all your bits from working

Jul 31, 2012 | 2001 Volvo S60

1 Answer

I have 1997 buick century and i was stopped at a light and the car inside lights started flashing and the car cut off and would not start back. radio was working and would not take a jump. does nothing...


Check for power at starter solenoid on switch side (purple wire) should have 12-12.6 volts if you have power to the solenoid and it won't do anything then the starter is bad.

Apr 21, 2011 | 1997 Buick Century

1 Answer

I was driving and heard a pop noise and then my 97


could be the timing chain. Was it a pop or more like a ping . A ping could indicate a timing chain problem. The tensioner might have gone bad.
its not hard to replace for an experienced mechanic

Jul 05, 2009 | 1997 Pontiac Sunfire

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

1,712 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

Marvin
Marvin

Level 3 Expert

81423 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Jeffrey Turcotte
Jeffrey Turcotte

Level 3 Expert

8841 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...