Question about Jeep Cherokee

1 Answer

Changed flexplate was bad {used one} now wont run right at times .changed tep sensor helped then same .starts fine then at times misses .can accelarate fine .misses at steady speed .no converter on exhaust.was ok till changed flex plate if crak sensor bad why only act up at times?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    New Friend:

    An expert that has 1 follower.

  • Expert
  • 84 Answers

Could the flex plate be incorrect for your car, if the tdc sensor does not get the correct signaloff of the flexplate because of incorrect spacing, this would cause your problem.

Posted on Dec 22, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My '94 Explorer is playing mind games. I installed a new starter in July and it ran fine for a few weeks. Then all of a sudden it wouldn't start. The starter works, bendix and all, but most of the time it...


Replace the flex plate. I can guarantee, that if you turn the flex plate enough you find a spot or two worn more than the rest of it. Missing teeth will cause a bendix grind, But if the teeth on the flex plate come to a point or even close point. This will kick the bendix back to the starter. The spring in the starter won't hold the pressure.

Dec 30, 2014 | Cars & Trucks

1 Answer

Timming belts and OBD2 codes.


Its possible the gears are not on the right marks.
Have you checked cam timing since replacing the second belt ?

Sep 03, 2012 | 2004 Kia Optima

1 Answer

My 2002 Merc Sable is having issues starting. Sometimes it will turn over but it struggles, other times I have to try repeatedly to get it to start. When it miss fires it makes a loud ZZZZZZZ sound. I...


I believe by the way you describe it it does sound like STarter is freewheeling.....Automatics have a flexplate instead of a flywheel....Although it is a solid metal starter ring around a thin metal flexplate....More than likely the starter gear is spinning on the shaft rather than the FLEXPLATE or
FLYWHEEL if you prefer....I Have installed rebuilt starters that were new but didnt work ....
Having almost the same problem you are having...The metal on the starter teeth are very soft compared to the flexplate.....It will ZZZZZZZZ like you stated if the starter gear is torn loose from
a factory screw up....It does happen..I cant say which parts store has Bad parts but these stores are commonly everywhere...(IF YOU KNOW WHAT I MEAN)...NAPA has good parts but you are taking a chance with most that are rebuilt...But not all...
In the old days you had to shim starters to or away from the flywheel...IF YOU ARE OLD ENOUGH TO REMEMBER...I would disconnect battery and remove starter.....CHECK FLEXPLATE AND STARTER GEAR TEETH...It could be installed wrong...Some I have seen installed with the starter teeth pointed away from the FLEXPLATE by accident...But if it starts sometimes...It should definitely be the Starter teeth or FLEXPLATE teeth worn in different areas................
...........Hope this helps......................Metalpoet.........LEVEL II CHRYSLER TECH.

Apr 17, 2011 | 2002 Mercury Sable

3 Answers

Truck idles fine all the time. However, on the


did you change the wires?..and cap?...could also be a bad coil

Mar 09, 2010 | 1996 Chevrolet K1500

1 Answer

My 96 jimmy studders and does not want to change to the 4th gear when in drive,when in overdrive it wont change to 5th gear(overdrive)will the tps sensor do that


Make sure the engine is running right, sometimes they wont shift if the engine is missing or losing vacuum. Sounds like the computer system is sensing there is not enough torque to shift into the higher gears so it is preventing it. This could be caused by your engine not running right under load, bad gas, bad plugs or something that is causing your engine to miss under load

Mar 01, 2010 | 1996 GMC Jimmy

3 Answers

Golf gti mk3 2.0l (2E engine code) is missing !


its a valve sticking or a coil breakdown

Jul 09, 2009 | 1994 Volkswagen Golf

1 Answer

1996 Cobra Mustang surging or loping wont run right, missing


You should check the engine coolant temprature sensor (ECT).

May 31, 2009 | 1997 Ford Mustang Cobra

1 Answer

1993 wrangler starting problems


You have to find out if it has fuel and spark . One or the other is missing at the demise of the engine.

May 07, 2009 | 1993 Jeep Wrangler

1 Answer

1998 Intrepid random misfire


I have a 98 dodge intrepid with a 2.7. My car would run fine at times and then all of a sudden start to miss badly and the valves would rattle. The mechanic changed the cam shaft sensor and now it runs very well.

Feb 28, 2009 | 1998 Dodge Intrepid

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

201 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jeep Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you a Jeep Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...